PDA

View Full Version : kmplayer dont run avi files?


owerlord
2010-01-14, 14:51
i have kmplayer and i just dragged a .avi movie in n900 video
then i navigate to the file from kmplayer and it does not run it?? it runs the n900 mp4 trailer of 9 movie? but not my avi files why? =(

SubCore
2010-01-14, 15:00
avi file is not avi file.

kmplayer surely does support the avi container, but it depends on the actual codec used inside that container if it'll play.

try mediainfo (http://mediainfo.sourceforge.net/) to find out about the codec.

owerlord
2010-01-14, 15:15
avi file is not avi file.

kmplayer surely does support the avi container, but it depends on the actual codec used inside that container if it'll play.

try mediainfo (http://mediainfo.sourceforge.net/) to find out about the codec.

but MPplayer the avi files work but not in KMplayer?

SubCore
2010-01-14, 15:22
hm that's strange.
perhaps Kmplayer is distributed with a different version of mplayer than the standalone mplayer package. can't really help you there, sorry.

noobmonkey
2010-01-14, 15:25
i have kmplayer and i just dragged a .avi movie in n900 video
then i navigate to the file from kmplayer and it does not run it?? it runs the n900 mp4 trailer of 9 movie? but not my avi files why? =(

Overlord! you are becoming my favourite postee' hehe :)
I'm trying to be polite so please do not take this offensivly, but this has been discussed with lots of post. I found 2 just by searching for Avi.

Avi files are just files, but there are many different types of codecs. These codecs are the things that are/are not supported, not the actual file extension.

There is a codec pack in one of the repositories. But what i would suggest is looking through alot of the N900 movie threads, and following one of their walk-throughs.
Good luck :)

SubCore
2010-01-14, 15:26
@owerlord

when you have started kmplayer, tap on the menu bar and press "select player", mplayer is selected, right?
defautl is osso-mediaplayer, which comes with fewer codecs than mplayer.

btw, kmplayer does not distribute it's own version of mplayer, it just utilizes the one already installed.

owerlord
2010-01-14, 15:36
@owerlord

when you have started kmplayer, tap on the menu bar and press "select player", mplayer is selected, right?
defautl is osso-mediaplayer, which comes with fewer codecs than mplayer.

btw, kmplayer does not distribute it's own version of mplayer, it just utilizes the one already installed.

i want to wach movies with subtitles what i read KMplayer supports em? when im in KMplayer and try to select player my default is osso-media-server and i got another one that is npp? i dont have MPplayer as option?

owerlord
2010-01-14, 15:36
Overlord! you are becoming my favourite postee' hehe :)
I'm trying to be polite so please do not take this offensivly, but this has been discussed with lots of post. I found 2 just by searching for Avi.

Avi files are just files, but there are many different types of codecs. These codecs are the things that are/are not supported, not the actual file extension.

There is a codec pack in one of the repositories. But what i would suggest is looking through alot of the N900 movie threads, and following one of their walk-throughs.
Good luck :)

guh im so sorry ^^"

SubCore
2010-01-14, 15:49
i want to wach movies with subtitles what i read KMplayer supports em? when im in KMplayer and try to select player my default is osso-media-server and i got another one that is npp? i dont have MPplayer as option?

if you don't have mplayer as option, you have to install it. if it is installed already, try reinstalling (possibly KMplayer as well).

unless you can select "mplayer" as option there, KMplayer only plays what the default media player (osso-media-server) can play.

owerlord
2010-01-14, 16:07
if you don't have mplayer as option, you have to install it. if it is installed already, try reinstalling (possibly KMplayer as well).

unless you can select "mplayer" as option there, KMplayer only plays what the default media player (osso-media-server) can play.

where do i install it? :o

can you tell me the

Catalog name:
Web address:
Distribution:
Components:

ims till cinda noob with all this =)

SubCore
2010-01-14, 16:11
where did you install kmplayer?
both are in extras-testing.

you'll have to invest a little effort yourself, finding that package is not complicated.

owerlord
2010-01-14, 16:35
ok sorry im new to this so i have lots of noob questions ^^"

owerlord
2010-01-14, 17:11
now im only in

Catalog name: maemo.org extras-testing
Web address: http://repository.maemo.org/extras-testing
Distribution:fremantle
Components:free non-free

cant seem to connect? =( its hard when i dont know the repository thingy yet

SubCore
2010-01-14, 17:35
now im only in

Catalog name: maemo.org extras-testing
Web address: http://repository.maemo.org/extras-testing
Distribution:fremantle
Components:free non-free

cant seem to connect? =( its hard when i dont know the repository thingy yet

yes, that's the correct repo and the correct settings.

what does "apt-get update" (run as root in xterminal) say?
and you did uncheck "disabled", right? :)

Strutten
2010-01-14, 17:50
I have both extras and extras testing active, but Mplayer is nowhere to be found...

b666m
2010-01-14, 17:58
i think it's in extras devel
[insert warning here ^^]

i have to say that following is the best way to watch videos on n900:
1. install "mplayer"
2. install "extra decoders support"
3. install "SiB" (kmplayer imho isn't that good)
4. start SiB and go in your video-folder and there you go :)

SubCore
2010-01-14, 18:02
I have both extras and extras testing active, but Mplayer is nowhere to be found...

really?
according to the package page (http://maemo.org/packages/view/mplayer/), the latest version has been promoted to -testing last week.

perhaps the repositories are overstrained due to PR1.1...

Strutten
2010-01-14, 18:09
really?
according to the package page (http://maemo.org/packages/view/mplayer/), the latest version has been promoted to -testing last week.

perhaps the repositories are overstrained due to PR1.1...

I'm looking in Media and in all för Mplayer. Is the official name somehow organizes somewhere else or named differently? Otherwise I'll just check in again tomorrow.

chainreaction
2010-01-14, 18:11
It's there in extras-testing Multimedia at the very moment labeled as "Mplayer Movie Player (command-line only)."

owerlord
2010-01-14, 18:11
yes, that's the correct repo and the correct settings.

what does "apt-get update" say?
and you did uncheck "disabled", right? :)

"apt-get update" (run as root in xterminal) say what? : O
and yeah i unchecked "disable"

but now im updating my n900

owerlord
2010-01-14, 18:13
i think it's in extras devel
[insert warning here ^^]

i have to say that following is the best way to watch videos on n900:
1. install "mplayer"
2. install "extra decoders support"
3. install "SiB" (kmplayer imho isn't that good)
4. start SiB and go in your video-folder and there you go :)

does SIB support subs?

owerlord
2010-01-14, 18:18
omg after i updated my n900 when i go to app management and try to enter repos it starts to check updates and does nothing and says pls wait, if i push it to stop it i am at the list where my repos should be but they are gone and i cant add more!! ='(

whats going on? ='((

EDIT: i think i got it working

Strutten
2010-01-14, 18:21
It's there in extras-testing Multimedia at the very moment labeled as "Mplayer Movie Player (command-line only)."

It's really strange, becouse it's not there for me! I tried the update command in X-terminal also, but nothing brings the Mplayer to my software downloader!

b666m
2010-01-14, 18:29
does SIB support subs?

haven't tested it yet, but i think that mplayer takes the subs automatically.

it just has to be in the same folder and named just like the video, for example:

maemo-org.avi -> maemo-org.sub
(i don't know which extension mplayer recognizes)

with x or z you can adjust subtitle delay by +/- 0.1 second
with r or t you can adjust subtitle position up/down
(full instructions are in SiB under "Info")

just give it a try. if you don't like what you get just uninstall it. ;)

EDIT:
just tried the subtitles. works perfectly!
http://www.mplayerhq.hu/DOCS/HTML/en/subosd.html
just do it as i described above. ;)

owerlord
2010-01-14, 19:16
geez im getting tired of this =/

i can only connect to extras (it load fast) and "MPlayer" is not there for me dont know why?? KMplayer is there thou

i CANT connect to extras-testing or extras-devel! they only get me to wait message for ages doing nothing, if i wait long enough for "extras-testing" i get this message

"http://repository.maemo.org/extras-testing/dists/fremantle/release.gpg
connection failed [IP: is it ok to say the IP]]

where do i check wat FIRMVARE im on in n900?

EDIT: i got somehow in the extras-testing cause it shows up new apps. and i found MPplayer =) some aplication recurse some python is it safe to install? are the files in extras-testing all safe ? ^^"

owerlord
2010-01-14, 20:14
haven't tested it yet, but i think that mplayer takes the subs automatically.

it just has to be in the same folder and named just like the video, for example:

maemo-org.avi -> maemo-org.sub
(i don't know which extension mplayer recognizes)

with x or z you can adjust subtitle delay by +/- 0.1 second
with r or t you can adjust subtitle position up/down
(full instructions are in SiB under "Info")

just give it a try. if you don't like what you get just uninstall it. ;)

EDIT:
just tried the subtitles. works perfectly!
http://www.mplayerhq.hu/DOCS/HTML/en/subosd.html
just do it as i described above. ;)

cant find SIB in extras-testing?

b666m
2010-01-14, 20:57
cant find SIB in extras-testing?

http://maemo.org/packages/view/sib/ is telling me that SiB is only in extras-devel. even though it's in devel-rep i would say that it's quite stable - no problems at all on my n900.
maybe you could just enable the devel-rep for downloading SiB and then disable it again. (and you MAY NOT update other apps/programs when you have devel-rep enabled and it's telling you that there is a newer version)

owerlord
2010-01-15, 15:04
got it to work when i downloaded the install file of SIB to n900 and then installed it.

SIB is really good =)

b666m
2010-01-15, 19:45
update:

the player NPP is a flashplayer for flash 10.
you can add a URL in the list on the left and play it via npp. ^^