- Talk - Talk (
-   MeeGo / Harmattan (
-   -   Nokia & AEGIS open-mode (

jalyst 2012-01-13 17:26

Nokia & AEGIS open-mode
Starting this thread upon recommendation of javispedro...
The original at FMC has become somewhat outdated, given where everything's at now.
Thanks to wolke for the following summary of how-to's, & qole for modifications:
05/11/12: please also read this, which is not in the info. below

grab the flasher for your OS that says 'for Harmattan', e.g.:

install it, e.g.:
sudo dpkg -i flasher*.deb
-get your product variant code {most look like 059****} from the sim card tray
{mine, the malaysian 64 GB, is 059J238}
-{you can get NaviFirmEx here:}
wine NaviFirmEx/NaviFirmEx.exe
change server to: Nokia Care Suite
phone is n9...
-pick the latest-looking release that has your code
-copy the link location of the large file and wget it
emmc should have the word 'emmc' in it and most are ~1.8GB
e.g.: 2C899062_DFL61_HARMATTAN_20.2011.40-4.SEAP_EMMC_SEAP.bin
flasher is the other one and most are ~1.1GB
e.g.: DFL61_HARMATTAN_20.2011.40-4_PR_LEGACY_005-OEM1-958_ARM.bin
-rename them to firmware.bin or emmc.bin if you feel like it.

patched: {you probably want this}

both gave me the big scary warning on a malaysian n9 64gb.
patched appears to work out-of-the-box {no aegis, real root}.
unpatched wouldnt let me restart sshd.

rename it to 'openkernel' if you feel like it.
1) install the flasher app
2) get the firmware image {i rename it 'firmware.bin'}
you must always flash the firmware first, and then the emmc and/or the kernel.
{you can do the emmc at the same time as firmware}
3) get the kernel {i rename it 'openkernel'}, and/or the emmc {i rename it 'emmc.bin'}
4) turn off your N9
5) unplug your N9 from the usb so you dont start until you are ready
6) run the first firmware command below. wait until it says waiting...
7) plug in your phone via usb to start flashing immediately.
when one command finishes {it will say 'Success'},
IMMEDIATELY run the next flasher command.
if the phone reboots in between commands, start over or you will brick it. {i find that the phone reboots in ~10s}

NOTE: deletes apps, and a lot of settings {everything not in /home}.
does NOT delete DCIM, or anything else in MyDocs

*Nokia claims this voids your warranty*
flasher -F firmware.bin -f
flasher -F firmware.bin -k openkernel --flash-only=kernel -f -R

*Nokia is FINE with this.*
flasher -f -F firmware.bin -F emmc.bin -R

*Nokia claims this voids your warranty*
flasher -f -F firmware.bin -F emmc.bin -R
flasher -F firmware.bin -k openkernel --flash-only=kernel -f -R

2 lists of what's definitely working, & what's not or may not.
Thanks again wolke for this! (headings link to original -potentially more updated- posts)

List of things that definitely work:
the point of this is to illustrate that everything works, except the things that dont. if you havent seen anything that doesnt, dont worry.
01) phone/contacts/conversations
02) openvpn
03) gps/maps/drive/turn-by-turn-directions
04) ssh over wifi/usb/wifi-hotspot as root or user
05) vncserver {vnc-ing INTO the n9, not FROM the n9. havent found a vncclient yet}
06) wifi-hotspot {joikuspot. you have to run a terminal cmd first}
07) firefox {fennec v11~a1, no flash yet, but it could be coming}
08) camera {video, iso, white bal, flash}
09) tklock-both {power button unlocks lockscreen + homescreen}
10) things i compile in scratchbox
11) locally&remotely executable terminal commands to:
+customize launcher-buttons on home screen
+change profiles {silent/meeting/general}
+(un)lock lock/home screens {simulate power-btn short, long, and double press}

+Nokia N9 64GB Black 059J238 {malaysian}
+patched open kernel

Things that possibly aren't solvable, even with open mode:

1) big scary warning
we know about disclaimer-cal and /usr/share/osso/boot/rle, but removing these does not remove it,
inserting modified RLEs does not fix it.
flashing with --suppress-warranty-disclaimer does not fix it, nor does flashing emmc.

2) cannot downgrade firmware
i REALLY REALLY want to solve this problem. i think its worth exploring how to, e.g.: flash the very first version so that any arbitrary version can be installed. from what i can tell, the problem is 100% the flasher app. maybe theres another flasher app already? maybe some reverse engineering could be gotten underway to do so? this is not impossible to do, and theres nothing malicious about wanting to do it {e.g. to test previous versions}.
the sole purpose for stopping downgrades is to patch-up aegis holes, and the sole purpose for aegis to exist is so that businesses dont shy away from 'open platforms'. large corporations dont know how to do business in an environment where they cant abuse the endusers.

3) ~/.profile is read by the thing that starts up the xserver-ish monstrosity, and you can BRICK YOUR PHONE AND LOSE YOUR EMMC {photos, convos, contacts, etc} if you do something stupid to it.

4) /root/.bashrc is overwritten in a stupid way
silly bug, no lasting damage, easy workaround, what the hell is doing it and why?

5) chroot!
im surprised this isnt up and working. at least one person has it on an n950.

6) pidgin
libpurple and gtk+ are working, with vkbd support!
so where's ma pidgin. {im occasionally working on this one, but its a pain.}

7) thunderbird, claws-mail, SOMETHING
my only requirement for email be that the whole msg {headers, body, and attachments} of all messages be fetched both on a schedule and by demand, and permanently stored offline.
i dont need my reader integrated with my fetcher.
i dont need my writer integrated with my reader.
fetch/read/write are very separate tasks for me that i only occasionally do at the same time.

8) lock screen customization
you can add an icon by setting a gconf string. im led to believe you can also tweak style.
i want a count of my missed calls, texts, and emails-by-account, and maybe a smaller clock to save battery. i would also like battery percentage and stats

9) making the power button {and vol buttons?} run arbitrary commands for short/long/double
namely, double-press to toggle my flashlight.
it seems you can send arbitrary dbus messages in mce.ini, so this should be doable. however, i dont know how to toggle the flashlight with dbus; i use a closed source 'app' called PhoneTorch; its nice because you can just phonetorch/killall phonetorch from a terminal, which may or may not be necessary for this.

10) full vnc control
i want to be able to simulate touch-screen drags, or at least control the main interface.

soln: netview

uvatbc 2012-01-13 21:57

Re: AEGIS open-mode
I'm trying to figure out the downsides of the aegis-free kernel.
Not enough people mentioning their experience. I'd also like to know if it can be reverted back to stock kernel or even better: dual boot.

jalyst 2012-01-14 06:59

Re: AEGIS open-mode

Originally Posted by uvatbc (Post 1150291)
I'm trying to figure out the downsides of the aegis-free kernel.
Not enough people mentioning their experience.
So we've got relatively few apps now that are still causing problems.
If we can get them all working nicely, then hopefully the downsides will become non-existent.
Hopefully we'll get more brave souls jumping on board & then sharing their experiences here.


<SNIP> or even better: dual boot.
Apparently not.... :(
I think it was explained why in much more detail earlier in that thread.
But I can't recall it all now...

jalyst 2012-01-14 16:15

Re: AEGIS open-mode
Hmm, the folks chatting in the original thread don't seem interest in moving here.
At least yet....

kiiwii 2012-01-14 17:00

Re: AEGIS open-mode
hi @jalyst

I think people sick with the no-kia aegis strategy will be lead to that FMC thread by google... at least me was.

so, personally, I read through all that thread from beginning and got excited about what @joergrw and @javispedro and all the participaters have contribute the community. That's a record and sign of how the progress made.

so, open a new thread is nice.

But I recommend to do a brief summery or statics what that thread have achieved. and most important, if I was a certain linux user/administrator but not familiar with maemo/meego/harmattan before, I will definitely hate aegis... coz "root" dose not gain the SUPER power of the whole system.... hmmm that made what a angry bird I was :D

so, brief introduction/summary/statics will be nice. and what's open mode and why open mode clarified will be fine. coz seemed I didnot see maemo people here feel the no-kia aegis policy.

that's what i thought. cheers.

soleil 2012-01-15 01:15

Re: AEGIS open-mode
I'm interested in this open mode kernel too . But as a normal user I can just sit and wait for a stable realease. I also want to know something great to give me the motivation to uses this open mode. For example USB host mode with ope mode or power kernel :) Am I demanding too much ? :D

MFaroTusino 2012-01-15 02:25

Re: AEGIS open-mode
I followed the method of flashing and using opensh, but after reboot, I got the device malf error. Luckily, since I followed the guide in order to not touch user files, everything was there once i re-flashed.

Being open would help me a lot. Have tried to change access of system files, to allow user to run them, but aegis stops me everytime :(

jalyst 2012-01-15 06:48

Re: AEGIS open-mode

Originally Posted by kiiwii (Post 1150563)
so, open a new thread is nice.
But I recommend to do a brief summery or statics what that thread have achieved. and most important, if I was a certain linux user/administrator but not familiar with maemo/meego/harmattan before, I will definitely hate aegis... coz "root" dose not gain the SUPER power of the whole system.... hmmm that made what a angry bird I was :D

That's a good point....
If I have time I'll amend the OP with a brief summary of what open-mode's about, & why it's needed etc.

1st I need feedback from participants in the original thread, as-to-whether they're happy w/the location of this thread.
Maybe they don't want to bother with a new thread now, although I think javispedro's logic for a new one was sound.
Personally I think this is a better spot than anywhere at FMC, way more inclusive & way more eyes etc.

qole 2012-01-15 08:07

I have been happily running aegis-free on my N950 for several weeks now.
It is so nice to have access to the full variety of Debian apps, like a text editor and a VNC viewer...

I have had problems with the following apps, both of which were solved by replacing the aegisfs dirs with a basic dir.
- facebook app
- location / gps / maps app
I have to manually replace the dirs after each reboot, quite annoying.

I have had recent problems with Skype chat not displaying messages in the chat window. Still investigating that.

The other apps seem to be Ok with aegis dirs now that I've stopped messing around with them...

I want to figure out how to extract all of the files out of aegisfs directories before flashing to open mode, then after flashing, disabling the aegisfs mounts and copying in the files unencrypted.

PS good choice of forum for this thread! ;)

F2thaK 2012-01-15 08:25

Re: AEGIS open-mode
Can we "open" the N9?

All times are GMT. The time now is 08:10.

vBulletin® Version 3.8.8