maemo.org - Talk

maemo.org - Talk (https://talk.maemo.org/index.php)
-   Applications (https://talk.maemo.org/forumdisplay.php?f=41)
-   -   [M5] Neovim on n900 (https://talk.maemo.org/showthread.php?t=100202)

justmemory 2018-02-13 12:58

Neovim on n900
 
Hi All!

I happened to successfully install neovim 0.1.7-4 on my n900. You can find the details here.

jm

http://talk.maemo.org/attachment.php...1&d=1518526404

sulu 2018-02-13 14:50

Re: Neovim on n900
 
From your github:
Quote:

These are just repacked Debian Stretch installers (since building Neovim for the n900 always failed for me); installing them are working fine.

WARNING! Neovim depends on libc6 >= 2.7 but Maemo5 has only 2.5.1.
Actually, the armel stretch package formally only depends on libc6 >= 2.4 [1], so at least that shouldn't be a problem when just installing the Stretch package on Maemo with libc6 2.5.1.
Of course there might be actual binary dependencies in neovim that require a higher libc6 version, but if that's the case, you should file a bug report against the Debian package, asking for corrected dependencies.

btw, I don't know neovim, but the N900 is my only device where I prefer nano over vim because I find it hard to hit vi shortcuts without breaking my fingers.
Does this work any better with neovim?


[1] https://packages.debian.org/stretch/neovim

justmemory 2018-02-13 16:16

Re: Neovim on n900
 
Quote:

Originally Posted by sulu (Post 1541107)
From your github:Actually, the armel stretch package formally only depends on libc6 >= 2.4 [1], so at least that shouldn't be a problem when just installing the Stretch package on Maemo with libc6 2.5.1.
Of course there might be actual binary dependencies in neovim that require a higher libc6 version, but if that's the case, you should file a bug report against the Debian package, asking for corrected dependencies.

btw, I don't know neovim, but the N900 is my only device where I prefer nano over vim because I find it hard to hit vi shortcuts without breaking my fingers.
Does this work any better with neovim?


[1] https://packages.debian.org/stretch/neovim

Thanks for the correction, you are right of course.
The "needed" version of libtermkey1 and libuv1 depends on libc6 >= 2.7 and neovim depends on libuv1. I shall correct that on github as well.

Hmm... About shortcuts... I do not know nano the way I know (neo)vim - I find the latter(s) more suitable for my usecase; I do not find hard the shortcuts. I used to vim/neovim so I do not know the answer... :) And you can map shortcuts as well...

sulu 2018-02-14 09:30

Re: Neovim on n900
 
Quote:

Originally Posted by justmemory (Post 1541111)
The "needed" version of libtermkey1 and libuv1 depends on libc6 >= 2.7 and neovim depends on libuv1.

You could try to just drop the libc6 version check from the libuv1 package or rebuild libuv1 after lowering the required libc6 dependency in its source package.
Either result might or might not work properly, but I think it's worth a try.

Quote:

Originally Posted by justmemory (Post 1541111)
And you can map shortcuts as well...

Thanks! I'll try that.

justmemory 2018-02-14 09:52

Re: Neovim on n900
 
Quote:

Originally Posted by sulu (Post 1541126)
You could try to just drop the libc6 version check from the libuv1 package or rebuild libuv1 after lowering the required libc6 dependency in its source package.
Either result might or might not work properly, but I think it's worth a try.

I tried to lower libc6 dependency level at repacking libuv1 and libtermkey1; installation worked but of course nvim did not start because it was only the check that I tricked so yeah rebuilding libuv1 and libvterm1 would be a solution but as I'm not an expert (especially in this field) I do not know how to rebuild package against a given libc6 or anything else. But maybe I will try to find out :)
One other thing is that I'm in the same boat as you - n900 is my only device (home laptop is not an option as my wife and kids would "kill" me...) so all my development is done on chrooted maemo-sdk. Building things not always easy as sometimes there are packages that building is depending on that I cannot get work on the n900. But I shall try and we will see. Thanks for the suggestion.

sulu 2018-02-14 10:20

Re: Neovim on n900
 
I still have some Debian chroots on my Cubieboard2 for Easy Debian backports, where I could try to rebuild those packages for older libc6 versions.
So far I know that you'd need libuv1 and libtermkey1. Are there any other packages I should build?

Edit:
Did you use armel or armhf packages?

justmemory 2018-02-14 10:44

Re: Neovim on n900
 
Quote:

Originally Posted by sulu (Post 1541129)
I still have some Debian chroots on my Cubieboard2 for Easy Debian backports, where I could try to rebuild those packages for older libc6 versions.
So far I know that you'd need libuv1 and libtermkey1. Are there any other packages I should build?

Technically only libuv1 and libtermkey1 depends on libc6 >= 2.7 so I think for the first try it is enough to rebuild these and then see if the other dependencies and neovim can be installed and run.

Quote:

Originally Posted by sulu (Post 1541129)
Edit:
Did you use armel or armhf packages?

I used armel packages.

sulu 2018-02-15 09:23

Re: Neovim on n900
 
I'm sorry, I can't build those packages.
There is no explicit dependency on libc6 2.7 in the packages, it comes implicitely from the build system.
If there is a way to manipulate this implicit dependency, then I don't know it.

The alternative would be to actually build the packages on a Debian version that still had glibc <= 2.5. This would mean to use Etch, but the armel architecture didn't appear in Debian until Lenny, which already had glibc 2.7.

justmemory 2018-02-15 11:52

Re: Neovim on n900
 
Quote:

Originally Posted by sulu (Post 1541166)
I'm sorry, I can't build those packages.
There is no explicit dependency on libc6 2.7 in the packages, it comes implicitely from the build system.
If there is a way to manipulate this implicit dependency, then I don't know it.

The alternative would be to actually build the packages on a Debian version that still had glibc <= 2.5. This would mean to use Etch, but the armel architecture didn't appear in Debian until Lenny, which already had glibc 2.7.

I think you don't need to feel sorry :) Many thanks for you to tried this!

Then it remains this way... :)


All times are GMT. The time now is 10:37.

vBulletin® Version 3.8.8