View Single Post
terrencegf's Avatar
Posts: 221 | Thanked: 182 times | Joined on Jul 2007 @ Central Illinois
#234
Installing xmms on diablo

UPDATE (Aug 7, 2008): The maintainer of xmms has updated his program to better work with diablo. Thus, my xmms-compat.deb package is no longer necessary. I'm leaving the old text here for historical purposes.

The new preferred way to install xmms is to enable the new debfarm repository for chinook.

One-click method:



Power-user method:
Open Application Manager, then select the "Tools->Application catalog..." menu. Click the "New" button. In the new window that pops up, enter the following information.
Code:
Catalog name: debfarm new (chinook)
Web address:  http://p.quinput.eu/debfarm/
Distribution: chinook
Components:   user
Click the "OK" button, then click the "Close" button. Let the application catalog check for updates.

Then install "xmms".

------------------------------------------------------------

Old post follows:

Since some people have expressed problems getting xmms to work on diablo, I have created a llittle .deb which helps by doing some extra steps after a base install of xmms. I have tried this on a stock diablo install on my N800 and it seems to work. As with everything I do, YMMV.

(1) Enable the debfarm.free.fr repository for chinook.

One-click method:



Power-user method:

Open Application Manager, then select the "Tools->Application catalog..." menu. Click the "New" button. In the new window that pops up, enter the following information.
Code:
Catalog name: debfarm (chinook)
Web address:  http://debfarm.free.fr/
Distribution: chinook
Components:   user
Click the "OK" button, then click the "Close" button. Let the application catalog check for updates.

(2) Install xmms and xmmsctrl.
While still in the Application Manager, make sure you are on the "Main view". Click the "Browse installable applications" button, then the "All" button. Scroll to the bottom of that window. For each of the following packages, select and click the "Install" button.
  • xmms
  • xmmsctrl
  • xmms-skins (optional)
  • xmms-flac (optional)
  • xmms-mp4 (optional)
The first two are mandatory. The last three are optional. DO NOT install any more than these five at first. I have tested this procedure with these five packages only. Make sure xmms works before installing additional xmms components.

NOTE! Do NOT run xmms yet!

(3) Download my xmms-compat.deb and install it. This is a very small package I put together which does the following:
  • Installs an Application Menu .desktop item named "Launch XMMS" which not only launches xmms, but also allows for the de-iconification of xmms, AND the restoration of your previous playlist. This is important because the default version of xmms on maemo becomes hidden when minimized. Also launching xmms using the default Application Menu item ignores your previous playlist.
  • Installs /home/user/.xmms/eq.preset to give you some default presets (from WinAmp) for the equalizer. (Taken from here.)
  • Installs a baseline /home/user/.xmms/config which sets the font (so you can see text in the menus), sets the output plugin to eSound (so the volume slider works), and adds a "skins" directory to point to the skins installed by xmms-skins.
  • Updates the icon / font / application caches so you don't have to reboot to see xmms in your Applications Menu.

I have also attached the files included in my .deb in case you want to see exactly what is being installed. (I had to gzip them since the forum wouldn't allow me to upload them with unknown extensions.)

Enjoy!
Attached Files
File Type: deb xmms-compat-0.1-1_all.deb (8.2 KB, 460 views)
File Type: gz launchxmms.desktop.gz (197 Bytes, 360 views)
File Type: gz eq.preset.gz (872 Bytes, 313 views)
File Type: gz config.gz (926 Bytes, 324 views)

Last edited by terrencegf; 2008-08-07 at 18:30. Reason: New version of xmms
 

The Following 6 Users Say Thank You to terrencegf For This Useful Post: