View Single Post
Posts: 832 | Thanked: 3,365 times | Joined on Mar 2009
#3
Originally Posted by pablocrossa View Post
Maybe you need a newer locale-gen?? Also try this:
ln -s /usr/share/X11/locale/locale.alias /usr/share/locale/locale.alias

The file exists in our N900 (at least in mine), got it from here:
http://bts.grml.org/grml/issue655
Installing corresponding locales.deb contains working /usr/share/locale/locale.alias. And there are also something wrong with locale-gen (coming from new package)

echo en_GB.UTF-8 UTF-8 > /etc/locale.gen
locale-gen

Calls localedef -i en_GB -c -f UTF-8 -A /usr/share/locale/locale.alias en_GB.UTF-8
which updates file: /usr/lib/locale/locale-archive
But it should create new subdirectory instead (at least locale is looking directory), so running manually
localedef -i en_GB -c -f UTF-8 -A /usr/share/locale/locale.alias en_GB.UTF-8 --no-archive

Creates subdirectory: /usr/lib/locale/en_GB.utf8
And locale is still looking them at /usr/lib/locale/en_GB
Symlinking is enough

ln -s /usr/lib/locale/en_GB.utf8/ /usr/lib/locale/en_GB

-------
Summary (not tested fresh flashed)
Code:
dpkg -i libc6_2.15.90-maemo1_armel.deb locales_2.15.90-maemo1_armel.deb
localedef -i en_GB -c -f UTF-8 -A /usr/share/locale/locale.alias en_GB.UTF-8 --no-archive
ln -s /usr/lib/locale/en_GB.utf8/ /usr/lib/locale/en_GB
reboot
#english locale is working

Adding more languages to the Settings->Languages
Code:
localedef -i fi_FI -c -f UTF-8 -A /usr/share/locale/locale.alias fi_FI.UTF-8 --no-archive
ln -s /usr/lib/locale/fi_FI.utf8/ /usr/lib/locale/fi_FI
-> English and Finnish tested
----------
Glibc-2.15.90: So far I haven't found any crash issues, every preinstalled application can be at least started. I have no idea about speed or battery consuming.


Check screenshot: This glibc version is not fooled on scratchbox's host kernel version.
Attached Images
 
 

The Following 13 Users Say Thank You to AapoRantalainen For This Useful Post: