View Single Post
Posts: 168 | Thanked: 191 times | Joined on Mar 2013
#3
No ipv6, at least on grps, on wlan I have an ipv6 when connected at home but my network doesn't have ipv6 so I suppose it is a local ipv6 (as said I don't understand much of ipv6), and I'm not at home now to get the ip.

Code:
gprs0     Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          inet addr:10.127.47.xxx  P-t-P:10.127.47.xxx  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP  MTU:1400  Metric:1
          RX packets:2371 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1700 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:10 
          RX bytes:2679790 (2.5 MiB)  TX bytes:120760 (117.9 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:5935 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5935 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:381592 (372.6 KiB)  TX bytes:381592 (372.6 KiB)

phonet0   Link encap:UNSPEC  HWaddr 15-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          UP POINTOPOINT RUNNING NOARP  MTU:4000  Metric:1
          RX packets:73866 errors:0 dropped:0 overruns:0 frame:0
          TX packets:26775 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:29760428 (28.3 MiB)  TX bytes:1859874 (1.7 MiB)
When I do a nslookup I get also ipv6 address.

Code:
Server:    127.0.0.1
Address 1: 127.0.0.1 N900

Name:      google.com
Address 1: 216.58.214.238 bud02s24-in-f14.1e100.net
Address 2: 2a00:1450:400d:807::200e bud02s22-in-x0e.1e100.net
In /etc/resolv.conf I have 127.0.0.1 and in /var/run/resolv,conf.gprs0 I have 2 nameservers but only ipv4 addresses.

When activating dnsmasq log-queries I get a lot of querie[AAAA] before getting querie[A], so it is looking first for an ipv6 before asking for an ipv4.

As stated before, I don't really understand how ipv6 works and therefore I would rather disable it, as for now it is not really needed (don't have ipv6 enabled on any of my other devices and they work as they should).

Any idea how to avoid any interaction with ipv6 on the N900?

Last edited by Malakai; 2017-02-10 at 16:03. Reason: Typos