Thread: [Fremantle Maemo5] Neovim on n900
View Single Post
Posts: 293 | Thanked: 661 times | Joined on Aug 2011 @ suncity
Originally Posted by sulu View Post
From your github:Actually, the armel stretch package formally only depends on libc6 >= 2.4 [1], so at least that shouldn't be a problem when just installing the Stretch package on Maemo with libc6 2.5.1.
Of course there might be actual binary dependencies in neovim that require a higher libc6 version, but if that's the case, you should file a bug report against the Debian package, asking for corrected dependencies.

btw, I don't know neovim, but the N900 is my only device where I prefer nano over vim because I find it hard to hit vi shortcuts without breaking my fingers.
Does this work any better with neovim?

Thanks for the correction, you are right of course.
The "needed" version of libtermkey1 and libuv1 depends on libc6 >= 2.7 and neovim depends on libuv1. I shall correct that on github as well.

Hmm... About shortcuts... I do not know nano the way I know (neo)vim - I find the latter(s) more suitable for my usecase; I do not find hard the shortcuts. I used to vim/neovim so I do not know the answer... And you can map shortcuts as well...

Last edited by justmemory; 2018-02-14 at 08:28. Reason: Correcting libc6 dependency information

The Following 3 Users Say Thank You to justmemory For This Useful Post: