View Single Post
Posts: 173 | Thanked: 85 times | Joined on Dec 2011
#4
As I mentioned above, uninstalling and reinstalling the developer-* packages from the settings/applications menu did not help .

So, I went to terminal, deleted the sshd.disabled file and thought that reinstalling just openssh-server should fix it. So I did "apt-get remove openssh-server" . And to my surprise, after it uninstalled that package, the phone also killed the dev-mode automatically, and the terminal/sdk icons were gone.

The I re-installed dev-mode by enabling it form the Settings GUI, and this somehow got back the SSH server .

This is totally unexplained behaviour! I am used to some sort of predictability in linux systems, coming from using Fedora/RHEL a lot.

But all is well that ends well.