Thread: Devuan?
View Single Post
Posts: 3,036 | Thanked: 12,656 times | Joined on Mar 2010 @ Sofia,Bulgaria
#6
Originally Posted by pythoneye2 View Post
for u-boot select u-boot console then type run sdboot.
username/password: root/toor

I couldnot get wifi too work, despite copying wl1251-fw.bin and wl1251-nvs.bin to /lib/firmware/ti-connectivity, i cant connect to my network.

Device shows up, syslog messages are
wl1251: loaded
wl1251: initialized

"iwlist wlan0 scan" lists all networks

i set up /etc/network/interfaces
ifup wlan0

dhcp forever, iwconfig no values set..

ESSID: off/any
AP: Not-Associated

dmesg:
wl1251: firmware booted (Rev 4.0.4.3.7)

I tried to create a script setting some values like (ESSID) via iwconfig (which seems to work), but failed to connect.

(It is the same in my wickets 4.1 config, maybe i should try conman)

Maybe someone has already found a way to get it work?
I had xfce installed, and for sure it worked from wicd, though I had to change some setting to make it use something newer (sorry, can't remember now what it was ).

What definitely works from console is wpa_supplicant, though iirc you should use nl80211 driver, not wext. Could be the same that had to be changed in wicd.
__________________
Never fear. I is here.

720p video support on N900,SmartReflex on N900,Keyboard and mouse support on N900
Nothing is impossible - Stable thumb2 on n900

Community SSU developer
kernel-power developer and maintainer

 

The Following 5 Users Say Thank You to freemangordon For This Useful Post: