View Single Post
Posts: 23 | Thanked: 49 times | Joined on May 2011
Hi.I'm trying really hard to run Saera version fom GitHub on my N900 but i run into this problem:
Traceback (most recent call last):
File "", line 35, in <module>
import fremantle_hw as platform
File "/home/user/saera/", line 62, in <module>
jproc = subprocess.Popen([f+'julius/julius.arm','-module','-gram',f+'julius/saera','-h',f+'julius/hmmdefs','-hlist',f+'julius/tiedlist','-input','mic','-tailmargin','800','-rejectshort','600'],stdout=subprocess.PIPE)
File "/usr/lib/python2.5/", line 594, in __init__
errread, errwrite)
File "/usr/lib/python2.5/", line 1153, in _execute_child
raise child_exception
OSError: [Errno 2] No such file or directory
Strange as it all look correct to me regarding parse of subprocess.Popen. I've tried to add shell=True after stdout=subprocess.PIPE but it just hang with
-module: line 1:/home/user/saera/julius/julius.arm: not found

The Following 2 Users Say Thank You to DNA_Splice For This Useful Post: