View Single Post
Posts: 799 | Thanked: 2,601 times | Joined on Jan 2011 @ Germany
I just built Netsurf 3.7 for Easy Debian Jessie/armhf and it seems to work fine. So I uploaded an archive of the Debian packages. [1] As always, please feel free to host and share this archive as it will undoubtedly vanish at some point.
$ md5sum netsurf_3.7_ed_sulu.tar
2d789e49980b19fe8369d7511ee12c9a  netsurf_3.7_ed_sulu.tar
I also tried to backport zulucrypt from Buster. but while the build process worked smoothly, actually mounting volumes fails with this error message:
ERROR: Insufficient privilege to mount the device with given options
Unfortunately the code is ambiguous about throwing this message [2] and I did not bother to investigate further. The same packages fail mounting a truecrypt volume with a different error message in their build environment (Jessie chroot on Stretch host on my Cubieboard2), while a parallel amd64 build works fine in a Jessie/amd64 chroot. So I don't know whether to blame the Maemo kernel, the architecture or something entirely different.


The Following 6 Users Say Thank You to sulu For This Useful Post: