Thread Tools
Posts: 2,076 | Thanked: 3,262 times | Joined on Feb 2011
There is already a thread about Roguelikes ported to N900 running (, so you can get the major ones from there. This thread will be about running the non-ported ones. Also most of these use less keys than say ADOM, so are much more user friendly on N900.

I played a bit with the qemu-i386 package for ADOM that 009N provided and after hundreds of uncaught target signal 11 errors I managed to run a few roguelikes successfully, here is the list:


Running without problems (though not at 100% speed, some bit more sluggish, others almost unnoticeably):

Frozen Depths ( - very nice ADOMesque RL with temperature replacing food worries. Fully configurable keys (keybindings.txt). Blood splatter. Boss battles. Lots of fun.

Zapm ( - Zapm is a science fiction roguelike game by Cyrus Dolph. A humble attempt to create "the sci-fi Nethack". Arrows don't seem to work that well, so either 1-9 or tap 'O' and enable VI keys. Make sure the screen is big enough (or rather font small enough). Very enjoyable.

Nlarn 0.6.1 ( - A rewrite of Noah Morgan's classic roguelike game Larn. Still have to dive into this one a bit deeper. Looks promising.

CalcRogue ( - CalcRogue, a roguelike game for the TI-89, TI-92+ and V200 calculators. Might make more sense running through a calculator emulator, no idea. Works anyway. No support for VI keys and the arrows seem to be RUN, so 1-9

Please note that Savescummer, Fatherhood and You Only Live Once all _require_ 80x30 terminal to run. This can be hard to accomplish on N900 (even 80x25 is problematic) - one way to do it: Easy debian with terminal that allows font changing (like LXterm for example, get it through synaptic), set small enough font (monospace 11 seems to do the trick), resize the window to the correct size and enjoy.

Savescummer ( - The features of Save Scummer are:

* Intelligent "Do What I Mean" commands that reduce all possible actions to a single keystroke.
* Infinite undo to correct mistakes in pressing said single keystroke.
* Fight the fifty-two monsters from Letter Hunt and one new bonus monster.
* 1980 different weapons and 216 different spells!
* Play one of 8 races or 9 classes!

Fatherhood ( - As the name suggests, in Fatherhood you play the role of a father who has an important task to perform. That task is the stopping of the flood waters (or on some maps, the fires) that threaten to wash away his homeland. The tension is that you have another implicity task: to be a good father. Your three children are also in the world, running about, either helping or hindering as is their whim.

You Only Live Once ( - The features of You Only Live Once are:

* Extremely tactical combat. There is no randomness in combat. You always hit and always do full damage. This means that careful placement is the difference between success and failure.
* Heavy on plot and characterization. A story is told. It is not just kill things for no reason. (If you want to just kill things for no reason, POWDER is recommended)
* Quick to complete. You can likely fully explore and enjoy the game in an hour or two. You are then free to get on with your life.

Alan's Psychedelic Journey ( - Mushroomy trip. 1-2 busrides long roguelike. Pretty fun.

Devil Might Laugh ( - Escape from hell and save your soul.

last-of-candle ( - last-of-candle is a turn-based dungeon exploring game like rogue. You play an adventurer who wants to reach the bottom of the dungeon, which is full of monsters. You can use your shadow as a friendly creature to deal with them.

Bane of the living ( - Through the forest, at the bottom of a cave, lies the Moonscythe - an artifact with a legendary power over the undead. You're not the only necromancer searching for it, so you'll have some competition.

Mad Mage ( - Mad Mage is about subverting the Identification minigame in Roguelikes. Roguelikes commonly expose the player to new and mysterious items, whose properties are not immediately clear until said item is tried or identified. In Mad Mage, you start with all potions and scrolls IDed, but you'll slowly forget the identifications... (uses ESC key a lot)

Rook ( - As long as you’re wearing the orb of the Turk, you can’t die a stupid death — every move you can make has to kill you. If you take it off, you’re playing a traditional roguelike. The ring of vulnerability will save you from losing any hitpoints, because every hit you take will kill you, which is forbidden by the orb. Along the way you’ll find potions of healing and scrolls of teleport, opium sots, drunkards, hounds, and the royal couple themselves, out for a stroll in the woods. Apparently they’re bad guys. Probably tyrants, or something. Kill them.

DungeonClimb ( - bit hard to get the correct screen resolution. Seemed to work ok with only upper rim shown (fullscreen and then ctrl-up with Set Deb HW Keys on). The screen gets messy from time to time.

Python (these even though not emulated run terribly slow, listing just as maybe some day we'll get Psyco ported to maemo):

GartenRL ( - roguelike gardening simulator. Runs comparatively well.

Harmless7DRL ( - This is a game about surviving by using your abilities cleverly. Direct hack-and-slash approaches are probably -- hopefully! -- doomed to failure (though if you become very skilled at the game, it may be fun to try as a challenge game). Nearly every monster in the game has some sort of special behaviour. Observing how the monsters behave and figuring out ways to deal with them (not necessarily kill them) is a large part of the game.

imonster ( - not much background on this one. You play the bad guys (vi keys) against a hero (and sometimes his dog). Runs quite well.

KleinRL ( - roguelike taking place on the surface of a Klein bottle. Pretty strange.

Hive Awakening ( - The hive is a civilization of intelligent bots, all under the mastery of the hive control. Unforseen, one unit loses its connection to the hive control and learns to appreciate the feeling of independence.. It is your, the player's, task to help it on its way through the hive. The more you advance, the more difficult the levels become, and you have to swap the equipment to customize the bot's powers. It is only in the control core that the bot can ensure its freedom. Can you lead your bot to the hive control interface?

Gnome Squad, Cypress Tree Manor and Emperor Engine - all run, but bottom of the screen is out of bounds. Maybe there is a quick tweak to change resolution, no idea.

Problematic (if anyone can run these somehow, please do tell):

Berserk! ( - couple of months ago was running without problems, now 'Uncaught target signal 11' every time. As I had quite a few things installed in between (CSSU, bash3/4, busybox...) it might work for some.

DoomRL ( - ioctl errors for starters, then the greetings screen shows and you can even move selection in the main menu. But alas, nothing else works. Keyboard (except for up/down arrows) seems to be dead. Not even ctrl-c.

Cataclysm ( - this awesome RL dies after the menu/character creation. Since the binary I found was a whooping 20MB I was surprised it did that well. First WIN builds/ports were also dying right after the menu, so maybe this can be fixed somehow.


For the lazy I prepared an archive. Just unpack it in /media/mmc1 and all should be working (except for the last three):
As I was trying to run a lot of different ones, you might want to remove some libs from rls/inc folder, as they are not used by any of them (SDL and GL(U) ones are a safe bet, checking the minimal setup is a bit too much of a hassle though). (added as MU link already seems dead)

Always make sure the screen is big enough and keybdmap with ESC is also useful in some cases.

Have fun!

Last edited by szopin; 2011-07-22 at 17:45.

The Following 3 Users Say Thank You to szopin For This Useful Post:
Addison's Avatar
Posts: 3,807 | Thanked: 1,133 times | Joined on Oct 2007 @ East Lansing, MI
So ADOM never properly worked on your N900?

I've been waiting months for that to finally be ported on the older N800.
Posts: 2,076 | Thanked: 3,262 times | Joined on Feb 2011
It was never ported as there are no sources. The package 009N provided was emulated through qemu and worked fine (though only in 79x25, damn you pixel border). Used his base to run the ones listed above. If you managed to get working qemu for N800, you might try these, some should work without problem.

The Following User Says Thank You to szopin For This Useful Post:
Posts: 1,680 | Thanked: 3,681 times | Joined on Jan 2011
doomrl would be SOOOWEEEET. However the dosport is abandoned, the linux port is buggy and only available for x86. Further to this the code is such a mess that apparently porting to ARM would be too hard. Last I heard, doomrl 1 was being abandoned in favour of doomrl 2...which also wont be open sourced or ARM compatible.
N900: One of God's own prototypes. A high-powered mutant of some kind never even considered for mass production. Too weird to live, and too rare to die.

The Following User Says Thank You to vi_ For This Useful Post:
Posts: 2,076 | Thanked: 3,262 times | Joined on Feb 2011
Well, the menu opens up (in the nosound one). So that's a start. Maybe with libs from different OS (the ones in the package are mostly ubuntu). Berserk! which is based on the same valkyrie framework was working like a charm. No idea why now throws segfaults. Also I found somewhere mention that cvs-m build of qemu can sometimes help with the signal 11. Couldn't find it compiled anywhere though.

The Following User Says Thank You to szopin For This Useful Post:
Addison's Avatar
Posts: 3,807 | Thanked: 1,133 times | Joined on Oct 2007 @ East Lansing, MI
Yeah, I'm still waiting on a proper qemu port from linux eventually.

It looks like it's not going to happen though under Maemo 4.

But for me, there's still always SSH and Telnet.

This gives me ADOM, Crawl, Nethack, and even a real time version of Angband.

I promise to at least ask my friend late tonight about the pixel border thingy.

Sorry for the wait on this.
Posts: 2,076 | Thanked: 3,262 times | Joined on Feb 2011
Check this thread Addison:

Two people there claim to have got qemu running on N800. Download their packages and try to replace qemu-i386 in /media/mmc1/rls/ folder from my archive with one of theirs. See if that works.

Make sure your mmc is ext2 or similar as you need this file to be executable.

Also if I remember correctly Cataclysm RL has SSH server. Might be worth checking out.

Yup, details here: http://roguebasin.roguelikedevelopme...itle=Cataclysm

The Following User Says Thank You to szopin For This Useful Post:
Addison's Avatar
Posts: 3,807 | Thanked: 1,133 times | Joined on Oct 2007 @ East Lansing, MI
I'm downloading linux-user-test-0.3.tar.gz right now.

I may need to catch up with you later to figure out how to put this all together.

Addison's Avatar
Posts: 3,807 | Thanked: 1,133 times | Joined on Oct 2007 @ East Lansing, MI
I get to 99% extracting that linux-user-test-0.3.tar file to my Windows XP Desktop, then suddenly, I'm getting all these errors of unhappiness...

Am I supposed to partition my memory card, download that file to that specific partition, and then somehow untar the little bugger right from my tablet?

If so, this is so way over my league already.

Oooh, and I'm greasing up my friend right now, preparing to ask him the favor of compiling libvte for you even though he owes me not a single favor for the rest of his life.

*Finger crossies*
Posts: 2,076 | Thanked: 3,262 times | Joined on Feb 2011
If you're getting to 99% it looks everything is ok and it just tells you the symbolic links to files are wrong (as it's on XP I would say this is expected). Now look at the extracted files for qemu-i386 (it should be around 3mb, or somewhere near that size). Put my archive in /media/mmc1/ (if you copied it over to MyDocs open up terminal and
cd /home/user/MyDocs
cp RLsN900.tar.gz /media/mmc1/
cd /media/mmc1
tar -xzvf RLsN900.tar.gz
(I am assuming above that N800 folder structure is the same as N900)
This should get you 'rls' folder with subfolders with games and 'inc' subfolder with libraries. In /media/mmc1/rls/ there is 'qemu-i386' which runs on N900. Overwrite this file with the one you extracted from 'linux-user-test-0.3.tar' and make it executable (assuming you copied it to MyDocs in terminal):

cd /home/user/MyDocs
cp qemu-i386 /media/mmc1/qemu-i386
cd /media/mmc1
chmod 777 qemu-i386

And you should be ready to go (if your card is formatted to ext2/3 so the chmod works). If for some reason your card is not in /media/mmc1 and the rls folder ends up there you will need to amend for each game (just change the line '/media/mmc1/rls/qemu-i386 /media/mmc1/rls/inc/ --library-path /media/mmc1/rls/inc ./<game_binary>' so that /media/mmc1/ is the correct path for your memory card. It's just below '# Run ADOM in emu' line - yeah I'm that lazy typing on small keyboard, didn't bother to remove it). Hope this works. If not, try with the other N800 build from that thread.

Good luck!

The Following User Says Thank You to szopin For This Useful Post:

Thread Tools

Forum Jump

All times are GMT. The time now is 09:04.