Active Topics

 



Notices


Reply
Thread Tools
Posts: 1,427 | Thanked: 2,077 times | Joined on Aug 2009 @ Sydney
#1
I want to be able to set a specific brightness level and make it stick without it fluctuating due to ambient light levels on my N9.

Sometimes, my N9 is simply not as bright as I want it to be and I can't do anything about it other than shine a torch to the light sensor.

Is this actually possible?

Last edited by jakiman; 2011-11-05 at 08:58.
 

The Following 3 Users Say Thank You to jakiman For This Useful Post:
HtheB's Avatar
Moderator | Posts: 3,402 | Thanked: 5,739 times | Joined on Dec 2009 @ Bize Her Yer Trabzon
#2
A simple search would let you know that there are already solutions...

Here is your solution guys:
http://wiki.maemo.org/Disable_the_ambient_light_sensor

Once you've disabled ALS, it won't dim the lights anymore.

Have fun!
__________________
www.HtheB.com
Please donate if you think I'm doing a good job.
 

The Following 2 Users Say Thank You to HtheB For This Useful Post:
F2thaK's Avatar
Posts: 4,365 | Thanked: 2,462 times | Joined on Jan 2010 @ Australia Mate
#3
TO DISABLE ALS:


in /etc/mce/mce.ini

under [Modules] > list of modules to load,
change "filter-brightness-als" to "filter-brightness-simple"

then reboot.


------------------------------------------------------
You need to be root to do it, I edit files as root through SSH over Wifi using WinSCP on my PC. The latest version of SSH for N9 disables SSH root access, I had fun re-enabling it. See here: http://talk.maemo.org/showthread.php?t=79645


Or you can use Nano:

1. open xterm
2. devel-su [enter] then your root password [enter]
3. nano /etc/mce/mce.ini

then use the arrowkeys on the virtualkeyboard to navigate the file, and make the change.

once done, ctrl+o then enter saves the file
ctrl+x closes Nano

Last edited by F2thaK; 2011-11-05 at 14:14.
 

The Following 14 Users Say Thank You to F2thaK For This Useful Post:
travla's Avatar
Posts: 397 | Thanked: 241 times | Joined on Mar 2010 @ Melbourne, Australia
#4
Similar solution to the N900 answer after all...
 

The Following User Says Thank You to travla For This Useful Post:
Posts: 1,427 | Thanked: 2,077 times | Joined on Aug 2009 @ Sydney
#5
wow. so easy. alright, trying it out now.

Update: I've just tested this and it works brilliantly. It will give you 5 distinct level of brightness using the brightness bar in Settings and does not fluctuate by ambient lighting changes. The maximum brightness is brighter than iPhone4's max brightness level while keeping the color temperature and saturation intact. (it's slightly warmer than iPhone4) The over-saturation mode is gone also. So you get max brightness without over-saturation. I really like this!

Last edited by jakiman; 2011-11-05 at 13:15.
 

The Following 5 Users Say Thank You to jakiman For This Useful Post:
Posts: 98 | Thanked: 16 times | Joined on Jun 2010
#6
Originally Posted by F2thaK View Post
Think ive got it, it seems to be working...


in /etc/mce/mce.ini

under [Modules] > list of modules to load,
change "filter-brightness-als" to "filter-brightness-simple"

then reboot.
Hey. This is fantastic. Been trying to figure this out. Great job. Only issue is i'm not able to edit the file. It seems like it's read-only. I used file manager and file box and same thing. Is there an editing program i'm supposed to have to be able to do this?
 

The Following User Says Thank You to dagee04 For This Useful Post:
F2thaK's Avatar
Posts: 4,365 | Thanked: 2,462 times | Joined on Jan 2010 @ Australia Mate
#7
 

The Following User Says Thank You to F2thaK For This Useful Post:
Posts: 98 | Thanked: 16 times | Joined on Jun 2010
#8
Originally Posted by F2thaK View Post
See http://talk.maemo.org/showpost.php?p...30&postcount=5 for extended instructions.
Ahhh thanks dude. Worked!
 

The Following 2 Users Say Thank You to dagee04 For This Useful Post:
Posts: 1,427 | Thanked: 2,077 times | Joined on Aug 2009 @ Sydney
#9
You can also set it manually to a specific value via the terminal:

echo 255 > /sys/devices/omapdss/display0/backlight/display0/brightness

you can set manually values between 0-255.
I tested this and value 1 is much darker than the lowest point in the Settings slider bar. Also, I'm not sure if it's just my eyes but value 255 seems to be a tiny tiny bit brighter than the maximum accessible via the Settings bar. (while using filter-brightness-simple module in mce.ini)

http://forum.meego.com/showpost.php?...4&postcount=13

by the way, anyone know how to manually access the over-saturation mode also?
(the mode which is max brightness + more vibrant colors for outdoors which N9 has)
This mode seems to look better in direct sunlight or similar situations...
 

The Following User Says Thank You to jakiman For This Useful Post:
Posts: 87 | Thanked: 56 times | Joined on Nov 2008
#10
Originally Posted by F2thaK View Post
TO DISABLE ALS:


in /etc/mce/mce.ini

under [Modules] > list of modules to load,
change "filter-brightness-als" to "filter-brightness-simple"

then reboot.
I had "filter-brightness-simple" in mce.ini and bumbed into troubles after PR1.1 update.

After screen saver turned on, I could see the clock in black backround. But when I double tapped or pushed power button, I had completely black screen. Another push on power button brought back the clock on screen. Felt like screen was off except in screen saver mode. Reboot didn't fix that. After reboot screen was on, but when screen kicked on, same situation again.

After putting back "filter-brightness-als" and rebooting everything was ok again.
 

The Following 2 Users Say Thank You to sconf For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 21:32.