Notices


Reply
Thread Tools
Posts: 115 | Thanked: 38 times | Joined on May 2010 @ Sunny Woollahra
#91
I started having this error (rootfs etc) after installing Mad Developer and the associated libraries as directed to herel, which is a link from here.

My Question is

how do I remove (or optify?) those libraries?
__________________
I think there should be another word for mondegreen
 
Posts: 21 | Thanked: 4 times | Joined on Jun 2010
#92
Well, I too now have this problem... lol

I deleted all the SMS and MMS I was willing to delete (quite a lot, it took 90 minutes going through them all!) and continued to get the yellow banner come up.

i turned it off and on again but it continued to come up every 2 to 3 minutes.

The device then turned itself off and I switched it on again.

Since then I've not had the yellow banner but I apparently have no Applications installed, no Catalogues installed, and I get "Operation Failed" if I try to edit or create in my Calendar. I can't open a catalogue to download anything (like roothsh?) and I seem to be unable to use shift-Sym to get my square brackets for quotes in this message box.

I opened up X Terminal (my first time, eek! lol) and tried "df -h". This returned:
Filesystem Size Used Available Use% Mounted on
with no figures or anything, just that top line.

I tried "df -h /" and it returned:
Filesystem Size Used Available Use% Mounted on
df: /: can't find mount point
I tried "df" and it returned:
Filesystem 1k-blocks Used Available Use% Mounted on


UPDATE:
It is the morning after. It hasn't fixed itself overnight, dammit... lol

However, I _think_ I managed to Disable the two catalogues with the 'unsafe' applications in while my App Manager worked for the first 5 minutes this morning... it did say Operation Failed but the Catalogues were 'greyed out' afterward so hopefully it worked...

I noted that there were warning messages in red for each of the two catalogues - I will attempt to copy them here later.

The phone is still completely unstable though. Now I still can't send messages but I can telephone people, who then tell me they received my messages and have replied. I can't access Photos and my desktop has no visible icons, but when you tap the background then tap the 'cog' icon that comes up in the top right, the 'XM and 'spanner' buttons for (some of) the invisible icons are there.

I did at least discover while Catalogues was briefly working that I do have rootsh installed . I will now attempt to use that to remove things I don't want.

I will update further!

Last edited by MaemoNoob; 2011-09-06 at 06:49.
 
Posts: 1 | Thanked: 1 time | Joined on Sep 2011
#93
I recommend taking a backup of the device before trying anything I suggest here I do not take any responsibility if you manage to break your device into a state that it needs to be reflashed...

I had this error when my rootfs was full, but there was also a bug in the database component some time ago which caused this to appear. I think it was reported, had a workaround posted and fixed eventually. https://bugs.maemo.org/show_bug.cgi?id=10418

But to the point...

There are four possible reasons for the annoying error message:

- /home partition is full (you need to uninstall some apps, especially if you have several custom themes installed, these hog up space real fast)
- rootfs is full (instructions have been posted several times on the thread)
- Database is corrupt and you have an old image (older than PR1.2).. or it could be that this happens just after installing PR1.2 image and you got old database. You will lose all your messages with this, but it should get rid of the error:
Code:
#Open terminal
#Create a backup dir with your messages and such in it
mkdir /home/user/rtcom-eventlogger-backup
#copy the files over to backup dir
cp -a /home/user/.rtcom-eventlogger/* /home/user/rtcom-eventlogger-backup
#check the copy was done right, should contain files like el.db
ls /home/user/rtcom-eventlogger-backup
#remove files from the database dir
rm /home/user/.rtcom-eventlogger/*
reboot
- Backup dir is used just in case if this doesn't help, so you can still restore your messages. If this didn't help, go copy the files from the backup dir back:
Code:
#Open terminal
#Copy the files back
cp -a /home/user/rtcom-eventlogger-backup/* /home/user/.rtcom-eventlogger
- eMMC is corrupt (eMMC reflash helps sometimes, else you need to take your phone for maintenance)

I do not recall if this is related, but sometimes the browser breaks up messaging app, workaround is to clean up messaging specific browser files (they will be recreated). If I recall right this was related to messages not showing at all in the views though... Be careful with the remove command! Check that you really are removing files just under /home/user/.mozilla/rtcom directory

Also see https://bugs.maemo.org/show_bug.cgi?id=11456

Code:
#Open terminal
#Remove messaging browser specific files.
#NOTE:
#Check that the command is written right. Any spaces in the path will make the
#command remove things that you don't want to remove
rm -rf /home/user/.mozilla/rtcom/*
reboot
I can't stress enough, please be very careful when trying these.
 

The Following User Says Thank You to MikaN For This Useful Post:
Posts: 21 | Thanked: 4 times | Joined on Jun 2010
#94
Thank you very much for your detailed reply

Thank you too to everyone who has posted up the methods to fix this previously!

It got to the point that:
I can't send SMS messages
I can't send MMS
Call Logs aren't updated
I can't enter new calendar entries
I can't amend old calendar entries
I can take pictures but I can't view pictures
File Manager says I have no directories
Application Manager says I have no catalogues
I can't uninstall applications because Application Manager says I have no catalogues
Hildon crashed and seemed to not reload on reboot

Basically it turned into an internet tablet which I could make and receive calls, and that was it! lol


So, in the end I gave up and have reflashed it tonight.

I reflashed to PR1.2 because that is what I was running and, mainly, because I like the way the internet works using it (I use a lot of internet ) and I understand PR1.3 changes things with regards to the back-arrow / left-swipe setup, which would annoy me! I understand PR1.3 may make things quicker, though, so I'm not saying I won't reflash in the future...


I backed everything I could up using PC Suite and I also used the phone in Mass Storage Device mode and dragged-and-dropped from the folders into a folder on my computer (just in case). Then, once I had reflashed, I either dragged and dropped back onto the phone using Windows Explorer or PC Suite, or re-installed from the on-device Backup file.

It seems to have worked so far - I think I have kept everything bar a couple of weeks of Calendar entries, from what I can see, so hopefully all will go smoothly...

I can't see where Messages are backed up on PC Suite, that is my only real issue, but after not appearing at first they are now back, so I am happy

Thank you again, everyone, for a great community!


Let's hope I don't download anything dodgy from the development catalogues this time... lol



EDIT 2011.10.03:
I have checked properly and I think I have lost all my additional calendars that I set up, losing all the entries in them I will have to see if I have them backed up on the Computer / PC Suite!

Last edited by MaemoNoob; 2011-10-03 at 14:55.
 
sla_erick's Avatar
Posts: 29 | Thanked: 5 times | Joined on Aug 2008 @ Mexico
#95
i had this problem yesterday, somehow, freeing up some space at rootfs stopped poping up that message. But the problem is that ALL MY CONVERSATIONS (IM & SMS) are gone, everey time i open the conversation app says i dont have any conversations. I did the backup process and now i have the el*.db files in my computer. With a SQLite software i was able to open those DB files and saw ALL of my conversations (IM & SMS) on a table called "events". The DB file i opened was el-v1.db Please i needto fix this, i have no idea on how to do this. Now i have 83% used space at my rootfs, the files that were on my rtcom-eventlogger folder are: "el.db", "el-v1.db", "el.db-journal", "el-v1.db-journal" and "el-v1-before-restore.db". I ran a script i saw from other post to back up the files, erase them and then copy them again. Any help would be apreciate it. Excuse me for my bad english
__________________
Nokia N900 user, learning JAVA programing and future MAEMO developer
 
Posts: 8 | Thanked: 0 times | Joined on Apr 2012
#96
That's what I'm starting to think, but wouldn't a damaged emmc fail when flashing? It's flashes without any problems at all.

 
Posts: 23 | Thanked: 3 times | Joined on Jul 2012 @ Near Barcelona - From San Francisco
#97
Hope this is the correct thread...

Just loaded a lot of music on my N9, and now getting a recurring message to check Data Storage, as I am almost out. Sure enough, my User Data shows 9.4Gb out of 9.5 is allocated. For the "partitions" for Installed Apps and Application Data is it possible to reallocate and assign some to User Data as they each have a couple of unused Gbs?

Should have bought the 64Gb!

-keatsfan
 
Posts: 34 | Thanked: 11 times | Joined on Dec 2012
#98
thanks brother for your information.
 
Posts: 110 | Thanked: 65 times | Joined on Apr 2012
#99
Holy dead thread revival, Batman!
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 04:04.