Notices


Reply
Thread Tools
Posts: 33 | Thanked: 6 times | Joined on Jun 2011
#121
Thanks for sharing nice discussion.actually i was not aware these things.thank you..
 
Posts: 7 | Thanked: 1 time | Joined on May 2011 @ Shanghai-China
#122
Originally Posted by max_kamdi View Post
sir my n900 camera nt working it shw only black screen n camera options.. plz help me out..
Got the same problem after installed Power48.

Tried all the fix way and camera remains black screen.

Blessn900 has installed but can not startup(just a flash on the screen). Anyone please help.Thanks!

_________________________________________________
Update: Updated to Power kernel 49 fix my problem.

Last edited by seawall; 10-22-2011 at 12:25 AM.
 
Posts: 9 | Thanked: 29 times | Joined on Dec 2010
#123
Let me begin my reply with *WARNING* - do not allow Enhanced Linux Kernel/'Kernel-power' to be removed by ANY application manager! If you do this, the phone will become stuck in a reboot loop (read on for solution).

My situation was as follows:

1. Upgraded stock N900 to 1.3.1. Current apps installed include BlessN900 and FCamera.
2. Installed Enhanced Linux Kernel.
3. Overclocking works.. camera doesn't ("Operation failed").
4. Tried removing all camera-related software - this does not fix the issue. Indicated solution in this thread is to enable extras-devel repository and upgrade the fcam-drivers package, using Faster Application Manager (FAM) to 1.7.2.
5. FAM says "Kernel-power" must be removed in order to install the upgrade.
6. Upon reboot, the phone is stuck in a reboot loop and will not boot up or charge.

If this happens to you - remove the battery immediately! N900 can't charge in this state and flashing requires good level of charge in the battery!

To resolve the problem a micro-USB -> USB cable and computer are required.

First grab flasher-3.5 from here: http://tablets-dev.nokia.com/maemo-d...-downloads.php . (Installation at the final phase, "Installing Connectivity Cable Driver", may take a very long time, be patient).
Then download the most recent firmware revision image (~190mb) for your locale: http://tablets-dev.nokia.com/nokia_N900.php.
Don't worry about the suggestions you may have read elsewhere about needing to reflash the whole OS - it should be possible to recover the phone in seconds as long as there is enough charge remaining in the battery to do so. I refer to the instructions here http://wiki.maemo.org/Kernel_Power#Deinstallation ..with this excerpt:

Open Command Prompt to the installation directory of flasher 3.5 and prepare the following command:

Code:
flasher-3.5 -f --flash-only=kernel -R -F <firmware-image>
Re-insert the battery into your N900 and hold down the 'u' key on the keyboard. Insert the Micro-USB cable.

The display should activate without the backlight. When the USB icon appears at the upper right corner of the display, you may release the 'u' key and run the command you typed above. In a few seconds, the kernel is replaced.

Only the kernel will be replaced by this operation. If successful, you should be able to boot the phone with its kernel reverted to the stock version from the image. Camera functionality is restored

If unsuccessful, it may be because the battery's charge is too low (charge with another device or get hold of a battery with charge).

Alternatively, follow instructions elsewhere to attempt a full reflash.

I ensured all camera-related software was uninstalled and have installed Enhanced Linux Kernel again - camera functionality is maintained.


Hope this helps!

Alex

Last edited by PSX; 12-02-2011 at 09:40 AM. Reason: Fixing formatting
 
Posts: 3 | Thanked: 0 times | Joined on Jan 2012
#124
doesn't work ... tryied already all of these ... enyone esle? i must to get rid of this S***i phone ... i'm really sad...
 
Posts: 189 | Thanked: 403 times | Joined on Jan 2012
#125
Originally Posted by kudd View Post
doesn't work ... tryied already all of these ... enyone esle? i must to get rid of this S***i phone ... i'm really sad...
I also had problems with the camera and kernel-power and fcam drivers.

What did the trick for me was installing cssu. Go to wiki.maemo.org and look for CSSU.
 
Posts: 1 | Thanked: 0 times | Joined on Jul 2012
#126
hi guys i was resolve my problem with operation faild
i did all things from this thread and many others witch i found in google and for me reflesh with flasher 3.5 does not work nothing was work :? .
so i just soldering camera pins and my cam start workin again.
DO NOT REFLOW THEM coz u damege your lens.sry for my english and enjoy ur cam again ;D
 
Posts: 96 | Thanked: 27 times | Joined on Sep 2011
#127
echo69, u should hav taken a screen shot of the process and work you did for more clearity.

im having a blurry camera myself (focus issue) and not camera operation failed.

Last edited by zzzchainzzz; 07-06-2012 at 02:38 PM.
 
Posts: 173 | Thanked: 21 times | Joined on Sep 2010 @ Rio de Janeiro
#128
Hello guys, I also am one more N900 owner having 'Operation Failed' problem, I have fcam drivers installed by downloading it to MyDocs and using X-Term to install, still not work, am right now checking for updates on App Man to try to install BlessN900 to see if it fixes the problem, also will try to see if it has new drivers of FCam, am on KP v 51, problem is that I don't know wich app is causing that, have tried reflas kernel using flasher 3.5 for windows, still the same, altough I'm not sure if it went correct as I still had all my apps installed, I don't want to reflash 32gb mass memory nor lose my contacts, the apps I don't care as I can reinstall all of them again manually on App Man, toght I will install one by one and between each will check if cam still working, sorry for long post, will report back later or tomorrow, in the meanwhile if someone knows a solution I will appreciate very much. Still waiting for App Man... Thanks.
 
Posts: 173 | Thanked: 21 times | Joined on Sep 2010 @ Rio de Janeiro
#129
Today, I open the lens cover and for a great surprise the camera was working again, I don't know what I did, recently I've installed apps tickstill, omWeather and Miniature, now the problem I have since last week, was having the usb problem for a while but last week N900 got droped on the floor and the usb piece got out, so I'm charging with Universal charger, also am unable to connect to PC, thanks God I don't have to reflash anymore (for the camera), but will replace the usb connector when I can, I hope it's not very expensive.
 
Reply

Tags
bada 4 gays, bada rox

Thread Tools

 
Forum Jump


All times are GMT -4. The time now is 10:39 AM.