Posts: 86 | Thanked: 8 times | Joined on May 2010
#1
I first noticed a problem last week, after synching over a new set of MP3s: one album's worth of songs appeared in Canola but wouldn't play. (The other albums played fine.) Then over the weekend, I was travelling. At one point, after powering it up and checking email, I started Canola and played a song, but it was mostly unused. Then on the trip back, I powered it off when I got on the plane, then restarted to listen to music for the trip. Canola would not start, I never saw any UI for it at all. So I tried using the default media player; it would start, and it would find the songs, but it wouldn't play anything.

When I got home, I ran Canola from a shell window (over SSH) and it was throwing an error when reading the 'settings' file. I located that and found it was 0 bytes, so I renamed it. A new 'settings' file was created, as I had hoped; however, Canola started with a hung UI. Starting from the shell shows an error: Failed to execute dbus-launch. (I can run dbus-launch from the shell with no apparent error, but I don't know what arguments Canola is passing to that program.)

So, fine: I'll reinstall Canola. Except, I couldn't start the Application Manager. This got me thinking that I was going to have to reflash. I tested some other apps, like Tear (my #2 application after Canola) and didn't see any other problems.

I sat down with it again today. Somehow, Application Manager is running again, altho it failed to launch one other time, immediately after I saw the "Failed to execute dbus-launch" error. I've uninstalled Canola and reinstalled; no change. Uninstalled again, then installed and ran canola-cleanup, and reinstalled. Now it's telling me there is no /etc/canola.conf -- which is true, but why didn't that get created on installation?

Also, the issue with Media Player is still there: it sees the MP3s on the SD card but can't load them to play.

How can I fix this? Maybe I do need to reflash, but boy I'd really rather not.
 
Posts: 822 | Thanked: 821 times | Joined on Sep 2010
#2
canola.conf could be a static file from the installation and Canola is unable to recreate it.

Have you tried rebooting or reseating the SD card?

Do you have mplayer and have you tried using it to play the files? Just run mplayer some-file-name from the shell.
 
Reply

Thread Tools

 
Forum Jump


All times are GMT -4. The time now is 11:51 PM.