Reply
Thread Tools
Posts: 78 | Thanked: 56 times | Joined on Oct 2011 @ Denmark
#1
Hi,

Rhythmbox (in Ubuntu 11.04) crashed while I was transferring music to my Nokia N9.

Then the file system became read-only. I tried to repair it with fsck on my Ubuntu-computer without luck.
Then I reformatted the device as fat32 using Gparted on Ubuntu and started to recreate folders and then transfer music to the N9 though Rhythmbox.

But when I disconnect it from the computer the Music app don't find any music.

The only file found i MyDocs is: pvr_hwrec

Code:
~/MyDocs $ ls -al
total 132
drwxrwxrwx    3 user     root         65536 Jan  1  1970 .
drwxr-xr-x   44 user     users         4096 Feb 28 18:37 ..
drwxrwxrwx    2 user     root         65536 Feb 28 02:57 pvr_hwrec
The partition seems to be mounted:
Code:
~/MyDocs $ mount | grep MyDocs
/dev/mmcblk0p1 on /home/user/MyDocs type vfat (rw,nosuid,nodev,noexec,noatime,nodiratime,uid=29999,fmask=0133,dmask=0000,allow_utime=0022,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,rodir,errors=remount-ro)
And fstab seems to be right:
Code:
~/MyDocs $ cat /etc/fstab 
rootfs / rootfs defaults,errors=remount-ro,noatime 0 0
/dev/mmcblk0p3 /home ext4 rw,noatime,errors=remount-ro,barrier=1 0 0
/dev/mmcblk0p1 /home/user/MyDocs vfat noauto,nodev,noexec,nosuid,noatime,nodiratime,utf8,uid=29999,shortname=mixed,dmask=000,fmask=0133,rodir 0 0
ubi0:var /var ubifs noauto,no_chk_data_crc,bulk_read
I've tried to reboot but nothing helps. It really seems like the partition didn't get mounted right.

I can't umount/mount the partition because of N9's stupid nanny-root right. And yes development is enabled and I've typed devel-su.

Code:
~ # lsof | grep MyDocs
~ # umount /dev/mmcblk0p1
umount: can't umount /home/user/MyDocs: Operation not permitted
~ # umount /home/user/MyDocs/
umount: can't umount /home/user/MyDocs: Operation not permitted
It's stupid to restrict the root user when the advanced user has enabled development mode especially when things broke and need to be repaired.

Anyway I would be really glad if anyone could help me
 
Posts: 78 | Thanked: 56 times | Joined on Oct 2011 @ Denmark
#2
Deleted the fat32 partition in Gparted and now I able of mounting the partition manually and transferring files as root.
I'll keep you updated.
 
Reply

Thread Tools

 
Forum Jump


All times are GMT -4. The time now is 01:23 AM.