Reply
Thread Tools
Posts: 10 | Thanked: 2 times | Joined on Sep 2010 @ Berlin
#1
While I'm very happy with my N9, I do have huge problems with SIP-telephony over Wifi.

My N900 had accepted wifi bugs, making serious SIP-telephony over Wifi impossible (stuttering, channel loss), I was hoping that the N9 would have reached the same quality as my old Symbian-based E51.

The N9 is more useable than the N900 for SIP-telephony over Wifi

I use a AVM Fritzbox 7170 for years and recently tried a D-Link DIR-645. Using the Fritzbox I often get package loss and general non-ideal voice quality, and always missing the first missing seconds of the talk, using the DIR-645 I've got a better over-all quality, but frequent complete connection dropout, especially when answering a call.

Anyone here who has a setup where error-free serious SIP-over-Wifi telephony is working with the N9? Which equipment do you use, which Wifi channels etc.?

ATM I'm considering to revive my E51 and degrade the N9 to a toy. :-(
 
Posts: 203 | Thanked: 132 times | Joined on Aug 2011
#2
The key to VOIP is QOS.

I got a couple of Linksys E3000, 1 Linksys WRT54GS v1.1 and a Cisco E4200v1 all using Tomato firmware (Toastman builds) and utilizing QOS

So far everything is working great without any echo/delays over wifi and 3.5G
 
Posts: 303 | Thanked: 636 times | Joined on Jan 2012 @ Enschede, The Netherlands
#3
I too find telephony over WLAN with my FB 7270 next to unusable Can't even use 11n, in which case WLAN-connection breaks from time to time.

It seems as if power saving is a notch too high. Whenever there's no more data to stream for a (very) short while, the connection seems to back off.

Pinging the router from the N9:

Code:
64 bytes from 192.168.200.1: seq=9 ttl=64 time=195.648 ms
64 bytes from 192.168.200.1: seq=10 ttl=64 time=53.101 ms
64 bytes from 192.168.200.1: seq=11 ttl=64 time=24.810 ms
64 bytes from 192.168.200.1: seq=12 ttl=64 time=27.069 ms
64 bytes from 192.168.200.1: seq=13 ttl=64 time=21.698 ms
64 bytes from 192.168.200.1: seq=15 ttl=64 time=100.067 ms
64 bytes from 192.168.200.1: seq=16 ttl=64 time=16.113 ms
64 bytes from 192.168.200.1: seq=17 ttl=64 time=1054.382 ms
64 bytes from 192.168.200.1: seq=18 ttl=64 time=58.685 ms
64 bytes from 192.168.200.1: seq=19 ttl=64 time=23.621 ms
Needless to say, pinging the router from my desktop has <<1ms latency. This also becomes apparent when SSHing to the mobile: keystrokes have quite a severe lag.

Unfortunately I don't know how to disable power management, to see if that indeed is the case. So I can only confirm the problem.
 
Posts: 6 | Thanked: 0 times | Joined on Feb 2012 @ Germany
#4
There are other threads about wifi problems that you might want to search for.

What I did so far to be able to use SIP is to change my FB's (7270) wifi settings to
802.11b+g (disabling n) what helped a lot with lost connections. Both, ssh and
SIP are usable since then.

Concerning the ping latency, there was a hint to install wireless-tools
and turn off wlan0's power managment (iwconfig wlan0 power off).
This results in ping times of 1 ms but when the phone turns idle,
something turns on power management, again. So that is not really a solution...

Hope, that helps.

Last edited by x6hank; 2012-02-23 at 17:35.
 
Posts: 158 | Thanked: 56 times | Joined on Jan 2012 @ Timisoara, Romania
#5
Originally Posted by BlinkThinks View Post
The key to VOIP is QOS.

I got a couple of Linksys E3000, 1 Linksys WRT54GS v1.1 and a Cisco E4200v1 all using Tomato firmware (Toastman builds) and utilizing QOS

So far everything is working great without any echo/delays over wifi and 3.5G
The answer is clear: Linksys and Cisco vs. World
Seriously, if you want real VOIP, get a REAL stuff, ie Linksys or better Cisco
__________________
"No one will need more than 637 kb of memory for a personal computer."
 
Posts: 303 | Thanked: 636 times | Joined on Jan 2012 @ Enschede, The Netherlands
#6
Originally Posted by x6hank View Post
Concerning the ping latency, there was a hint to install wireless-tools
and turn off wlan0's power managment (iwconfig wlan0 power off).
This results in ping times of 1 ms but when the phone turns idle,
something turns on power management, again. So that is not really a solution...
That indeed works, but not only do you have to be root, but you'll also need to start the developer shell (develsh).

Digging in an iwconfig manual I saw a timeout-option.

Code:
/sbin/iwconfig wlan0 power timeout 2
That should give a timeout of 2 seconds before going back to sleep. With this, ping-times are in the 1ms-2ms range as expected. But what's more: power mode is still enabled, so I hope this doesn't drain the battery. Even better: this setting seems to be permanent for the session. I haven't tried rebooting, but otherwise it seems to stick; going to standby-screen or even flight mode doesn't revert it.

I can't test full duplex SIP right now, but calling the voice mail box worked well
 

The Following 2 Users Say Thank You to Fuzzillogic For This Useful Post:
Posts: 188 | Thanked: 89 times | Joined on Sep 2006
#7
BTW the connection speed may also depend on other wifi APs / network activity in your neighbourhood.
Check used channels in your area.
Don't forget that only 1, 6 and 11 are really independent, all others skirt into the neighbouring channels, i.e. if your neighbour has his AP on channel 4, you should be on 9 or higher.

BTW WiFi as a system deals better with collisions on the same channel (slot time sharing required) than on adjacent channels (noise/disturbance, bad reception at all times). That's why Bluetooth is a major disturbance to Wifi, quick channel hopping, so mostly a signal-to-noise degradation for the Wifi link.
So if your neighbours are on 1, 6 and 11, best go on 1, 6, and 11 too, unless their link signal is weak, so your signal can just drown it, then go on an adjacent channel - your stronger signal / link should not be impacted much.

Disclaimer: this that and the other from putting bits and pieces together - I'm not an RF engineer.
__________________
If I said something useful, please hit the 'Thanks!' link related to that post.
 

The Following User Says Thank You to aRTee For This Useful Post:
Posts: 10 | Thanked: 2 times | Joined on Sep 2010 @ Berlin
#8
Thanks to everyone for the very detailed information. I'll try playing around with the wireless-tools and also try get hold of one this cisco-routers.
 
Posts: 303 | Thanked: 636 times | Joined on Jan 2012 @ Enschede, The Netherlands
#9
I've installed PR1.2 (full flash, clean device). Wow. Ping-times are now 5ms-10ms without further configuration. Browsing by wifi now feels very much more snappier than ever before. No more weird delays.

This might all be due to my FB7270 router, but given the clear fact it now works much better I'd say it was de N9's software as well. Haven't tried SIP, but this sure is promising.
 
Moderator | Posts: 5,119 | Thanked: 3,969 times | Joined on Oct 2009
#10
Originally Posted by Fuzzillogic View Post
I've installed PR1.2 (full flash, clean device). Wow. Ping-times are now 5ms-10ms without further configuration. Browsing by wifi now feels very much more snappier than ever before. No more weird delays.

This might all be due to my FB7270 router, but given the clear fact it now works much better I'd say it was de N9's software as well. Haven't tried SIP, but this sure is promising.
finally some positive stuff, so many of the posts since 1.2 are so depressing
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 09:28.