Reply
Thread Tools
Posts: 986 | Thanked: 2,330 times | Joined on May 2011 @ Brazil
#11
Originally Posted by buurmas View Post
Strangely, I still have the problem. I don't appear to have python2.5-dev installed yet; that is, it does not appear in the PackageView program.

Here's what I did. I ran the Application Manager, saw the updates to Integral & Derivative, installed them, and ran them but nothing happened. I also installed Limit -- same thing.
I am surprised that the new versions of "Integral" and "Derivative" need "python-sympy_0.7.1-maemo4" (new version which depends on python2.5-dev) but this python-sympy package is not updated.

For the users of Integral v1.1.4 and Derivative v1.0.0 for Maemo 4, I think the solution is :
- uninstall "Integral"/"Derivative"/"Limit" from the application manager (it will uninstall python-sympy_0.7.1-maemo3);
- update the application manager;
- install "Integral"/"Derivative"/"Limit" so that the new python-sympy (and python2.5-dev) will be installed.
__________________
Python, C/C++, Qt and CAS developer. For Maemo/MeeGo/Sailfish :
Integral, Derivative, Limit - calculating mathematical integrals, derivatives and limits. SymPy - Computer Algebra System.
MatPlotLib - 2D & 3D plots in Python. IPython - Python interactive shell.
-- My blog about mobile & scientific computing ---
Jolla. 2 Nokia N9 16GB Black @ 1.35 GHz, 1 with Sailfish, Stowaway foldable BT keyboard.
Nexus 4 with Sailfish. Nokia N900 @ 1.1 GHz. N810. Nokia 9500. Psion Revo+.
 
Posts: 986 | Thanked: 2,330 times | Joined on May 2011 @ Brazil
#12
Originally Posted by buurmas View Post
I installed python2.5-dev from the terminal (sudo apt-get) and now everything appears to be working. Perhaps the dependencies on SymPy still aren't correctly being handled?
Hi buurmas. If you can, please follow my last suggestion : uninstall "Integral"/"Derivative"/"Limit" and install again.

Thanks for your comments and installation debugging.
__________________
Python, C/C++, Qt and CAS developer. For Maemo/MeeGo/Sailfish :
Integral, Derivative, Limit - calculating mathematical integrals, derivatives and limits. SymPy - Computer Algebra System.
MatPlotLib - 2D & 3D plots in Python. IPython - Python interactive shell.
-- My blog about mobile & scientific computing ---
Jolla. 2 Nokia N9 16GB Black @ 1.35 GHz, 1 with Sailfish, Stowaway foldable BT keyboard.
Nexus 4 with Sailfish. Nokia N900 @ 1.1 GHz. N810. Nokia 9500. Psion Revo+.
 

The Following User Says Thank You to rcolistete For This Useful Post:
Posts: 668 | Thanked: 359 times | Joined on Mar 2009
#13
I'll try to do it today. For completeness, I'll manually uninstall python2.5-dev if I need to.
__________________
* n810 since Feb 2009
* Most-used apps: Opera, gPodder, Panucci, Tomiku, Canola, Quasar, MaemoMapper, ATI85, Maemopad+, AisleRiot Solitaire, Anagramarama, Rapier, Gnumeric, pyRDesktop
* Mobile-friendly URLs of popular sites
 

The Following User Says Thank You to buurmas For This Useful Post:
Posts: 986 | Thanked: 2,330 times | Joined on May 2011 @ Brazil
#14
Originally Posted by buurmas View Post
I'll try to do it today. For completeness, I'll manually uninstall python2.5-dev if I need to.
Yes, please "apt-get remove python2.5-dev". But leave "python-sympy" (old version) to see if the new version installs when installing "Integral"/"Derivative"/"Limit".

Thanks in advance.
__________________
Python, C/C++, Qt and CAS developer. For Maemo/MeeGo/Sailfish :
Integral, Derivative, Limit - calculating mathematical integrals, derivatives and limits. SymPy - Computer Algebra System.
MatPlotLib - 2D & 3D plots in Python. IPython - Python interactive shell.
-- My blog about mobile & scientific computing ---
Jolla. 2 Nokia N9 16GB Black @ 1.35 GHz, 1 with Sailfish, Stowaway foldable BT keyboard.
Nexus 4 with Sailfish. Nokia N900 @ 1.1 GHz. N810. Nokia 9500. Psion Revo+.
 
Posts: 668 | Thanked: 359 times | Joined on Mar 2009
#15
Success!
Originally Posted by rcolistete View Post
Yes, please "apt-get remove python2.5-dev". But leave "python-sympy" (old version) to see if the new version installs when installing "Integral"/"Derivative"/"Limit".
I uninstalled Integral, Derivative, & Limit. According to PackageView, python2.5-dev was still present at this point. I'm not sure about sympy -- it may have been automatically removed by the Application Manager. I then did "sudo apt-get remove python2.5-dev", which worked. I then installed Derivative and it worked! Same with Integral and Limit.

Thank you for these useful programs!
__________________
* n810 since Feb 2009
* Most-used apps: Opera, gPodder, Panucci, Tomiku, Canola, Quasar, MaemoMapper, ATI85, Maemopad+, AisleRiot Solitaire, Anagramarama, Rapier, Gnumeric, pyRDesktop
* Mobile-friendly URLs of popular sites
 

The Following User Says Thank You to buurmas For This Useful Post:
Posts: 986 | Thanked: 2,330 times | Joined on May 2011 @ Brazil
#16
Good news for Maemo 4 users :
- IPython 0.10.2 is released, with an icon and simple installation from the application manager;
- "SymPy Interactive Shell" is released, so the installation and use of SymPy on Maemo 4 is now easier than before.

See the 1st post of this topic.
__________________
Python, C/C++, Qt and CAS developer. For Maemo/MeeGo/Sailfish :
Integral, Derivative, Limit - calculating mathematical integrals, derivatives and limits. SymPy - Computer Algebra System.
MatPlotLib - 2D & 3D plots in Python. IPython - Python interactive shell.
-- My blog about mobile & scientific computing ---
Jolla. 2 Nokia N9 16GB Black @ 1.35 GHz, 1 with Sailfish, Stowaway foldable BT keyboard.
Nexus 4 with Sailfish. Nokia N900 @ 1.1 GHz. N810. Nokia 9500. Psion Revo+.

Last edited by rcolistete; 2012-02-22 at 17:45.
 
Posts: 986 | Thanked: 2,330 times | Joined on May 2011 @ Brazil
#17
IPython and SymPy are now in Maemo 4 extras repository.

See the 1st post of this topic for the links.
__________________
Python, C/C++, Qt and CAS developer. For Maemo/MeeGo/Sailfish :
Integral, Derivative, Limit - calculating mathematical integrals, derivatives and limits. SymPy - Computer Algebra System.
MatPlotLib - 2D & 3D plots in Python. IPython - Python interactive shell.
-- My blog about mobile & scientific computing ---
Jolla. 2 Nokia N9 16GB Black @ 1.35 GHz, 1 with Sailfish, Stowaway foldable BT keyboard.
Nexus 4 with Sailfish. Nokia N900 @ 1.1 GHz. N810. Nokia 9500. Psion Revo+.
 

The Following User Says Thank You to rcolistete For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 20:30.