Reply
Thread Tools
qwazix's Avatar
Moderator | Posts: 2,620 | Thanked: 5,384 times | Joined on Jan 2010
#1
I can't connect to the N9 as user from my ubuntu laptop with public key authentication. I can connect fine as root, or as user with password. I did everything suggested in this thread but nothing works. I also posted there but as the thread is marked as solved i thought I'd open a new one.

If anybody got any ideas please share.

Thanks.
__________________
Proud coding competition 2012 winner: ρcam
My other apps: speedcrunch N9 N900 Jollacontactlaunchtimenow

Nemo UX blog: Grog
My website: qwazix.com
My job: oob
 
Posts: 293 | Thanked: 64 times | Joined on Jan 2008 @ Fremantle, W. Australia
#2
I can "ssh developer@n9" with PK, but not to user@n9.

It is something in the home directory /home/user . Aegis?
Create a new password table entry with same UID but different home.
 
Posts: 29 | Thanked: 10 times | Joined on Mar 2010
#3
@qwazix

Are you sure that your pub key is in .ssh/authorized_keys on your n9?

@myk

Open the terminal on the n9 and run passwd to set a passwd. You should then be able to ssh in with the password you set.
 
Posts: 293 | Thanked: 64 times | Joined on Jan 2008 @ Fremantle, W. Australia
#4
uber,
This issue is specific to user "user". The .ssh/authorized_keys is identical for root, user and developer. Login with password works fine.

I tried to test is by copying /home/user as root. But now I have a bunch of files in there I cannot chmod or chown, even as root. Must learn this Aegis security thingy, which I suspect is the problem with ssh.
 
qwazix's Avatar
Moderator | Posts: 2,620 | Thanked: 5,384 times | Joined on Jan 2010
#5
Yes it is. And I made a new one too with just one key as user, just in case it was something with the old authorized_keys which was created before reflash
__________________
Proud coding competition 2012 winner: ρcam
My other apps: speedcrunch N9 N900 Jollacontactlaunchtimenow

Nemo UX blog: Grog
My website: qwazix.com
My job: oob
 
Posts: 313 | Thanked: 245 times | Joined on Jan 2010 @ USA
#6
On the linux machine's shell do this and try again. This solved the problem for me.

export SSH_AUTH_SOCK=0
 

The Following User Says Thank You to dsawhney For This Useful Post:
qwazix's Avatar
Moderator | Posts: 2,620 | Thanked: 5,384 times | Joined on Jan 2010
#7
Unfortunately, it didn't work... I don't know what else to try...
__________________
Proud coding competition 2012 winner: ρcam
My other apps: speedcrunch N9 N900 Jollacontactlaunchtimenow

Nemo UX blog: Grog
My website: qwazix.com
My job: oob
 
Posts: 293 | Thanked: 64 times | Joined on Jan 2008 @ Fremantle, W. Australia
#8
qwazix,
stop trying to ssh in as "user". Use developer instead. It is the same userID, so same permissions and ownership of created files.
 
Posts: 8 | Thanked: 0 times | Joined on Mar 2012 @ Germany
#9
Hi,

I think I just found a solution for you as I was going crazy for a few days now having my new N9, updated to PR1.2 and not being able to ssh into it from a remote machine at home.

I checked a lot of threads and forums all around dealing with this ssh log in business but I was not able to succeed.

Now, looking to this thread and once again checking the /etc/ssh/sshd_config file I found the restriction that blocked me all the time: it was the line of "AllowUsers" and a variety of limited ip address ranges - due to my individual setting of my home network I could not access as my ip start with 192.123.x.x.

After editing the line AllowUsers in /etc/ssh/sshd_config and adding *@192.123.0.0/16 and a restart I am now able to access and log in via ssh from my Ubuntu machine(s).

I am not quite sure about the syntax of the AllowUsers address ranges, some hints might be appreciated.

I logged in with the developer account and passwort set via teh SDK tool on the N9, but will check next if it also works now as user@n9-ip.


Regards,
Timm
 
Posts: 293 | Thanked: 64 times | Joined on Jan 2008 @ Fremantle, W. Australia
#10
Originally Posted by TimmW View Post
setting of my home network I could not access as my ip start with 192.123.x.x.
You cannot just go around using any old address on your home network, at least not if it connects in any way to the internet. That address range belongs to Kraft Foods.

See http://en.wikipedia.org/wiki/IP_addr...vate_addresses
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 14:39.