Reply
Thread Tools
Posts: 1 | Thanked: 0 times | Joined on Mar 2012 @ The Netherlands
#31
Don't know if this has been mentioned before, but AccuWeather does seem to update if the energy saving mode is disabled.

Noticed that when my energy saved N9 was being recharged - and the device goes into normal mode - it keeps track of the weather...
 
Posts: 418 | Thanked: 429 times | Joined on May 2011
#32
Observed another ocassion that AccuWeather wouldn't update anymore automatically after being in Power Saver mode and later in Normal mode again.

Two ways of fixing this: Reboot your phone OR (much faster, but Terminal required) kill the "msyncd" process of the Buteo-Sync-Framework for which AccuWeather just has a plugin for updating the homescreen widget.

After killing msyncd and restarting AccuWeather, a new instance of msyncd will be started, this time with the AccuWeather plugin correctly loaded again.
 
Posts: 397 | Thanked: 185 times | Joined on Oct 2011
#33
Originally Posted by marrat View Post
Observed another ocassion that AccuWeather wouldn't update anymore automatically after being in Power Saver mode and later in Normal mode again.

Two ways of fixing this: Reboot your phone OR (much faster, but Terminal required) kill the "msyncd" process of the Buteo-Sync-Framework for which AccuWeather just has a plugin for updating the homescreen widget.

After killing msyncd and restarting AccuWeather, a new instance of msyncd will be started, this time with the AccuWeather plugin correctly loaded again.
cant seemed to find the process using the top command
 
Posts: 418 | Thanked: 429 times | Joined on May 2011
#34
Originally Posted by kai_en View Post
cant seemed to find the process using the top command
Look with 'ps'

> ps | grep msyncd

and then

> kill <msyncd PID>
 
Posts: 397 | Thanked: 185 times | Joined on Oct 2011
#35
Originally Posted by marrat View Post
Look with 'ps'

> ps | grep msyncd

and then

> kill <msyncd PID>
1280 user /usr/bin/msyncd

so this is the process that i should be killing?
 
Posts: 303 | Thanked: 637 times | Joined on Jan 2012 @ Enschede, The Netherlands
#36
I'd try to do it the nice way first, by graciously restarting the service instead of recklessly killing it:

Code:
~ # /sbin/initctl restart xsession/msyncd
Run as root. No need to look up the PID.

However, it didn't help in my case (killing msynd didn't either).
 

The Following User Says Thank You to Fuzzillogic For This Useful Post:
Posts: 418 | Thanked: 429 times | Joined on May 2011
#37
Originally Posted by kai_en View Post
1280 user /usr/bin/msyncd

so this is the process that i should be killing?
Yes, that helped for me.

In your case it would be

> kill 1280

But as I see, for Fuzzillogic it didn't help... Strange bugs are strange...
 
Posts: 242 | Thanked: 124 times | Joined on Dec 2010
#38
The problem is back!

After I had made the update from Accuweather, the weather situation has not been updated on the screen. This problem could be solved as follows:

http://talk.maemo.org/showpost.php?p...8&postcount=16

Now, this problem reappeared, though in the meantime I have done nothing else except phone-calls, internet, sms and installed two games from the store ( Bugs Smoke + Free Cell).

For a complete information: I'm actually running PR 1.1 because the damn "country variant".
 
Posts: 648 | Thanked: 648 times | Joined on Oct 2011
#39
Originally Posted by cddiede View Post
Well, I've disabled devel mode, uninstalled dev-utils and dev mode packages. Then I rebooted, refreshed the accuweather, re-enabled dev mode, and re-installed the devel packages that were removed.

So far my weather icon hasn't blanked out, but I'll keep watching it...
I did the above and Accuweather is updating. But there is still a strange bug. After coming out of airplane mode Accuweather refuse to update until a reboot. Very annoying.
 
Posts: 418 | Thanked: 429 times | Joined on May 2011
#40
Originally Posted by SamGan View Post
I did the above and Accuweather is updating. But there is still a strange bug. After coming out of airplane mode Accuweather refuse to update until a reboot. Very annoying.
Yes, after flight mode I have the same problem. But killing msyncd solves the problem for me without rebooting.
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 01:12.