Reply
Thread Tools
Posts: 323 | Thanked: 179 times | Joined on Oct 2009 @ Gent, Belgium
#161
some update on Nemo booting in Bootmenu u-boot.

David Greaves has added a hint to the Nemo bug report on what to patch to MAYBE allow the NEMO kernel to boot on our hw.
I took that patch, rebased it on our 2.6.37 kernel (here) and created the kernel in COBS.

Can anyone take the uImage and modules out of my latest compiled kernel (including that patch) here and try it on a freshly prepared NEMO SD card install ?

It could actually be in the right area, the patch, as I did see once a complete SD card corruption after trying to boot from it, with the stock NEMO kernel, requiring a lowlevel format. And that can only happen during writes

I'm being 'attacked' at my normal business job here, otherwise I would do the testing myself.

Please let me know the results.
 

The Following 6 Users Say Thank You to Netweaver For This Useful Post:
Posts: 1,445 | Thanked: 2,587 times | Joined on Feb 2011 @ Germany
#162
Originally Posted by Fabry View Post
Not "/dst-part" but "dst-part".
So: mount -t ext4 -o noatime /dev/mmcblk0p4 dst-part

With "/dst-part" you search on root dir and theorically dst-part is on /home/user, so wrong path
No idea what that's about. I assumed "dst-part" was just a generic placeholder for the name of a mount point.

In any case, the spacing was all wrong. The choice of a mount point is something very personal so it's none of my business...
 
Posts: 1,223 | Thanked: 1,870 times | Joined on Feb 2011 @ Quezon City, Philippines
#163
Originally Posted by Netweaver View Post
Can anyone take the uImage and modules out of my latest compiled kernel (including that patch) here and try it on a freshly prepared NEMO SD card install ?
The link needs a username and password. Can you upload it somewhere else?
__________________
N9 PR 1.3 Open Mode + kernel-plus for Harmattan
@imblying, working on Glacier for Nemo.
 
Posts: 323 | Thanked: 179 times | Joined on Oct 2009 @ Gent, Belgium
#164
sorry, this link should work. Forgot about the login requirements.

I just quickly took the rpm, the uImage and all you might wanna see/know about the kernel is in there.
http://www.filefactory.com/file/c445...00_armv7hl_rpm
 

The Following User Says Thank You to Netweaver For This Useful Post:
Posts: 323 | Thanked: 179 times | Joined on Oct 2009 @ Gent, Belgium
#165
updating my own request.

I ran the modified kernel on a newly prepared card and still the same issue
After 100s of error -110 it does fall through to a proper Nemo Mobile screen but again 100s of error -110 later it finally stops with a systemd-fsck alert.
It was worth the try. Please also try on other cards/environments.

I'll update the bug to say it's not the definitive solution.
 
Posts: 1,223 | Thanked: 1,870 times | Joined on Feb 2011 @ Quezon City, Philippines
#166
Tried on a 2GB Nokia uSD and 32GB Sandisk Class 4.
Both ended up exploding under Nemo.

Lemme try once more.
__________________
N9 PR 1.3 Open Mode + kernel-plus for Harmattan
@imblying, working on Glacier for Nemo.
 
Posts: 146 | Thanked: 89 times | Joined on Sep 2010 @ Krugersdorp
#167
I installed this u-boot, and got the penguin logo fine. system booted using stock kernel. since i use kp49, i rebooted and tried to choose kp49, but device stopped at Loading Kernel... stage. after several tries, and edits of /etc/bootmenu.d/ files, nothing at all boots, not even stock kernel.

I understand i must have done something wrong somewhere. anyone can help me 'fix' this? now i can't even charge the device by the way.

I'm sure my rootfs is still fine though, so I don't think a reflash is needed, yet. I suppose there should be some command (maybe via flasher utility) which would 'override' u-boot, allowing me to boot into maemo normally.

Please help

Last edited by qhubekela; 03-27-2012 at 06:11 AM. Reason: add more info
 
Posts: 146 | Thanked: 89 times | Joined on Sep 2010 @ Krugersdorp
#168
well, further investigations showed that there were kernel panics as per http://talk.maemo.org/showthread.php?t=83094 thread. so i'll rescue whatever files i can and reflash.
 
Posts: 146 | Thanked: 89 times | Joined on Sep 2010 @ Krugersdorp
#169
FIXED: you can follow the discussion with Pali and NIN101 here: http://mg.pov.lt/maemo-irclog/%23mae...03-28T22:46:34

No reflash was needed.
 
Posts: 1,223 | Thanked: 1,870 times | Joined on Feb 2011 @ Quezon City, Philippines
#170
Tested the latest Nemo image on eMMC - no -110 errors at all.

However, performance is completely destroyed, and totally unusable.
__________________
N9 PR 1.3 Open Mode + kernel-plus for Harmattan
@imblying, working on Glacier for Nemo.
 
Reply

Tags
bootmenu, u-boot

Thread Tools

 
Forum Jump


All times are GMT -4. The time now is 07:03 PM.