Notices


Reply
Thread Tools
Posts: 1,376 | Thanked: 2,073 times | Joined on Nov 2009 @ Dublin, Ireland
#171
A new release r2693 is available for fheroes2. We are being left behind.
 
Posts: 131 | Thanked: 239 times | Joined on Feb 2012
#172
I was able to build the revision 2764 using scratchbox und play the game in the scratchbox under Xephyr.

I installed libsdl-mixeroggwav1.2-dev instead of libsdl-mixer1.2-dev. I used
make RELEASE=1 WITH_AI=simple
to compile. It was not necessary to change the sourcecode. This version supports right click emulation out of the box. It is possible to enable this in the game.

How can i proceed? I have a working version, but i dont now how to build a deb package and upload it under fheroes2 under devel.

Last edited by HolgerN; 2012-04-02 at 15:28. Reason: removed not working link
 

The Following 3 Users Say Thank You to HolgerN For This Useful Post:
Posts: 1,376 | Thanked: 2,073 times | Joined on Nov 2009 @ Dublin, Ireland
#173
Hi, first of all thanks for this. Packaging is not so difficult and once you have a working .deb, uploading to the repos is the easiest part. There is a complete Wiki about how to do it here.

You can also take a look at this tutorial by Ammyt.
 

The Following 2 Users Say Thank You to ivgalvez For This Useful Post:
Posts: 131 | Thanked: 239 times | Joined on Feb 2012
#174
Ok the new package is now in extras-devel.

I hope everything works.

after installation, you have to do the following steps:

Copy your data into /opt/fheroes2/data

copy your maps into /opt/fheroes2/maps

If you upgrade fheroes2 then you have to move the content from /opt/fheroes2/files/data into /opt/fheroes2/data and the content from /opt/fheroes2/files/maps into /opt/fheroes2/maps

If you upgrade copy also /opt/fheroes2/fheroes2_default.cfg to /home/user/.fheroes2/fheroes2.cfg

In order to enable right button emulation, start the game, click on new game and then on config.

Below is option
pocketpc: tap mode
enable this.

I hope everything works, as this is my first debian package and my first maemo package.

Attention all old save game are not working!

Last edited by HolgerN; 2012-03-23 at 18:18.
 

The Following User Says Thank You to HolgerN For This Useful Post:
Posts: 1,376 | Thanked: 2,073 times | Joined on Nov 2009 @ Dublin, Ireland
#175
Wow! that was fast, congratulations.

I'll test it as soon as possible and provide you feedback. However if this is going to be promoted to Testing at any time, you should provide an upgrade path for current users with a postinst script that checks and moves all the related stuff.

Edit: Upgrading from previous version throws error:

error setting ownership of './opt/fheroes2/files/music/README'

Because I had all data, maps and music symlinked to MyDocs, so I can override it easily.

Last edited by ivgalvez; 2012-03-23 at 19:23.
 

The Following User Says Thank You to ivgalvez For This Useful Post:
Posts: 131 | Thanked: 239 times | Joined on Feb 2012
#176
Thank you for your feedback.
I will have a closer look on the post install script. I will remove the creation of maps, data and music from debian/rules into the postintall script.

If you replace your links by normal directories, then it should be possible to upgrade.
 

The Following User Says Thank You to HolgerN For This Useful Post:
Posts: 131 | Thanked: 239 times | Joined on Feb 2012
#177
I updated the package and now everything should work. An uprade from 0.5 should work automatically.

Please test and report errors.
 

The Following User Says Thank You to HolgerN For This Useful Post:
Posts: 1,376 | Thanked: 2,073 times | Joined on Nov 2009 @ Dublin, Ireland
#178
Apparently version maemo-5 overwrites data and maps directories. I had them symlinked to MyDocs (from /opt/fheroes2) and the symlinks were replaced by empty directories.

Besides, I'm not able to play any music. I had the music files in ogg format in /opt/fheroes2/files/music (symlinked) but nothing is played.

Apart from that, the game runs perfectly. Thanks.
 

The Following User Says Thank You to ivgalvez For This Useful Post:
Posts: 131 | Thanked: 239 times | Joined on Feb 2012
#179
If you edit the file /home/user/.fheroes2/fheroes2.cfg and change

music = ext
then ogg music should work.
 

The Following User Says Thank You to HolgerN For This Useful Post:
Posts: 1,376 | Thanked: 2,073 times | Joined on Nov 2009 @ Dublin, Ireland
#180
Done! thank you very much.
 
Reply

Tags
fheroes2, homm2

Thread Tools

 
Forum Jump


All times are GMT. The time now is 23:32.