Notices


Reply
Thread Tools
Posts: 131 | Thanked: 239 times | Joined on Feb 2012
#121
There is a port to maemo for openxcom

http://mobile4dev.blogspot.de/2011/0...aemo-n900.html

I don't now if it work or not.
 

The Following 3 Users Say Thank You to HolgerN For This Useful Post:
Estel's Avatar
Posts: 4,737 | Thanked: 7,739 times | Joined on Mar 2011
#122
Originally Posted by HolgerN View Post
There was a typo in the control file. Everything should work now. Iibzma1 is added now.
Thanks for looking into this, yet, unfortunately, still no joy During update, lzma1 wasn't listed as dependency, and trying to run OpenTTD result in same error as in last report.

Of course, i could just install dependency manually, yet, I would like to help debugging this issue.

/Estel

// Edit

WTF package from repositories provides this? I wasn't able to find one. Maybe it's just isn't there, but was installed locally by some users?

for clarification, I got latest (-devel) lzma (4.43-14maemo5) and liblzma1 (4.999.9beta+20091116-1maemo1) installed (for ages).
__________________
N900's aluminum backcover / body replacement
-
N900's HDMI-Out
-
Camera cover MOD
-
Measure battery's real capacity on-device
-
TrueCrypt 7.1 | ereswap | bnf
-
Hardware's mods research is costly. To support my work, please consider donating. Thank You!

Last edited by Estel; 04-06-2012 at 07:03 PM.
 
Posts: 131 | Thanked: 239 times | Joined on Feb 2012
#123
In the new version 1.1.5 of openttd i added one new build dependancy: liblzma-dev.

In build version 3 i added the dependency liblzma1 which is build from the same sources as liblzma-dev.

If this not working then there is maybe a bug in the liblzma package?

Last edited by HolgerN; 04-07-2012 at 10:46 AM.
 

The Following 2 Users Say Thank You to HolgerN For This Useful Post:
Estel's Avatar
Posts: 4,737 | Thanked: 7,739 times | Joined on Mar 2011
#124
why You added development files of libzma-dev = development files? Isn't userspace equivalent enough?

anyway, liblzma-dev depends on liblzma1, so i'm not sure if they're exactly same. In any case, after manually installing liblzma-dev it still *doesn't* work, splitting same error.

/Estel
__________________
N900's aluminum backcover / body replacement
-
N900's HDMI-Out
-
Camera cover MOD
-
Measure battery's real capacity on-device
-
TrueCrypt 7.1 | ereswap | bnf
-
Hardware's mods research is costly. To support my work, please consider donating. Thank You!
 
Posts: 131 | Thanked: 239 times | Joined on Feb 2012
#125
No, only for building i am using liblzma-dev and for normal use i have added only liblzma1 and not liblzma-dev.

Depends:

openttd-data (= 1.1.5-1maemo3), libc6 (>= 2.5.0-1), libfontconfig1 (>= 2.6.0-1osso1+0m5), libfreetype6 (>= 2.3.9-1osso2+0m5), libgcc1 (>= 4.2.1), liblzma1 (>= 4.999.9beta+20091116-1maemo1), liblzo2-2 (>= 2.03-1maemo3), libpng12-0 (>= 1.2.37-1maemo1+0m5), libsdl1.2 (>= 1.2.13-2maemo5+0m5), libstdc++6 (>= 4.2.1-4maemo9+0m5), libx11-6 (>= 1.1.99.5+0m5), zlib1g (>= 1.2.3-9.osso9+0m5), openttd-opengfx (>= 0.2.4), openttd-opensfx (>= 0.2.3)

Build-Depends:

:debhelper (>= 5), autotools-dev, quilt, sharutils, maemo-version, libsdl1.2-dev, libx11-dev, libfontconfig1-dev, x11proto-core-dev, zlib1g-dev, zlib1g, libfreetype6-dev, libpng12-dev, liblzo2-dev, m4, pkg-config, liblzma-dev

Last edited by HolgerN; 04-07-2012 at 03:20 PM.
 

The Following User Says Thank You to HolgerN For This Useful Post:
Posts: 781 | Thanked: 3,026 times | Joined on Mar 2009
#126
Just reflashed PR1.3, installed openttd from extras-devel (version 1.1.5-1maemo3)

It has dependencies:
liblzma1 liblzo2-2 openttd-data openttd-opengfx openttd-opensfx

Seems correct. These are versions of libraries:
liblzo2-2 2.03-1maemo3
liblzma1 4.999.9beta+20091116-1maemo1

Starting game from terminal with: /usr/games/openttd works as expected (=works).
 

The Following User Says Thank You to AapoRantalainen For This Useful Post:
Estel's Avatar
Posts: 4,737 | Thanked: 7,739 times | Joined on Mar 2011
#127
So it's only me? I've tried re-installing alongside purge, to no avail. Any ideas?
__________________
N900's aluminum backcover / body replacement
-
N900's HDMI-Out
-
Camera cover MOD
-
Measure battery's real capacity on-device
-
TrueCrypt 7.1 | ereswap | bnf
-
Hardware's mods research is costly. To support my work, please consider donating. Thank You!
 
Posts: 781 | Thanked: 3,026 times | Joined on Mar 2009
#128
Originally Posted by Estel View Post
Any ideas?
Do you have the same?
Code:
apt-cache policy liblzo2-2 liblzma1
liblzo2-2:
  Installed: 2.03-1maemo3
  Candidate: 2.03-1maemo3
  Version table:
 *** 2.03-1maemo3 0
        500 https://downloads.maemo.nokia.com ./ Packages
        500 https://downloads.maemo.nokia.com ./ Packages
        100 /var/lib/dpkg/status
liblzma1:
  Installed: 4.999.9beta+20091116-1maemo1
  Candidate: 4.999.9beta+20091116-1maemo1
  Version table:
 *** 4.999.9beta+20091116-1maemo1 0
        500 http://repository.maemo.org fremantle/free Packages
        100 /var/lib/dpkg/status
Is your error really:
Code:
liblzma.se.0: cannot open shared object file: No such file or directory
Or is it liblzma.so.0?

Is this same:
Code:
ldd /usr/games/openttd
        libX11.so.6 => /usr/lib/libX11.so.6 (0x4002f000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x4011e000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x401ff000)
        libSDL-1.2.so.0 => /usr/lib/libSDL-1.2.so.0 (0x4021f000)
        libz.so.1 => /usr/lib/libz.so.1 (0x4027f000)
        liblzma.so.0 => /usr/lib/liblzma.so.0 (0x40297000)
        liblzo2.so.2 => /usr/lib/liblzo2.so.2 (0x402be000)
        libpng12.so.0 => /usr/lib/libpng12.so.0 (0x402e3000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x4030b000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x40334000)
        libm.so.6 => /lib/libm.so.6 (0x403a7000)
        libc.so.6 => /lib/libc.so.6 (0x4041d000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x40542000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0x40554000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x4055e000)
        libdl.so.2 => /lib/libdl.so.2 (0x4056a000)
        /lib/ld-linux.so.3 (0x40000000)
        libasound.so.2 => /usr/lib/libasound.so.2 (0x40575000)
        libpulse-simple.so.0 => /usr/lib/libpulse-simple.so.0 (0x40631000)
        libpulse.so.0 => /usr/lib/libpulse.so.0 (0x4063b000)
        libexpat.so.1 => /usr/lib/libexpat.so.1 (0x40663000)
        librt.so.1 => /lib/librt.so.1 (0x40689000)
        libpulsecommon-0.9.15.so => /usr/lib/libpulsecommon-0.9.15.so (0x40698000)
        libdbus-1.so.3 => /usr/lib/libdbus-1.so.3 (0x406c8000)
        libgdbm.so.3 => /usr/lib/libgdbm.so.3 (0x40705000)
How about these:
Code:
md5sum /opt/maemo/usr/lib/liblzma.so.0.0.0 /usr/games/openttd
498f39800e398551962e17d1ecbd569e  /opt/maemo/usr/lib/liblzma.so.0.0.0
8f6805b0e07e4dcc60587c999896643b  /usr/games/openttd

Last edited by AapoRantalainen; 04-07-2012 at 04:20 PM.
 

The Following User Says Thank You to AapoRantalainen For This Useful Post:
Estel's Avatar
Posts: 4,737 | Thanked: 7,739 times | Joined on Mar 2011
#129
//Edit: Solved, see last edit, left post for records.

Originally Posted by AapoRantalainen View Post
Do you have the same?
Code:
apt-cache policy liblzo2-2 liblzma1
liblzo2-2:
  Installed: 2.03-1maemo3
  Candidate: 2.03-1maemo3
  Version table:
 *** 2.03-1maemo3 0
        500 https://downloads.maemo.nokia.com ./ Packages
        500 https://downloads.maemo.nokia.com ./ Packages
        100 /var/lib/dpkg/status
liblzma1:
  Installed: 4.999.9beta+20091116-1maemo1
  Candidate: 4.999.9beta+20091116-1maemo1
  Version table:
 *** 4.999.9beta+20091116-1maemo1 0
        500 http://repository.maemo.org fremantle/free Packages
        100 /var/lib/dpkg/status
Yea, same here (with "500" listed 2 times):
Code:
apt-cache policy liblzo2-2 liblzma1
liblzo2-2:
  Installed: 2.03-1maemo3
  Candidate: 2.03-1maemo3
  Version table:
 *** 2.03-1maemo3 0
        500 https://downloads.maemo.nokia.com ./ Packages
        500 https://downloads.maemo.nokia.com ./ Packages
        100 /var/lib/dpkg/status
liblzma1:
  Installed: 4.999.9beta+20091116-1maemo1
  Candidate: 4.999.9beta+20091116-1maemo1
  Version table:
 *** 4.999.9beta+20091116-1maemo1 0
        500 http://repository.maemo.org fremantle/free Packages
        500 http://repository.maemo.org fremantle/free Packages
       100 /var/lib/dpkg/status
Is your error really:
Code:
liblzma.se.0: cannot open shared object file: No such file or directory
Or is it liblzma.so.0?
Of course liblzma.so.0 . Stupid typo from my side, sorry.

Originally Posted by AapoRantalainen View Post
How about these:
Code:
md5sum /opt/maemo/usr/lib/liblzma.so.0.0.0 /usr/games/openttd
498f39800e398551962e17d1ecbd569e  /opt/maemo/usr/lib/liblzma.so.0.0.0
8f6805b0e07e4dcc60587c999896643b  /usr/games/openttd
/opt/maemo/usr/lib/liblzma* - no such file or directory (by * I mean that there is nothing with this name, including any wildcard). for OpenTTD, md5sum is OK.

Will check rest tomorrow, yet, it seems obvious that missing liblzma.so* is the case of problem. How come?

/Estel

// Edit
dpkg -L liblzma1
...then --purge'ing it, then removing any leftovers from list and installing again solved problem. I got NFC why it was looking like that... Thanks for help with hammering this out!
__________________
N900's aluminum backcover / body replacement
-
N900's HDMI-Out
-
Camera cover MOD
-
Measure battery's real capacity on-device
-
TrueCrypt 7.1 | ereswap | bnf
-
Hardware's mods research is costly. To support my work, please consider donating. Thank You!

Last edited by Estel; 04-07-2012 at 11:50 PM.
 
Posts: 131 | Thanked: 239 times | Joined on Feb 2012
#130
New stable release 1.2.0 is available in extras-devel.
 

The Following 6 Users Say Thank You to HolgerN For This Useful Post:
Reply

Tags
games, openttd, port, sdl

Thread Tools

 
Forum Jump


All times are GMT -4. The time now is 07:18 AM.