Notices


Reply
Thread Tools
Posts: 930 | Thanked: 3,376 times | Joined on Apr 2010 @ Czech Republic
#981
Originally Posted by rotoflex View Post
Installation notes for N900:
Code:
root
Nokia-N900:~# apt-get python-qtmobility12, python-pyside.qtgui, python-pyside.qtdeclarative, qt-components-10, espeak, python

E: Invalid operation python-qtmobility12,
also

Code:
apt-get install python-qtmobility12, python-pyside.qtgui, python-pyside.qtdeclarative, qt-components-10, espeak, python

(Reading package lists, Building dependency tree, Reading state information, etc.)

E: Couldn't find package python-qtmobility12,
Oh, now I see it, thanks ! I took the dependencies directly from the package description, where they are delimited by commas - they are of course delimited by whitespace in apt-get. So this is the correct command (I have also updated the release post):
Code:
apt-get install python-qtmobility12 python-pyside.qtgui python-pyside.qtdeclarative qt-components-10 espeak python
__________________
modRana: a flexible GPS navigation system
Mieru: a flexible manga and comic book reader

Thanks to everyone who voted for modRana & Mieru in the Maemo.org coding competition !

Last edited by MartinK; 04-15-2012 at 08:23 PM. Reason: spellcheck :)
 

The Following 2 Users Say Thank You to MartinK For This Useful Post:
Posts: 440 | Thanked: 159 times | Joined on Aug 2010 @ Las Vegas, NV
#982
-Change the title from modrana.py to Modrana or something.
-While not in full screen the lower row of icons (Menu, Zoom in/out) goes below the screen edge.
-Map layer names are variable namish rather than user friendly names (gsat instead of usual Google Satellite), Title is also not proper yet.

Thanks for mock up. Implemented stuffs seems to work fine!

Btw what is the short horizontal line at upper right end?
 

The Following User Says Thank You to Joseph9560 For This Useful Post:
Posts: 739 | Thanked: 112 times | Joined on Sep 2009
#983
Originally Posted by MartinK View Post
Oh, now I see it, thanks ! I took the dependencies dirrectly from the pacage description, where they are delimited by commas - they are of course delimited by whitespace in apt-get. So this is the correct command (I have also updated the release post):
Code:
apt-get install python-qtmobility12 python-pyside.qtgui python-pyside.qtdeclarative qt-components-10 espeak python
Still show "Couldn't find package python-qtmobility12"
 
Posts: 92 | Thanked: 95 times | Joined on Feb 2010 @ Smyrna, Atlanta / Bangalore, India
#984
Originally Posted by romanianusa View Post
Still show "Couldn't find package python-qtmobility12"
same here.. i have all the repos enabled
 
Posts: 1,523 | Thanked: 1,991 times | Joined on Jul 2011 @ not your mom's FOSS basement
#985
Originally Posted by MartinK View Post
Where can I get it ?
The deb packages packages are available from two separate OBS repositories, one for Fremantle and one for Harmattan:
Fremantle repository
Harmattan repository
Should there be any difference? I think you wrote the same path for both repositories. And i can't find anything else under "modrana:/modrana-fremantle/" than the Harmattan target.
 
Posts: 930 | Thanked: 3,376 times | Joined on Apr 2010 @ Czech Republic
#986
Originally Posted by Joseph9560 View Post
-Change the title from modrana.py to Modrana or something.
Done.

Originally Posted by Joseph9560 View Post
-While not in full screen the lower row of icons (Menu, Zoom in/out) goes below the screen edge.
Yeah, I noticed that too. I'll investigate whats causing it (probably the QML viewport in Fremantle not being notified of its size changing or something).

Originally Posted by Joseph9560 View Post
-Map layer names are variable namish rather than user friendly names (gsat instead of usual Google Satellite), Title is also not proper yet.
Done.

Originally Posted by Joseph9560 View Post
Thanks for mock up. Implemented stuffs seems to work fine!

Btw what is the short horizontal line at upper right end?
That should be the scale indicator - looks like the label (5km etc.) does not show up for some reason.

Originally Posted by romanianusa View Post
Still show "Couldn't find package python-qtmobility12"
Originally Posted by bipinbn View Post
same here.. i have all the repos enabled
The package is in Extras-devel repository - check if you have it enabled.

Originally Posted by don_falcone View Post
Should there be any difference? I think you wrote the same path for both repositories. And i can't find anything else under "modrana:/modrana-fremantle/" than the Harmattan target.
There is AFAIK no working Fremantle target on the (C)OBS so I just use the Harmattan target for both. As modRana is written in Python and nothing is actually being compiled, its not a problem.

The packages just have different startup scripts, icons and desktop files. Also the Harmattan package is build with Aegis support - otherwise modRana would not be able to use GPS on the N9/N950.
__________________
modRana: a flexible GPS navigation system
Mieru: a flexible manga and comic book reader

Thanks to everyone who voted for modRana & Mieru in the Maemo.org coding competition !
 

The Following 3 Users Say Thank You to MartinK For This Useful Post:
Posts: 739 | Thanked: 112 times | Joined on Sep 2009
#987
Originally Posted by MartinK View Post



The package is in Extras-devel repository - check if you have it enabled.


.
I'll never be able to install Modrana again. It shows error: "Your system has broken packages or you are trying to install conflicting packages."

I try uninstall the old version and try to upgrade to 0.29-2.....can't do it. Or reinstall everything over ...won't work either.

Extras-devel is enable.
 
Posts: 930 | Thanked: 3,376 times | Joined on Apr 2010 @ Czech Republic
#988
Originally Posted by romanianusa View Post
I'll never be able to install Modrana again. It shows error: "Your system has broken packages or you are trying to install conflicting packages."

I try uninstall the old version and try to upgrade to 0.29-2.....can't do it. Or reinstall everything over ...won't work either.

Extras-devel is enable.
Looks like broken package management on your device. Sometimes it can be fixed by running this command as root:
Code:
apt-get install -f
It tells the package manager to try to get the system back to a working state.
__________________
modRana: a flexible GPS navigation system
Mieru: a flexible manga and comic book reader

Thanks to everyone who voted for modRana & Mieru in the Maemo.org coding competition !
 
Posts: 739 | Thanked: 112 times | Joined on Sep 2009
#989
Originally Posted by MartinK View Post
Looks like broken package management on your device. Sometimes it can be fixed by running this command as root:
Code:
apt-get install -f
It tells the package manager to try to get the system back to a working state.
Thanks. It works now.
 

The Following User Says Thank You to romanianusa For This Useful Post:
Posts: 45 | Thanked: 20 times | Joined on Aug 2010 @ London
#990
Hi MartinK, I'm trying to install modRana on my N9 but even after making sure I have the up-to-date python dependencies you listed it is still failing installation and claims to not have found all of the dependencies. Is there something I'm leaving out? I used to use your app all the time on my N900 so thanks for all your work!
 
Reply

Tags
bada rox, martin_rocks, modrana, navigation, the best, wehasgps

Thread Tools

 
Forum Jump


All times are GMT -4. The time now is 05:15 PM.