coderus's Avatar
Posts: 4,041 | Thanked: 6,214 times | Joined on Nov 2011 @ Russia
#301
sorry, i don't know what it mean. i edit /etc/sudoers
 
qole's Avatar
Moderator | Posts: 7,098 | Thanked: 8,680 times | Joined on Oct 2007 @ Vancouver, BC, Canada
#302
Ah, the problem starts at install (dpkg -i sudo...deb):
Code:
aegis-installing sudo (from '')
Package sudo: denied 'CAP::setuid' -- origin '' does not allow it
Package sudo: denied 'CAP::setgid' -- origin '' does not allow it
Package sudo: denied 'CAP::setuid' for '/usr/bin/sudo' -- origin '' does not allow it
Package sudo: denied 'CAP::setgid' for '/usr/bin/sudo' -- origin '' does not allow it
Setting up sudo (1:1.6.8p12-4osso28+0m6) ...
__________________
qole.org --- twitter --- Easy Debian wiki page
Please don't send me a private message, post to the appropriate thread.
Thank you all for your donations!
 
qole's Avatar
Moderator | Posts: 7,098 | Thanked: 8,680 times | Joined on Oct 2007 @ Vancouver, BC, Canada
#303
Sigh, of course, even in 'open' mode, I am haunted by the ghost of Aegis.

Adding 'AEGIS_FIXED_ORIGIN=com.nokia.maemo' before dpkg fixes everything.
__________________
qole.org --- twitter --- Easy Debian wiki page
Please don't send me a private message, post to the appropriate thread.
Thank you all for your donations!
 
javispedro's Avatar
Posts: 2,123 | Thanked: 4,128 times | Joined on Jan 2009 @ Barcelona
#304
Originally Posted by qole View Post
Sigh, of course, even in 'open' mode, I am haunted by the ghost of Aegis.
Actually, all the current "openmode kernel" patch does is skip Aegis checks when you are root. It does not entirely disable Aegis because there's a bunch of stuff that still does weird things if you happen to do so.

Originally Posted by qole View Post
Adding 'AEGIS_FIXED_ORIGIN=com.nokia.maemo' before dpkg fixes everything.
And that works even under a vanilla kernel.
 
coderus's Avatar
Posts: 4,041 | Thanked: 6,214 times | Joined on Nov 2011 @ Russia
#305
AEGIS_FIXED_ORIGIN working only in OpenMode.
 
joerg_rw's Avatar
Posts: 1,884 | Thanked: 10,058 times | Joined on Mar 2010 @ SOL 3
#306
even a vanilla kernel can run in openmode, if it's an unsigned vanilla kernel
/j
__________________
Maemo Community Council member [2012-10, 2013-05, 2013-11, 2014-06 terms]
Hildon Foundation Council inaugural member.
MCe.V. foundation member

EX Hildon Foundation approved
Maemo Administration Coordinator (stepped down due to bullying 2014-04-05)
aka "techstaff" - the guys who keep your infra running - Devotion to Duty http://xkcd.com/705/

IRC(freenode): DocScrutinizer*
First USB hostmode fanatic, father of H-E-N
 

The Following User Says Thank You to joerg_rw For This Useful Post:
Posts: 1,214 | Thanked: 656 times | Joined on Dec 2010
#307
root is not in the sudoers file. This incident will be reported.

when i try to use sudo, any ideas?
 
Guest | Posts: n/a | Thanked: 0 times | Joined on
#308
Originally Posted by m4r0v3r View Post
root is not in the sudoers file. This incident will be reported.

when i try to use sudo, any ideas?
and just why do you run sudo as root?
nothing weird with that error at all
 
Posts: 1,214 | Thanked: 656 times | Joined on Dec 2010
#309
well it doesn't work no matter how i use it, whether it be sudo "command" or sudo -i otherwise what's the point of it, since am getting a permission denied error when i run ./configure as develsh, devel-su and just as the user so i thought maybe sudo could of sorted it out.
 
coderus's Avatar
Posts: 4,041 | Thanked: 6,214 times | Joined on Nov 2011 @ Russia
#310
@m4r0v3r, you don't know what is sudo?
read man linuxpages. sudo need for making actions as root from user, using user password. see? understand?
 
Reply

Tags
aegis, open kinda

Thread Tools

 
Forum Jump


All times are GMT. The time now is 02:48.