Reply
Thread Tools
int_ua's Avatar
Posts: 664 | Thanked: 1,021 times | Joined on Jul 2010 @ Kyiv, Ukraine
#1
I've deleted all games except chess (will add package names on request) and
Code:
osso-systemui-splashscreen
cherry
without losing any critical functionality.
Who tried any other package? Unsuccessfull strories?
__________________
I reckon current Russian government as fascist threat and everyone who supports it as my personal enemies. If you are one of those, prepend the info to anything else.

Last edited by int_ua; 2012-03-01 at 17:30.
 

The Following 4 Users Say Thank You to int_ua For This Useful Post:
Posts: 77 | Thanked: 58 times | Joined on Apr 2010 @ Germany
#2
Here is a list of all apps i remove when i flash my N900:
Code:
sudo apt-get remove
hildon-theme-beta
osso-chess-ui
gnuchess osso-graphics-game-chess
osso-lmarbles osso-graphics-game-lmarbles
osso-sounds-game-chess
maemoblocks
ap-installer amazon-installer foreca-installer facebook-installer skype-installer dtg-installer
tutorial-home-applet
osso-tutorial-l10n-engb
osso-tutorial-l10n-ptpt
osso-tutorial-l10n-frca
osso-tutorial-l10n-nlnl
osso-tutorial-l10n-cscz
osso-tutorial-l10n-itit
osso-tutorial-l10n-eses
osso-tutorial-l10n-svse
osso-tutorial-l10n-frfr
osso-tutorial-l10n-dede
osso-tutorial-l10n-fifi
osso-tutorial-l10n-nono
osso-tutorial-l10n-esmx
osso-tutorial-l10n-enus
osso-tutorial-l10n-ruru
osso-tutorial-l10n-mr0
osso-tutorial-l10n-plpl
So its just the games, the secondary theme and the whole tutorial and the installer apps, but i don't need them.
 

The Following 13 Users Say Thank You to Russe89 For This Useful Post:
Posts: 1,469 | Thanked: 2,705 times | Joined on Feb 2011 @ Germany
#3
but if I try removing e.g. cherry, then mp-fremantle-pr is removed, thus marking a number of (critical?) packages as auto-removeable!

do you install/reinstall those packages manually? or have you manipulated the mp-fremantle-pr metapackage to fix the dependencies?

at the moment saying that you can delete some of those packages "without losing any critical functionality" seems a bit of a risky statement.

I would also be interested in removing a whole bunch of things I don't need, but perhaps any of you who have actually done that could explain more in detail which steps you've followed?

Thanks.
 

The Following 3 Users Say Thank You to reinob For This Useful Post:
int_ua's Avatar
Posts: 664 | Thanked: 1,021 times | Joined on Jul 2010 @ Kyiv, Ukraine
#4
Originally Posted by reinob View Post
do you install/reinstall those packages manually? or have you manipulated the mp-fremantle-pr metapackage to fix the dependencies?
It was a long time ago when I deleted the games. I think I just marked them as manually-installed with apt-get install. Maybe I didn't notice and deleted something useful, please add the packages which are marked for auto-removal.
__________________
I reckon current Russian government as fascist threat and everyone who supports it as my personal enemies. If you are one of those, prepend the info to anything else.
 

The Following 2 Users Say Thank You to int_ua For This Useful Post:
Posts: 1,469 | Thanked: 2,705 times | Joined on Feb 2011 @ Germany
#5
@int_ua,

Sorry for the late reply.

Code:
# apt-get -s purge cherry
Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
   libtpsession (0.1-6+0m5)
   libqtm-serviceframework (1.0.2-maemo4+0m5)
   rtcom-accounts-plugin-facebook (4.140-1+0m5)
   libqt4-declarative (4.7.0~git20100909-0maemo1+0m5)
   rtcom-skype-emoticons-theme (0.0.7-2+0m5)
   libqtm-multimedia (1.0.2-maemo4+0m5)
   rtcom-accounts-voip-support (4.140-1+0m5)
   n900-fmrx-enabler (1.5-4+0m5)
   libqtm-publishsubscribe (1.0.2-maemo4+0m5)
   libconninet0 (0.40+0m5)
   libqtm-messaging (1.0.2-maemo4+0m5)
   qtm-modest-plugin (0.0.2-6+0m5)
   libqtm-location (1.0.2-maemo4+0m5)
   dsme-thermalobject-surface (0.0.1+0m5)
   modest-home-applet (0.0.4-5+0m5)
   libqtm-versit (1.0.2-maemo4+0m5)
   libconnsettings0 (0.23+0m5)
   microb-geolocation (1.1.5-6+0m5)
   libqtm-bearer (1.0.2-maemo4+0m5)
   libqt4-translations (4.7.0~git20100909-0maemo1+0m5)
   libtelepathy-qt4-0 (0.2.0-2maemo7+0m5)
   maemo-optify-runonce (0.10-32+0m5)
   libqtm-contacts (1.0.2-maemo4+0m5)
   libqtm-systeminfo (1.0.2-maemo4+0m5)
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
   cherry* (0.25-1+0m5)
   mp-fremantle-generic-pr* (21.2011.38-1)
0 upgraded, 0 newly installed, 2 to remove and 20 not upgraded.
Purg mp-fremantle-generic-pr [21.2011.38-1]
Purg cherry [0.25-1+0m5]
I suppose I could first mark (some of) those packages as manually installed so that they are not auto-remove'd, but I still find this dependency chaos very annoying.
 

The Following 4 Users Say Thank You to reinob For This Useful Post:
Posts: 781 | Thanked: 3,039 times | Joined on Mar 2009
#6
but I still find this dependency chaos very annoying.
Just reflashed device. Updated to the PR-1.3.1 with HAM
And then continued with apt-get -s purge cherry (or apt-get remove --purge cherry) and it will only uninstall cherry and mp-fremantle-generic-pr (not hundreds of packages)


Who tried any other package?
I started to fill this wikipage with my experiments:
http://wiki.maemo.org/Fremantle_closed_packages

If somebody want join filling, I have four steps to gather basic information.
Code:
#description
apt-cache show osso-systemui-splashscreen
#Provides files:
dpkg -L osso-systemui-splashscreen
#Current version
apt-cache policy osso-systemui-splashscree
#Reverse dependencies
apt-cache showpkg osso-systemui-splashscreen

#Remove (on device which can be reflashed)
apt-get remove --purge osso-systemui-splashscreen
And then I have explicitly state what happens when removed. I have tried to be verbose and comment every aspect.

I have found it is sometimes hard to say what is critical functionality. I have never used ActiveSync, so removing ActiveSync is not losing critical functionality? I rarely use bluetooth, so it is then not critical functionality? For sure when device will not start anymore = critical.
 

The Following 5 Users Say Thank You to AapoRantalainen For This Useful Post:
Posts: 1,469 | Thanked: 2,705 times | Joined on Feb 2011 @ Germany
#7
Originally Posted by AapoRantalainen View Post
Just reflashed device. Updated to the PR-1.3.1 with HAM
And then continued with apt-get -s purge cherry (or apt-get remove --purge cherry) and it will only uninstall cherry and mp-fremantle-generic-pr (not hundreds of packages)
A few days ago I decided to remove mp-fremantle-generic-pr. That was the only package that was removed, but then the list of packages I posted above are marked as being auto removeable.

I manually installed some of them (the ones that sounded like I could need them) and then did auto remove of the rest. Everything's OK for now (I didn't dare reboot yet..)

I'm going through a list of all packages in my N900 and marking the ones I would like to remove (particularly all l10n packages for language/country combinations that I will never need), but I'm still in the "preparation phase" (just editing my list on the computer).

It will take time until I actually do that, but then I'll post my results (if at all relevant). I have never flashed my N900.. and would like to keep it that way
 

The Following 3 Users Say Thank You to reinob For This Useful Post:
Posts: 1,469 | Thanked: 2,705 times | Joined on Feb 2011 @ Germany
#8
I have also removed qtm-maemo-metapackage and its dependencies (libqtm-*), as no other package seems to depend on that (YMMV).

You can check it here:
http://maemo.org/packages/package_in...age/1.3-2+0m5/
 

The Following 4 Users Say Thank You to reinob For This Useful Post:
Posts: 1,469 | Thanked: 2,705 times | Joined on Feb 2011 @ Germany
#9
Soo.. I just shutdown and turned on my N900 again. No problems at all.

I marked the following as manually installed (because of mp-fremantle-generic-pr):

Code:
	libtpsession (0.1-6+0m5)
	rtcom-accounts-plugin-facebook (4.140-1+0m5)
	libqt4-declarative (4.7.0~git20100909-0maemo1+0m5)
	rtcom-skype-emoticons-theme (0.0.7-2+0m5)
	rtcom-accounts-voip-support (4.140-1+0m5)
	n900-fmrx-enabler (1.5-4+0m5)
	libconninet0 (0.40+0m5)
	dsme-thermalobject-surface (0.0.1+0m5)
	modest-home-applet (0.0.4-5+0m5)
	libconnsettings0 (0.23+0m5)
	microb-geolocation (1.1.5-6+0m5)
	libqt4-translations (4.7.0~git20100909-0maemo1+0m5)
	libtelepathy-qt4-0 (0.2.0-2maemo7+0m5)
and then purge-removed the following:
Code:
mp-fremantle-generic-pr
libqtm-*
maemo-optify-runonce
cherry
sharing-service-flickr
sharing-service-ovi
chinese-font
google-search-widget
tutorial-home-applet
osso-tutorial*
testserver
{ap,amazon,foreca,facebook,skype,dtg}-installer
osso-lmarbles, osso-graphics-game-lmarbles
osso-mahjon, osso-graphics-game-mahjong, osso-sounds-game-mahjong
maemoblocks
osso-rss-feed-reader*
qtm-modest-plugin
So far so good.

Next in line are *-l10n-* (except -mr0 and -enus, -dede)
as well as ezitext-* (I don't even use the VKB at all).

Next-next in line are:
osso-systemui-splashscreen (need to make sure first)
hildon-welcome (same thing)
kernel-modules (from stock kernel, I only use kp50 now).
 

The Following 8 Users Say Thank You to reinob For This Useful Post:
int_ua's Avatar
Posts: 664 | Thanked: 1,021 times | Joined on Jul 2010 @ Kyiv, Ukraine
#10
An old script that I've used to purge locales manually (there were some dependencies preventing me from purging packages IIRC):
http://talk.maemo.org/showthread.php?t=61824
__________________
I reckon current Russian government as fascist threat and everyone who supports it as my personal enemies. If you are one of those, prepend the info to anything else.
 

The Following 4 Users Say Thank You to int_ua For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 07:45.