Reply
Thread Tools
Posts: 781 | Thanked: 3,039 times | Joined on Mar 2009
#41
Originally Posted by szopin View Post
/usr/bin/ld: BFD (GNU Binutils for Debian) 2.22 assertion fail ../../bfd/elf32-arm.c:11467
Assertation comes from ld, which comes from package binutils and source file is elf32-arm.c.
Comment above assert is
If the output has no requirement about FP hardware, follow the requirement of the input.
FP=floating point
I don't know what are these requirements, what they should be, where or how they should be defined.
*when gcc is compiled?
*when binutils is compiled?
*when gcc and binutils are used?

--
Assertation is easily disabled, just remove mentioned line on mentioned file and recompile binutils. It will work same way after that, without nagging. But there might be good reason for that assertation failing and that should be fixed.
 

The Following 2 Users Say Thank You to AapoRantalainen For This Useful Post:
Posts: 1,385 | Thanked: 2,087 times | Joined on Nov 2009 @ Dublin, Ireland
#42
Could it be possible to, at least, upgrade the OBS and Scratchbox to gcc4.4?

That would be a point to start with. Rebuild CSSU, then start rebuildong some application in extras-devel, finally every new application pushed to extras could then be built with a newer version of the compiler.
 

The Following 2 Users Say Thank You to ivgalvez For This Useful Post:
Posts: 2,613 | Thanked: 2,830 times | Joined on May 2011 @ Poland
#43
Originally Posted by ivgalvez View Post
Could it be possible to, at least, upgrade the OBS and Scratchbox to gcc4.4?

That would be a point to start with. Rebuild CSSU, then start rebuildong some application in extras-devel, finally every new application pushed to extras could then be built with a newer version of the compiler.
http://forum.meego.com/showpost.php?p=27649&postcount=2

Here is how to add the harmattan repository. Libstdc++6 v4.4 is out there.

I'm downloading Aapo's stuff, and will check it out.

EDIT: has anyone tried installing this directly on device?
__________________
If you want to support my work, you can DONATE

You're encouraged to donate at least a couple of euros - otherwise PayPal takes almost everything as a fee.

If you'd prefer other currency or form of donation, please contact me


MeeCoLay: run MeeGo Harmattan apps on Fremantle

Last edited by marmistrz; 2012-04-15 at 11:34.
 
Posts: 2,613 | Thanked: 2,830 times | Joined on May 2011 @ Poland
#44
Has anyone tried to compile libc6 >= 2.10?
I managed to run lots of harmattan apps using meego binaries + Aapo's libstdc++6, but now newer libc6 is missing. Binary ver. from meego not working
__________________
If you want to support my work, you can DONATE

You're encouraged to donate at least a couple of euros - otherwise PayPal takes almost everything as a fee.

If you'd prefer other currency or form of donation, please contact me


MeeCoLay: run MeeGo Harmattan apps on Fremantle
 
Posts: 781 | Thanked: 3,039 times | Joined on Mar 2009
#45
Originally Posted by marmistrz View Post
Has anyone tried to compile libc6 >= 2.10?
I'm on it, namely on trunk of elibc (version > 2.15). I'm not fully tested results or checked steps, but here comes sketch how it should go (my vision).

(I have binutils2.22 installed, not sure is it needed. More info later)

You need newer gcc than 4.2.


Libc needs autoconf2.68.

Autoconf2.68 needs:
m4 1.4.13, but we have only 1.4.8-2.
pkg-config 0.26, but we have only 0.22


Compiling m4 1.4.13:
Based on ubuntu 12.04 package
lower dependency of texi2html
Code:
#this check is failing
rm ./checks/005.command_li
#this test is failing
rm ./tests/test-spawn-pipe.sh
Installing m4
Code:
fakeroot dpkg -i

Compiling pkg-config 0.26
Based on ubuntu 12.04 package
Fetch debian/rules from Fremantles version


installing pkg-config
Code:
fakeroot dpkg -i ../pkg-config_0.26-1ubuntu1_armel.deb
#outside of scratchbox
sudo rm /scratchbox/devkits/autotools-legacy/bin/pkg-config
sudo ln -s /scratchbox/users/`whoami`/targets/FREMANTLE_ARMEL/usr/bin/pkg-config /scratchbox/devkits/autotools-legacy/bin/pkg-config

Compiling autoconf2.68
Based on ubuntu 12.04 package
Code:
echo 5 > /debian/compat

Installing autoconf
Code:
fakeroot dpkg -i ../autoconf_2.68-1ubuntu2_all.deb
#outside of scratchbox
sudo rm /scratchbox/devkits/autotools-legacy/bin/autoconf
sudo ln -s /scratchbox/users/`whoami`/targets/FREMANTLE_ARMEL/usr/bin/autoconf /scratchbox/devkits/autotools-legacy/bin/autoconf

Compiling eglibc
Code:
svn co svn://svn.eglibc.org/branches/eglibc-2_14 eglibc
mkdir eglibc_build
cd eglibc_build
CC=gcc-4.6 ../eglibc/libc/configure --enable-add-ons=nptl,../eglibc/ports --prefix=/opt/
make
 

The Following 7 Users Say Thank You to AapoRantalainen For This Useful Post:
Posts: 781 | Thanked: 3,039 times | Joined on Mar 2009
#46
@marmistrz Four weeks ago you advised me how to get binutils2.22 to the repository, now I'm trying to achieve it (some issues with autobuilder).

Package name is binutils2.22 (no conflicts with existing package names). It's files goes to the /usr/binutils2.22/bin, /usr/binutils2.22/lib and ... (no conflicts with existing files). And name of binaries is still as expected, e.g. ld.

And it is used:
Code:
PATH=/usr/binutils2.22/bin:$PATH
LD_LIBRARY_PATH=/usr/binutils2.22/lib:$LD_LIBRARY_PATH
 

The Following 11 Users Say Thank You to AapoRantalainen For This Useful Post:
Posts: 2,613 | Thanked: 2,830 times | Joined on May 2011 @ Poland
#47
Originally Posted by AapoRantalainen View Post
I'm on it, namely on trunk of elibc (version > 2.15). I'm not fully tested results or checked steps, but here comes sketch how it should go (my vision).

(I have binutils2.22 installed, not sure is it needed. More info later)

You need newer gcc than 4.2.


Libc needs autoconf2.68.

Autoconf2.68 needs:
m4 1.4.13, but we have only 1.4.8-2.
pkg-config 0.26, but we have only 0.22


Compiling m4 1.4.13:
Based on ubuntu 12.04 package
lower dependency of texi2html
Code:
#this check is failing
rm ./checks/005.command_li
#this test is failing
rm ./tests/test-spawn-pipe.sh
Installing m4
Code:
fakeroot dpkg -i

Compiling pkg-config 0.26
Based on ubuntu 12.04 package
Fetch debian/rules from Fremantles version


installing pkg-config
Code:
fakeroot dpkg -i ../pkg-config_0.26-1ubuntu1_armel.deb
#outside of scratchbox
sudo rm /scratchbox/devkits/autotools-legacy/bin/pkg-config
sudo ln -s /scratchbox/users/`whoami`/targets/FREMANTLE_ARMEL/usr/bin/pkg-config /scratchbox/devkits/autotools-legacy/bin/pkg-config

Compiling autoconf2.68
Based on ubuntu 12.04 package
Code:
echo 5 > /debian/compat

Installing autoconf
Code:
fakeroot dpkg -i ../autoconf_2.68-1ubuntu2_all.deb
#outside of scratchbox
sudo rm /scratchbox/devkits/autotools-legacy/bin/autoconf
sudo ln -s /scratchbox/users/`whoami`/targets/FREMANTLE_ARMEL/usr/bin/autoconf /scratchbox/devkits/autotools-legacy/bin/autoconf

Compiling eglibc
Code:
svn co svn://svn.eglibc.org/branches/eglibc-2_14 eglibc
mkdir eglibc_build
cd eglibc_build
CC=gcc-4.6 ../eglibc/libc/configure --enable-add-ons=nptl,../eglibc/ports --prefix=/opt/
make
Could you upload some binaries as soon as you have 'em?
I could test whether it works with forum-tmo from meego.
__________________
If you want to support my work, you can DONATE

You're encouraged to donate at least a couple of euros - otherwise PayPal takes almost everything as a fee.

If you'd prefer other currency or form of donation, please contact me


MeeCoLay: run MeeGo Harmattan apps on Fremantle

Last edited by marmistrz; 2012-05-22 at 11:25.
 
Posts: 781 | Thanked: 3,039 times | Joined on Mar 2009
#48
Originally Posted by marmistrz View Post
Could you upload some binaries as soon as you have 'em?
eglibc-svn-r18520 (2012-05-12 18:44:41)
http://cc.oulu.fi/~rantalai/maemo/libc.so

It seems to work when used with LD_LIBRARY_PATH. I don't know how to overwrite system's libc (system reboots when I tried).
 

The Following 3 Users Say Thank You to AapoRantalainen For This Useful Post:
Posts: 2,613 | Thanked: 2,830 times | Joined on May 2011 @ Poland
#49
Originally Posted by AapoRantalainen View Post
eglibc-svn-r18520 (2012-05-12 18:44:41)
http://cc.oulu.fi/~rantalai/maemo/libc.so

It seems to work when used with LD_LIBRARY_PATH. I don't know how to overwrite system's libc (system reboots when I tried).
When put to /opt/meecolay/lib, named libc.so.6 (and set LD_LIBRARY_PATH to this)
this gives Segmentation fault.

Even running meecolay, which is just a modified /usr/bin/preenv script. (diff. vars & preloads) there is Segmentation fault

The same happens with MeeGo's libc6 (2.10 or 2.9 iirc)

is newer libstdc++ > 4.6 required or some other lib?
__________________
If you want to support my work, you can DONATE

You're encouraged to donate at least a couple of euros - otherwise PayPal takes almost everything as a fee.

If you'd prefer other currency or form of donation, please contact me


MeeCoLay: run MeeGo Harmattan apps on Fremantle
 
Posts: 525 | Thanked: 570 times | Joined on Apr 2011 @ Republic of the Philippines
#50
@AapoRantalainen
hope you don't mind this: http://talk.maemo.org/showthread.php?t=84322&page=7
though i don't think that's really the official nomination thread. just so you know that your effort's being appreciated.

sorry for being off-topic.
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 02:56.