Reply
Thread Tools
Posts: 529 | Thanked: 192 times | Joined on Aug 2010 @ UK
#11
Thanks for pointing out config file i shall sort that 2 moz now at some point .....

Originally Posted by Spyrocheti View Post
Hello, been following most of the threads for a year now, I just registered so I could answer to the following, since I faced the same problem and no clear explanation existed.

So if you, like I, after typing ./set get the permission denied try to chmod +x set and run ./set again.

PS if you'd also like to manually edit the config to point to metasploit because the OP's file is 0bytes ;p you can

cd /home/opt/set/config
vi set_config

use the arrows to find the line where it points to metasploit (you can't miss it)

type i to enter insert mode

edit the location (if you followed OP's guide on metasploit then it's /home/opt/msf)

hit the ESC button on screen to exit insert mode
type :wq to write/save and quit vi editor.

PS. since I can now post a huge thanks for all your hard work!!1
__________________
METASPLOIT INSTALL N900
Keep the forums clean
Dont forget to say thanks
 
D@vIcHoJD's Avatar
Posts: 236 | Thanked: 94 times | Joined on Jan 2012 @ Ecuador
#12
Originally Posted by one1002 View Post
hmm..strange..lol..

anyway, i tried 2nd option (Fast-Track Penetration Testing) but it says "PYSMSSQL is not installed. MSSQL attacks will not work!"

and it prompted me to download it from "code.google.com/pymssql/downloads/list"..

but it never prompt me about to download the "pexpect-2.3.tar.gz/download..

anyway, what does that pexpect-2.3 do?
Thanks for these great tools and you've been using a while but I have the same problem 2nd option (Fast-Track Penetration Testing) (MSSQL) and download the package mssql, it works, but when I enter SET again, asks me to reinstall the package, how to correct this problem .
 
Posts: 13 | Thanked: 15 times | Joined on Mar 2012
#13
Originally Posted by D@vIcHoJD View Post
Thanks for these great tools and you've been using a while but I have the same problem 2nd option (Fast-Track Penetration Testing) (MSSQL) and download the package mssql, it works, but when I enter SET again, asks me to reinstall the package, how to correct this problem .
Set does prompt you to download/install it for you, if you answer yes.
But you should notice that it actually tries to pull it from the (atm active) repositories and actually fails even though it reports that it completed successfully.

I tried with all known to me repositories active and still couldn't find the python-pymssql package

Last edited by Spyrocheti; 2012-04-18 at 05:38. Reason: pkgname typo
 

The Following User Says Thank You to Spyrocheti For This Useful Post:
Posts: 5 | Thanked: 2 times | Joined on Apr 2013
#14
it Works!! Excellent! thank you very much...




Here is the set_config file extracted and modified with the correct path /home/opt/msf3/

Backup the original file using the following command:

"cp /home/opt/set/config/set_config /home/opt/set/config/set_configOLD", and press enter, next

Put the new set_config file into your nokia N900 with Winscp or Filezilla Client browsing to /home/opt/set/config/

Answer to replace file question? YES!

its working so good on my N900, Greetings from México!, questions? visit OrlandoHC

Last edited by orlandohc; 2014-06-07 at 15:39.
 

The Following User Says Thank You to orlandohc For This Useful Post:
Posts: 6 | Thanked: 3 times | Joined on Jul 2013 @ Italy
#15
Can anyone update this thread? Because the links and related files are bit different. Thanks for the support.
 
Posts: 2 | Thanked: 0 times | Joined on Jan 2014
#16
hellooooooo fiends i couldn't fix this message that appers when i try to open set tool
/home/user # ./set
/binsh: ./set: permission denied






i really did this chmod +x set but it is still doesn't work
 
Posts: 6 | Thanked: 0 times | Joined on Feb 2014
#17
Originally Posted by alaa nokia n900 View Post
hellooooooo fiends i couldn't fix this message that appers when i try to open set tool
/home/user # ./set
/binsh: ./set: permission denied






i really did this chmod +x set but it is still doesn't work
same problem, can any1 help with that??
 
Guest | Posts: n/a | Thanked: 0 times | Joined on
#18
Originally Posted by centuu View Post
same problem, can any1 help with that??
because you installed SET in /home/user/set

Install in /home/opt/set
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 19:51.