Notices


Reply
Thread Tools
Estel's Avatar
Posts: 4,911 | Thanked: 8,167 times | Joined on Mar 2011
#51
It doesn't work for me. Also, in case Saturn missed it, encoding of special characters still doesn't work (at least, for polish special chars). Tried it both with sending SMS to myself, and just using smssend to input message into conversation - all special characters appear as junk.

/Estel

// Edit

As for long sms'es - while trying to send more than 70 characters, I just get "FAILED" after trying to send SMS, without any additional informations.
__________________
N900's aluminum backcover / body replacement
-
N900's HDMI-Out
-
Camera cover MOD
-
Measure battery's real capacity on-device
-
TrueCrypt 7.1 | ereswap | bnf
-
Hardware's mods research is costly. To support my work, please consider donating. Thank You!
 
Posts: 52 | Thanked: 33 times | Joined on Mar 2011 @ France
#52
For me it works with my special french chars now. Note that I always use the -C option...
 

The Following User Says Thank You to krutznikov For This Useful Post:
Estel's Avatar
Posts: 4,911 | Thanked: 8,167 times | Joined on Mar 2011
#53
Strange, because it replaces polish characters with junk no matter of -C or -c option (conversations window that pop-ups also contain text with junked polish characters).

/Estel
__________________
N900's aluminum backcover / body replacement
-
N900's HDMI-Out
-
Camera cover MOD
-
Measure battery's real capacity on-device
-
TrueCrypt 7.1 | ereswap | bnf
-
Hardware's mods research is costly. To support my work, please consider donating. Thank You!
 
sakya's Avatar
Posts: 533 | Thanked: 1,331 times | Joined on Dec 2010 @ Italy
#54
@Estel: What's your LANG?
Code:
echo $LANG
For this to correctly work in the N900 terminal you need to set it to UTF8:
Code:
export LANG="it_IT.UTF8"
 

The Following User Says Thank You to sakya For This Useful Post:
Estel's Avatar
Posts: 4,911 | Thanked: 8,167 times | Joined on Mar 2011
#55
Thanks, of course it was my noobines, and with LANG set to pl_PL.UTF8, it works correctly.

ho ever, I noticed another strange thing - when I try to send message with special characters using -c, I got loading screen, that closes itself after a while, and nothing else happens. When i use -C, ho ever, I got message sent properly.

Furthermore, using message with only one or two special characters, works well with -c! Still, when I try to send message with all (9 only) special characters, it just end as I described it (loading screen, and nothing happens).

/Estel

// Edit

Furthermore, despite -C working properly, even if I manage to make -c working (by using only few special characters), all of them are replaced by "?" symbol in conversations window.
__________________
N900's aluminum backcover / body replacement
-
N900's HDMI-Out
-
Camera cover MOD
-
Measure battery's real capacity on-device
-
TrueCrypt 7.1 | ereswap | bnf
-
Hardware's mods research is costly. To support my work, please consider donating. Thank You!

Last edited by Estel; 2011-12-15 at 16:52.
 
Posts: 105 | Thanked: 46 times | Joined on May 2011
#56
Hei hei!

I was looking for an app like smssend for a while, thanks!
Unfortunately it doesn't exactly do what it's supposed to do. I have a GSM-unit in my car that can switch a relay when it receives a message from a pre-defined mobile-number with specific text. This works very well when I use option "-c" and send the message with conversation, but it doesn't work at all without conversation. Shouldn't the message be the same with and without "-c"?

Edit: I tried both as user and root.

Last edited by daniel_m; 2012-02-20 at 12:59.
 
Posts: 135 | Thanked: 287 times | Joined on Feb 2012 @ Germany
#57
Thank you for the nice tool it is very useful.
I have a brainchild for another option to point to an ascii or utf8 file with the sms message. I would realy appreciate it if it is possible.
 
Posts: 52 | Thanked: 33 times | Joined on Mar 2011 @ France
#58
I think you can just use a command line like
smssend -c -n +37XXXXXXX -m "$(cat file.txt)"

Last edited by krutznikov; 2012-04-23 at 12:54.
 
Posts: 135 | Thanked: 287 times | Joined on Feb 2012 @ Germany
#59
Yeah this works but when you have an unicode text with different language characters this will not work.
With an extra option you can process the text different and pass it to conversation that it display properly with 16bit unicode encoding.
 
Posts: 135 | Thanked: 287 times | Joined on Feb 2012 @ Germany
#60
So I added an option to pass a txt file to the conversation. No problems with character encoding.
Now I can send every character which I can write with ukeyboard through the conversation. So far tested it only with "-c" and "-C". Works only with "-c". service.compose switch itself to UCS2 sms and service.send does it not.
Is there a way to set maybe the codec to "ISO-10646-UCS-2" before sending?

Here is nearly all what I did. Only added a new param and using it instead "-m". Maybe it is helpful for somebody.

Code:
case SmsSender::argFile:
		{
			QByteArray fullmess;
                    	m_TxtFile = new QFile(param);
			if (!m_TxtFile->open(QIODevice::ReadOnly | QIODevice::Text))
				return errLogfileOpenFailed;
			
			while (!m_TxtFile->atEnd()) {			
			fullmess = m_TxtFile->readLine();
			message.append(fullmess);
			}
			m_TxtFile->close();
		}                 
		   break;
 

The Following 2 Users Say Thank You to Halftux For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 07:39.