Reply
Thread Tools
Posts: 77 | Thanked: 42 times | Joined on Oct 2011 @ Sofia, Bulgaria
#1
This is a complicated story. I have been trying to get avahi running on the n9 for some time now, and it seems I almost got it. I used inception to "liberate" my phone from the tyrannical opressors who have stolen its soul from me.

Then, I installed the following packages from this repository using incept <pkgname>:
Code:
avahi-daemon_0.6.24-0maemo0harmattan-eb1_armel.deb
bind9-host_9.7.0.dfsg.P1-1maemo3harmattan-eb1_armel.deb
libavahi-client3_0.6.24-0maemo0harmattan-eb1_armel.deb
libavahi-common3_0.6.24-0maemo0harmattan-eb1_armel.deb
libavahi-common-data_0.6.24-0maemo0harmattan-eb1_armel.deb
libavahi-core5_0.6.24-0maemo0harmattan-eb1_armel.deb
libbind9-60_9.7.0.dfsg.P1-1maemo3harmattan-eb1_armel.deb
libdaemon0_0.13-0maemo0harmattan-eb1_armel.deb
libdns64_9.7.0.dfsg.P1-1maemo3harmattan-eb1_armel.deb
libisc60_9.7.0.dfsg.P1-1maemo3harmattan-eb1_armel.deb
libisccc60_9.7.0.dfsg.P1-1maemo3harmattan-eb1_armel.deb
libisccfg60_9.7.0.dfsg.P1-1maemo3harmattan-eb1_armel.deb
liblwres60_9.7.0.dfsg.P1-1maemo3harmattan-eb1_armel.deb
After installined I tried starting avahi through opensh:
Code:
/etc/init.d/avahi-daemon start
And I got some errors about avahi not able to connect to Dbus. Restarted phone. Boot loop. Damn.

The interesting part is that when I forced the phone into R&D mode using flasher:
Code:
sudo flasher --set-rd-flags=no-lifeguard-reset --enable-rd-mode
The phone came back from the dead! It booted, and everything worked fine! Even Avahi was working!

I spent almost 5 hours investigating why does the phone get in a boot loop. I tried preventing avahi from starting on boot (by deleting the avahi script in /etc/network and the avahi spec from/etc/dbus-1/system.d/). I checked /etc/network/interfaces and saw it was identical to the default. In the end, I uninstalled avahi-daemon and bind9-host, but to no avail. As soon as I disable R&D mode with flasher, the phone gets in a boot loop.

From the debs, I saw the following new files were installed (apart from some libraries, that probably didn't cause the loop):
Code:
/usr/sbin/avahi-daemon
/etc/avahi/*
/etc/init.d/avahi-daemon
/etc/dbus-0/system.d/avahi-daemon.conf
/usr/bin/host
It is interesting that when I tried installing Avahi from the same repo, but with apt-get and devel-su, it didn't cause a reboot loop, and Avahi didn't work.

It seems like "bricking" the phone is so damn easy. I bet there is some kind of hash check or something that prevents boot in normal mode. I have used Linux for more than 5 years now because it is robust. It is ironic though how easy it is to screw up your n9 and end up reflashing it.

In R&D mode, everything was working fine. I considered staying in R&D mode, but the front LED would keep flashing - it's very annoying.

Last edited by YavkatA; 2012-03-06 at 16:06.
 

The Following User Says Thank You to YavkatA For This Useful Post:
Posts: 13 | Thanked: 12 times | Joined on Apr 2012
#2
Hi there. I'm having the same problem you describe -- only being able to fully boot using R&D mode -- on the N900, most likely for different reasons since I didn't have anything to do with Avahi.

Incidentally, the last things I did before rebooting were commenting out the fstab-gen lines of /etc/event.d/rcS-late and installing the fcam API package. I reverted those changes in R&D mode and tried reverting to production mode but no joy. I can't seem to narrow down the exact cause and am trying to remember all of the other changes I made since last boot...

Did you ever get to the bottom of your issue? Did you try uninstalling Avahi? If you learned anything else, maybe it can give me a clue. Thanks.

Last edited by Doctor Colossus; 2012-04-25 at 04:52.
 
Posts: 77 | Thanked: 42 times | Joined on Oct 2011 @ Sofia, Bulgaria
#3
You probably have a different issue. I believe what was happening in my case was that Avahi installed files in Aegis-protected directories, which caused a hash mismatch and thus the phone refused to boot.
The only way I was able to solve this was with a reflash.
 

The Following User Says Thank You to YavkatA For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 19:58.