Notices


Reply
Thread Tools
Posts: 16 | Thanked: 12 times | Joined on Mar 2010 @ Copenhague, Denmark
#1
Hi,

I've released the first public version of qmood, an application which enables you to access the extensive Stereomood.com library of music free of charge. Stereomood is an indexing service which spiders various music blogs across the internet and hotlinks to their content. The catalogue is rather big and is a great way of discovering new music. Also, I like the idea of not having to pay for Spotify.


As this is my first foray into UI-design in QML, the interface isn't all that pretty, but substantially prettier than the crap I had running on Symbian :-).


.debs are available at http://qmood.googlecode.com along with installation instructions - give it a try and tell me what you think.

Currently only available for N9/harmattan.
N900 port should be fairly straight-forward, but as my dear brick recently moved on to greener pastures, I lack the means to properly develop it for maemo5.

A screenshot of the application in action:

Last edited by sahib; 01-17-2012 at 07:40 PM.
 

The Following 6 Users Say Thank You to sahib For This Useful Post:
zapotek's Avatar
Posts: 184 | Thanked: 83 times | Joined on Jun 2010 @ Athens Greece
#2
i can't loggin i dont now why!
 
Posts: 16 | Thanked: 12 times | Joined on Mar 2010 @ Copenhague, Denmark
#3
Originally Posted by zapotek View Post
i can't loggin i dont now why!
Okay, have you installed 0.1.0 (linked here) or 0.1.1 (available through Appsformeego)?

Is the same issue manifested regardless if you connect through a WLAN or through your GSM/3G operator?
 
Dousan's Avatar
Posts: 1,090 | Thanked: 1,371 times | Joined on Jan 2010 @ Denmark
#4
It won't log me in either. I used 0.1.1 and tried both 3G/mobile data and wifi. No dice, it just keeps trying to log in?

Regards Dousan...
__________________
We do not see things as they are; we see things as we are...
My Procreate art:
http://procreate.si/forums/index.php?topic=407.0
My S°ciety6:
http://society6.com/Dousan
My Tumblr:
http://dousan.tumblr.com
 
Posts: 925 | Thanked: 3,343 times | Joined on Apr 2010 @ Czech Republic
#5
This is how it behaves on my side (latest version from A4M):
  • fill in valid login & password
  • click on "Login"
  • the progress wheel spins and nothing else happens
  • when I click cancel, I'm dumped to a black screen
IMHO, it should return to the login screen if the user clicks cancel during the login phase or if the login fails for some reason. Also some login timeout - say 30 seconds - might be in order.
__________________
modRana: a flexible GPS navigation system
Mieru: a flexible manga and comic book reader

Thanks to everyone who voted for modRana & Mieru in the Maemo.org coding competition !
 
Posts: 16 | Thanked: 12 times | Joined on Mar 2010 @ Copenhague, Denmark
#6
Originally Posted by MartinK View Post
This is how it behaves on my side (latest version from A4M):
  • fill in valid login & password
  • click on "Login"
  • the progress wheel spins and nothing else happens
  • when I click cancel, I'm dumped to a black screen
IMHO, it should return to the login screen if the user clicks cancel during the login phase or if the login fails for some reason. Also some login timeout - say 30 seconds - might be in order.
Thanks for your feedback guys.
I've pinpointed the issue (it's due to an OAuth barf...) and I'm gonna fix it right away.

Edit: turns out it's due to some sort of hickup in the stereomood.com authentication process, I've notified them about it.

Last edited by sahib; 04-25-2012 at 06:00 PM.
 

The Following 2 Users Say Thank You to sahib For This Useful Post:
Posts: 16 | Thanked: 12 times | Joined on Mar 2010 @ Copenhague, Denmark
#7
Until stereomood.com fixes their authentication issues, you can use this build which enables anonymous login and usage of stereomood.
Attached Files
File Type: deb qmood_0.1.2_armel.deb (176.3 KB, 129 views)
 

The Following 2 Users Say Thank You to sahib For This Useful Post:
zapotek's Avatar
Posts: 184 | Thanked: 83 times | Joined on Jun 2010 @ Athens Greece
#8
everything works fine now :-)
 
Posts: 16 | Thanked: 12 times | Joined on Mar 2010 @ Copenhague, Denmark
#9
Originally Posted by zapotek View Post
everything works fine now :-)
Cheers :-).

I employed a static sign in to a pre-authenticated account - a rather ugly workaround. You should be able to use your own account before long - this can be done by selecting 'Flush OAuth token' from the menu on the top mood selection screen and signing in anew. Once Stereomood fixes their sign-in bug, that is :-).

Last edited by sahib; 05-06-2012 at 08:59 AM.
 
zapotek's Avatar
Posts: 184 | Thanked: 83 times | Joined on Jun 2010 @ Athens Greece
#10
i am using my account maybe they fixed
 
Reply

Thread Tools

 
Forum Jump


All times are GMT -4. The time now is 12:57 PM.