Reply
Thread Tools
Mike Fila's Avatar
Posts: 412 | Thanked: 477 times | Joined on Feb 2011 @ Bronx, NY
#31
Do you have any sign of life in the screen what I mean is it back lit? Well you have a couple of choices. Usually when the screen craps out tv out still works ...so you could try to reflash or you could disassemble the slider to see if the cable is intact, but idk if that would cause the tv out to stop functioning. The other thing would be if you have ssh installed to go in and wipe the text messages.
 
Posts: 3 | Thanked: 0 times | Joined on Mar 2012
#32
[QUOTE=el3ctronick;487699] I switched the phone on. But nothing came up on the screen. I heard the 'nokia' tune play and the keyboard lit up, but that was all. Just a blank screen.

I have the same problem, i switched on my n900 i didn't feel the vibration when i press the power button. the white light came on and then the yellow light blink three times then the keyboard lit up. There was no light or image on the screen the phone was just blank.
 
dumpystig's Avatar
Posts: 464 | Thanked: 336 times | Joined on Feb 2011 @ UK, Northwest
#33
Sounds like it may be a ribbon connector that's not fully inserted. Only way to check is by dismantling your phone.
 
dumpystig's Avatar
Posts: 464 | Thanked: 336 times | Joined on Feb 2011 @ UK, Northwest
#34
Service Manuals here:

http://talk.maemo.org/showthread.php?t=56986

I've dismantled a couple of N900's and it's a relatively easy task.

Last edited by dumpystig; 2012-04-26 at 15:03.
 

The Following User Says Thank You to dumpystig For This Useful Post:
Posts: 3 | Thanked: 0 times | Joined on Mar 2012
#35
Originally Posted by dumpystig View Post
Sounds like it may be a ribbon connector that's not fully inserted. Only way to check is by dismantling your phone.
I tried dismantling the phone disconnected the ribbon from the board and reconnecting but i never went any further in the phone.
 
Posts: 3 | Thanked: 0 times | Joined on Mar 2012
#36
Originally Posted by dumpystig View Post
Service Manuals here:

http://talk.maemo.org/showthread.php?t=56986

I've dismantled a couple of N900's and it's a relatively easy task.
thanks dude it worked i disassembled the phone and clean the connectors and is working
 
Posts: 2 | Thanked: 0 times | Joined on Oct 2010
#37
Hey, Has anyone found a solution to this problem?
 
Posts: 2 | Thanked: 0 times | Joined on Oct 2010
#38
I tried a new screen, and nothing changed.
 
Posts: 3 | Thanked: 0 times | Joined on Feb 2011 @ Italy
#39
Hi, I have the same identical problem: I hear the nokia startup tone, if someone call me the phone ring just one time and close the call , and the screen is ever black. So I have brought the phone to a nokia laboratory to fix it, and the answer was:
"we have found water in your device, hence your phone is not more under warranty"....(this is impossible, i have never left my n900 near any water....)
So the guy to prove it, he gave me this photo:

http://www.alexdiclaudio.eu/n900.jpg

I don't know how is possible, but I don't believe that the water magically appears into the center of my phone, leaving perfectly cleaned all sides...

Is there anyone that know if they are trying to trick me?

Thank for the help guys
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 12:15.