Reply
Thread Tools
Posts: 1,364 | Thanked: 1,477 times | Joined on Feb 2011
#1
Ok, this thread is about mess we have with some packages in the repos. As we finally have some response from Nokia, maybe they can help us with those. Please post all crazy/worrisome/******** situations you encountered with packages. I'll start:


SVN - download this package (quite useful) and you get segmentation fault.
FIX: sudo apt-get install libaprutil1=1.3.9-2 libapr1=1.4.2-1

Can we get someone to remove 'newer' ones?

Another...
Auto - make/conf - while current setup works for most, I have encountered quite a few autogen.sh files that cry no automake found (there are plenty of auto* packages, conflicting all the way around, if someone can fix this pls do!)

SDL_Mixer... much has been told about it (wav only and more), still a mess

Everybody is welcome to add problematic packages (ttf anyone?), lets hope with recent qgil return we can fix the repos...
 

The Following 4 Users Say Thank You to szopin For This Useful Post:
Posts: 1,364 | Thanked: 1,477 times | Joined on Feb 2011
#2
Another:

Midnight commander: sloppily built, expects /usr/bin in /scratchbox/tools, can we get this best on earth file management tool right?

FIX: create /scratchbox/tools and 'sudo ln -s /usr/bin/ .' inside it to get all the compression methods working (almost)
 

The Following 3 Users Say Thank You to szopin For This Useful Post:
Posts: 1,364 | Thanked: 1,477 times | Joined on Feb 2011
#3
Another:

p7zipfull: does not work, too many levels of symbolic links

FIX: sudo gainroot
cd /usr/bin
rm 7*
ln -s /opt/maemo/usr/lib/p7zip/7zr 7z
ln -s /opt/maemo/usr/lib/p7zip/7zr 7zr
ln -s /opt/maemo/usr/lib/p7zip/7zr 7za
 

The Following 4 Users Say Thank You to szopin For This Useful Post:
Posts: 1,364 | Thanked: 1,477 times | Joined on Feb 2011
#4
This one's proprietary, so qgil and Nokia definitely won't help but still:

Joikuspot: All webpages you try to access - fail

FIX: sudo rmmod JoikuSpot_Bouncer
sudo modprobe JoikuSpot_Bouncer

(maybe the thread should be renamed to qucikfixes (when there is), but still why expect that from enduser to have expected outcome? Doubt this is planned for N9 experience)
 

The Following 2 Users Say Thank You to szopin For This Useful Post:
Posts: 1,364 | Thanked: 1,477 times | Joined on Feb 2011
#5
libsdl-ttf2.0 vs 2.0-0

http://talk.maemo.org/showthread.php?t=59573

libsdl 1.2.8 (don't even mention 1.3) is there any solution, or is it just backwards incompatibility?

FIX: None known
 

The Following 2 Users Say Thank You to szopin For This Useful Post:
Posts: 1,364 | Thanked: 1,477 times | Joined on Feb 2011
#6
Most hurtful for me is what I mentioned in the first post:

Note, selecting automake1.4 for regex 'automake*'
Note, selecting automake1.5 for regex 'automake*'
Note, selecting automake1.6 for regex 'automake*'
Note, selecting automake1.7 for regex 'automake*'
Note, selecting automake1.9 for regex 'automake*'
Note, selecting automake1.10-autoconf264 for regex 'automake*'
Note, selecting automaken for regex 'automake*'
Note, selecting automake1.10-doc for regex 'automake*'
Note, selecting automake for regex 'automake*'
Note, selecting automake1.10 for regex 'automake*'


Note, selecting autoconf2.13 for regex 'autoconf*'
Note, selecting automake1.10-autoconf264 for regex 'autoconf*'
Note, selecting autoconf2.64 for regex 'autoconf*'
Note, selecting autoconf for regex 'autoconf*'

264 seems to work fine until something cries no auto* found, why, how and why? One of the versions is by Aapo, so hoping for detailed analysis what went wrong. This is a serious problem for on-device building
 

The Following 2 Users Say Thank You to szopin For This Useful Post:
Posts: 1,364 | Thanked: 1,477 times | Joined on Feb 2011
#7
Another midnight commander issue:

Enter (KP_Enter) stops working every now and then (very erratically, could be connected to bash as its working shell vs ash)

FIX: sadly CSSU (http://talk.maemo.org/showpost.php?p...5&postcount=47), sadly as reflash is required to revert, not a drawback if everything works fine, but still a leap of faith. If you want to revert, another FIX: BackupMenu
 

The Following User Says Thank You to szopin For This Useful Post:
Estel's Avatar
Posts: 4,878 | Thanked: 8,056 times | Joined on Mar 2011
#8
Originally Posted by szopin View Post
Another:

p7zipfull: does not work, too many levels of symbolic links

FIX: sudo gainroot
cd /usr/bin
rm 7*
ln -s /opt/maemo/usr/lib/p7zip/7zr 7z
ln -s /opt/maemo/usr/lib/p7zip/7zr 7zr
ln -s /opt/maemo/usr/lib/p7zip/7zr 7za
Thanks for this, it have been bugging me for months. Are You sure, that ln -s /opt/maemo/usr/lib/p7zip/7zr 7zr is required? In my case, invoking 7zr works without this step. Or am I missing something?

/Estel
__________________
N900's aluminum backcover / body replacement
-
N900's HDMI-Out
-
Camera cover MOD
-
Measure battery's real capacity on-device
-
TrueCrypt 7.1 | ereswap | bnf
-
Hardware's mods research is costly. To support my work, please consider donating. Thank You!
 

The Following User Says Thank You to Estel For This Useful Post:
Posts: 1,364 | Thanked: 1,477 times | Joined on Feb 2011
#9
Could be, I just relinked the symlink hell (symlinks to symlinks to...), if 7zr works no need for that step
 
Posts: 1,364 | Thanked: 1,477 times | Joined on Feb 2011
#10
This one is giving me headaches. My favourite contributor had a role in it too. It boils down to:

Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
upstart: PreDepends: sysvinit-utils (>= 2.86.ds1-23) or
busybox (>= 3:1.6.1.legal-1osso8) but it is not going to be installed
E: Broken packages

This is for autoconf 2.64, same for package automake1.10-autoconf264. Installing sysvinit-utils proposes removal of 424 components. Busybox is power and much higher number. Or is it power?
Just checked standard busybox same error. 1.6>1.10.2legal...
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 10:26.