Reply
Thread Tools
fpp's Avatar
Posts: 2,853 | Thanked: 954 times | Joined on Nov 2005
#1031
All right, new topic created and fleshed out :

http://talk.maemo.org/showthread.php?t=83270

Everyone interested, please head over there... the fun continues :-)

Thanks for your help & patience joerg !
__________________
maemo blog

Last edited by fpp; 2012-04-14 at 15:38.
 

The Following 3 Users Say Thank You to fpp For This Useful Post:
Posts: 632 | Thanked: 377 times | Joined on May 2010
#1032
I was wondering if anyone was successful in using usb host mode to make the N900 a wireless router using the WIRED profile wonderfully described in http://talk.maemo.org/showpost.php?p...&postcount=127

i tried to do that with qt mobile hot spot and joikuspot and wasn't successful:
using joikuspot i cannot see the WIRED profile at all, and with QT Mobile hot spot i do see it, but choosing it makes it still try to use the 3G network.

Does anyone know how to make it work?

The reason i need that is that i have laptop computer of my company which i am not an administrator on (so i cannot install anything on it including nokia's software), and only has windows terminal capabilities to home/work desktop machines, so i need to set up the n900 as a true router at my hotel to make both of them internet accessible (since at the hotel i only have wired connection from the room)
 

The Following 2 Users Say Thank You to impeham For This Useful Post:
Posts: 632 | Thanked: 377 times | Joined on May 2010
#1033
Is it possible to connect an NTFS disk on key in read/write mode?
I am only able to connect it as read only - when trying to create folder on it i get:

can't create directory 'aaa': Read-only file system

i read a little about this issue and checked that i have this installed:

kernel-module-ntfs 2.1.29-maemo1 Windows Read/Write NTFS file driver

but doesn't help.
 
ffha's Avatar
Posts: 131 | Thanked: 168 times | Joined on May 2010 @ Netherlands
#1034
Originally Posted by impeham View Post
Is it possible to connect an NTFS disk on key in read/write mode?
I am only able to connect it as read only - when trying to create folder on it i get:

can't create directory 'aaa': Read-only file system

i read a little about this issue and checked that i have this installed:

kernel-module-ntfs 2.1.29-maemo1 Windows Read/Write NTFS file driver

but doesn't help.
I installed the following package on my N900 to enable NTFS read/write support: http://packages.debian.org/squeeze/a...fs-3g/download

Have fun
 

The Following User Says Thank You to ffha For This Useful Post:
Posts: 632 | Thanked: 377 times | Joined on May 2010
#1035
Originally Posted by ffha View Post
I installed the following package on my N900 to enable NTFS read/write support: http://packages.debian.org/squeeze/a...fs-3g/download

Have fun
tried installing ntfs-3g and i get:

Reading package lists... Done
Building dependency tree
Reading state information... Done
ntfs-3g is already the newest version.

so i guess this is probably not the problem...
 
peterleinchen's Avatar
Posts: 1,867 | Thanked: 2,379 times | Joined on Aug 2010 @ Ruhrgebiet, Germany
#1036
Is the module loaded?
What about package kernel-module-ntfs from maemo repos? This one is loaded on boot and helped me.
 
woody14619's Avatar
Posts: 1,439 | Thanked: 3,159 times | Joined on Dec 2009 @ Rochester, NY
#1037
Originally Posted by impeham View Post
Is it possible to connect an NTFS disk on key in read/write mode?
I think the default is read only, but you can probably enable write. Try remounting the device, like this:

Code:
mount -o remount,rw /media/<Insert-mount-name-here>
It may also be a compile-time option for the module, depending on how old the kernel is, but I'm thinking even with our older kernel it should be in there to allow it.
 
Posts: 632 | Thanked: 377 times | Joined on May 2010
#1038
Originally Posted by woody14619 View Post
I think the default is read only, but you can probably enable write. Try remounting the device, like this:

Code:
mount -o remount,rw /media/<Insert-mount-name-here>
It may also be a compile-time option for the module, depending on how old the kernel is, but I'm thinking even with our older kernel it should be in there to allow it.
A strange thing happened - after i executed this command, i was able to create and delete a folder - i thought this solved the problem so i changed the "mount.sh" script and added this command as the first line after the "then" line which comes after the mount command and tried to unmount and mount again from hen.
However, i am not able to mount it again in read/write mode - even if i returned the script to its original form and retry your command.

I tried also to connect the usb key to my laptop and scan for errors - just to make sure that nothing was wrong because of the dismount, but still after this i cannot connect it again in write mode using hen and getting the "Read-only file system" again when trying to do write operation.

i tried manually running the following after the "Enumerate" button press in hen:

mkdir -p /media/sda1
modprobe ntfs
mount -w -o uid=29999,gid=29999,utf8,dmask=027,fmask=137 /dev/sda1 /media/sda1
mount -o remount,rw /media/sda1

all the commands went with no errors, and /media/sda1 is accesible in read only mode.

one more thing i did which i don't know if might affect this is add the -f -l parameters to the umount command in the "mount.sh" script (because for some reason it refused to dismount the first time).

Last edited by impeham; 2012-04-26 at 21:46.
 
Posts: 632 | Thanked: 377 times | Joined on May 2010
#1039
Found a workaround - i'm mounting the ntfs disk from easy debian - there i have R/W working.
 

The Following User Says Thank You to impeham For This Useful Post:
joerg_rw's Avatar
Community Council | Posts: 1,852 | Thanked: 9,810 times | Joined on Mar 2010 @ SOL 3
#1040
please keep discussions about mounting etc out of this thread! See post #9

For the rest of you I created a little
scriptie that at least for me does completely 'hidden' (non-interactive) hostmode,
I.E. you can start it from shell as root, or via single click on a icon with according .desktop (use sudo there, adjust your sudoers.d/ by adding a file named start-hostmode...) Obviously it's meant to get started _after_ plugging in your memstick/whatever. Be patient, I had to implement a few delays to allow things to settle, so give it a minute. Last thing it does is invoking the original mount script by mohammad, which in turn shows a short notification about "successfull mount"

http://maemo.cloud-7.de/maemo5/usr/sbin/start-hostmode (does highspeed "echo hosth >/sys...")

To stop hostmode, you kill the script - in shell for example you do Ctrl-C. ATTENTION! This doesn't do proper umount! I eventually might fix this.

/j
ps: this script is a marginally augmented version of "improved booston script" as shipping with new version of h-e-n mentioned in next post
__________________
Maemo Community Council member [2012-10, 2013-05, 2013-11, 2014-06 terms]
Hildon Foundation Council inaugural member.
MCe.V. foundation member

EX Hildon Foundation approved
Maemo Administration Coordinator (stepped down due to bullying 2014-04-05)
aka "techstaff" - the guys who keep your infra running - Devotion to Duty http://xkcd.com/705/

IRC(freenode): DocScrutinizer*
First USB hostmode fanatic, father of H-E-N

Last edited by joerg_rw; 2012-05-20 at 20:37.
 

The Following 7 Users Say Thank You to joerg_rw For This Useful Post:
Reply

Tags
bada rox, detection, h-e-n, hostmode, speed, usb host

Thread Tools

 
Forum Jump


All times are GMT. The time now is 07:46.