Reply
Thread Tools
Posts: 689 | Thanked: 1,254 times | Joined on Feb 2010 @ Gdynia, Poland
#41
Hello, Ade, I just wanted to let you know (and all of you people) that if you push an update now, there may be problems. According to http://maemo.org/packages/package_in.../fceu/0.0.1-1/ , one of dependencies is "libxau6". I'm worrided about the no version part, becuase, as reported today in thread http://talk.maemo.org/showthread.php?t=83939 , there is newer version of libxau6 in extras-devel (someone forgot to change the name of newly uploaded package), so if package builder uses that new version, you're ****ed. You may want to change it to use specific version (dependecies with "=version") for now, unless the issues are resolved or repo admins remove duplicate package with errors from extras-devel. Cheers!
 

The Following 3 Users Say Thank You to misiak For This Useful Post:
Temporal's Avatar
Posts: 321 | Thanked: 185 times | Joined on Oct 2010 @ Brazil
#42
I know that this might be somewhat of an overkill, but for the ones using gamegripper like me, I fixed the fixed keys problem by creating a subset of the keyboard mapping.

By adding this:
Code:
////////////////////////////////////////////////////////////////////////////////
partial alphanumeric_keys
xkb_symbols "fce" {
    include "nokia_vndr/rx-51(english_base)"
    include "nokia_vndr/rx-51(arrows_4btns)"

    name[Group1] = "FCE_Ultra";

//original T now L
    key <AD05>	{ [	l,		T,		5,		t		] };
//original U now O
    key <AD07>	{ [	o,		U,		7,		u		] };
//original O now U
    key <AD09>	{ [	u,		O,		9,		o		] };
//original L now T
    key <AC09>	{ [	t,		L,		exclam,		l		] };
//original R now H
    key <AD04>	{ [	h,		R,		4,		r		] };
//original H now R
    key <AC06>	{ [	r,		H,		parenleft,	h		] };
};
////////////////////////////////////////////////////////////////////////////////
to the file:
/usr/share/X11/xkb/symbols/nokia_vndr/rx-51
(backup first, and DO NOT reboot unless the command worked!!!)
Now I am able to play using gamegripper by reseting the keys using the fceu-gui after invoking:
setxkbmap -layout fce
and then after I'm done playing I invoke:
setxkbmap -layout us
This works for me because I use the US keyboard, If you are an AZERTY or russian or other you'll have to modify my changes to accomodate your layout.
PS: You'll HAVE to change the "r" button to some other that has no function like I did because when you hit w+d+l+left, it will bring an "r" from nowhere (at least does on mine).
As a failsafe (if you are stuck with t as l, u as o, r as h and vice-versa, by locking the caps and hitting shift+fn+key it will spill the lowercase of those six changed chars.)
Maybe this could be incorporated as an option in a possible future version of fceu-gui?
Hope this helps someone else.
__________________
Love and Goodness are not a property. Are not a franchising. They are present in each one of us, and must be cultivated with KNOWLEDGE.
 

The Following 2 Users Say Thank You to Temporal For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT -4. The time now is 07:52 PM.