Reply
Thread Tools
Posts: 13 | Thanked: 0 times | Joined on Apr 2012 @ Navi Mumabi
#11
Originally Posted by sifo View Post
try to flash FIASCO+EDITED EMMC *(like 8 GB for /home/user ) if want to try download it from MEDIAFIRE.COM hope this help or try cold reflashing
Thanks Sifo.. I guess i tried the 160 MB image, but it failed. I guess i did not do it properly. As this is combined image, would the flasher command would be:

flasher-3.5.exe -F <image_name> -f -R which is followed by the standard procedure of the flashing. If not, would you please expand the steps to me ?
 
pusak gaoq's Avatar
Posts: 723 | Thanked: 512 times | Joined on Nov 2010 @ Kuching:Malaysia
#12
hmmmm....remember if you wanna re-flash your devices,you need to flash your eMMC first then your fiasco images....

the command for eMMC is...

flasher-3.5.exe -F <images name> -f

the command for fiasco is....

flasher-3.5.exe -F <images name> -f -R
__________________
My Phone Evolution : Nokia 3650-Nokia 6600-Nokia 6630-Motorola Rizr-Sony P1i-Nokia E63-Nokia X3-Samsung E980-Iphone 2G-Sony W595-Nokia E71-Nokia 5800-Nokia N900-HTC Hero-Xperia Mini Pro
 
sifo's Avatar
Posts: 1,359 | Thanked: 1,288 times | Joined on Oct 2011 @ Tartus.Syria
#13
sure ! here it is :

originally posted by ammyt

I have a windows 7 32bit flashed my N900 7 times till now:
1. the process is extensive but quite comprehensive
2. you'll need to know ur imei for software downloads
Now roll up ur sleeves we'll bring ur N900 back to life!:
1. go to tablets-dev.nokia.com/nokia_N900.php
2. there r clear instructions on how to find and enter ur imei
3. after that throw the eula in a trash and click I agree
4. find RX-51_2009SE_20.2010.36-2_PR_COMBINED_MR0_ARM.bin latest global release for Maemo 5 and click on it then download it
5. find RX-51_2009SE_10.2010.13-2.VANILLA_PR_EMMC_MR0_ARM.bin latest vanilla emmc content click on it then download it
6. place ur 2 .bin in the folder where maemo flasher was installed (e.g. C:/program files/maemo)
Now u should have the 3 required files for flashing:
1. flasher 3.5
2. RX-51_2009SE_10.2010.13-2.VANILLA_PR_EMMC_MR0_ARM.bin emmc content
3. RX-51_2009SE_20.2010.36-2_PR_COMBINED_MR0_ARM.bin fiasco (OS)
The following procedure is the important one:
1. Be sure ur N900 has at least 50% of its battery charge
2. disconnect any internet connections (this is the issue with windows 7)
3. go to start menu then in the search type maemo flasher u should find it.
4. click on it it will open a cmd window
5. connect ur usb cable in ur pc not in the N900 yet
6. open ur N900's keyboard and press u button and keep holding it while plugging the usb cable in ur N900
7. faded Nokia logo with usb icon on top right corner shall appear
8. ur cool stop holding the u button now or ull suffer from finger constipation :P
9. returning to maemo flasher issue this command:
flasher-3.5.exe -F RX-51_2009SE_20.2010.36-2_PR_COMBINED_MR0_ARM.bin -f (u can copy and paste it in maemo flasher)
10. HIT ENTER the windows 7 screen about allow and don't allow should appear click allow another cmd window shall appear it will show the flashing status takes about 5mins
11. after it finishes the other cmd window will close and u return to maemo flasher issue this command:
flasher-3.5.exe -F RX-51_2009SE_10.2010.13-2.VANILLA_PR_EMMC_MR0_ARM.bin -f -R
12. the same other cmd window will appear showing flasing status after it finishes ur N900 will reboot
13. disconnect ur usb cable close flasher be happy
Now a bit work with ur N900
1. once ur N900 reboot open the ur battery cover, remove the battery, and yep we're not letting it boot
2. with the battery removed press the power button long press it for 5 seconds to leave away any static electricity from usb connecting
3. count 30 seconds then plug ur battery back do not put back the cover.
4. boot ur N900 by pressing the power button ur N900 should boot happily although it will take time with the 5 dots in the booting process
5. after it boots ull get the seetings of time and date etc...
6. put the cover back and brick ur N900 again :P
p.s. if ur led flashes orange when ur N900 boots after flashing NO WORRIES just repeat the takeoff battery static electricity process

If you're using custom EMMC just rename the custom emmc to RX-51_2009SE_10.2010.13-2.VANILLA_PR_EMMC_MR0_ARM.bin
hope this help
__________________
[ N900-Crack ] [ The Purge ] [ New Smiles ] [ New icons ] [ ? ]
" Hey ! I've just met you and this is crazy, so install cssu maybe ? "
Please help out keeping Maemo.org alive, and consider donating.
https://www.facebook.com/ZoRk7

Last edited by sifo; 2012-04-29 at 19:43.
 
Posts: 13 | Thanked: 0 times | Joined on Apr 2012 @ Navi Mumabi
#14
Originally Posted by sifo View Post
sure ! here it is :

I have a windows 7 32bit flashed my N900 7 times till now:
1. the process is extensive but quite comprehensive
2. you'll need to know ur imei for software downloads
Now roll up ur sleeves we'll bring ur N900 back to life!:
1. go to tablets-dev.nokia.com/nokia_N900.php
2. there r clear instructions on how to find and enter ur imei
3. after that throw the eula in a trash and click I agree
4. find RX-51_2009SE_20.2010.36-2_PR_COMBINED_MR0_ARM.bin latest global release for Maemo 5 and click on it then download it
5. find RX-51_2009SE_10.2010.13-2.VANILLA_PR_EMMC_MR0_ARM.bin latest vanilla emmc content click on it then download it
6. place ur 2 .bin in the folder where maemo flasher was installed (e.g. C:/program files/maemo)
Now u should have the 3 required files for flashing:
1. flasher 3.5
2. RX-51_2009SE_10.2010.13-2.VANILLA_PR_EMMC_MR0_ARM.bin emmc content
3. RX-51_2009SE_20.2010.36-2_PR_COMBINED_MR0_ARM.bin fiasco (OS)
The following procedure is the important one:
1. Be sure ur N900 has at least 50% of its battery charge
2. disconnect any internet connections (this is the issue with windows 7)
3. go to start menu then in the search type maemo flasher u should find it.
4. click on it it will open a cmd window
5. connect ur usb cable in ur pc not in the N900 yet
6. open ur N900's keyboard and press u button and keep holding it while plugging the usb cable in ur N900
7. faded Nokia logo with usb icon on top right corner shall appear
8. ur cool stop holding the u button now or ull suffer from finger constipation :P
9. returning to maemo flasher issue this command:
flasher-3.5.exe -F RX-51_2009SE_20.2010.36-2_PR_COMBINED_MR0_ARM.bin -f (u can copy and paste it in maemo flasher)
10. HIT ENTER the windows 7 screen about allow and don't allow should appear click allow another cmd window shall appear it will show the flashing status takes about 5mins
11. after it finishes the other cmd window will close and u return to maemo flasher issue this command:
flasher-3.5.exe -F RX-51_2009SE_10.2010.13-2.VANILLA_PR_EMMC_MR0_ARM.bin -f -R
12. the same other cmd window will appear showing flasing status after it finishes ur N900 will reboot
13. disconnect ur usb cable close flasher be happy
Now a bit work with ur N900
1. once ur N900 reboot open the ur battery cover, remove the battery, and yep we're not letting it boot
2. with the battery removed press the power button long press it for 5 seconds to leave away any static electricity from usb connecting
3. count 30 seconds then plug ur battery back do not put back the cover.
4. boot ur N900 by pressing the power button ur N900 should boot happily although it will take time with the 5 dots in the booting process
5. after it boots ull get the seetings of time and date etc...
6. put the cover back and brick ur N900 again :P
p.s. if ur led flashes orange when ur N900 boots after flashing NO WORRIES just repeat the takeoff battery static electricity process

If you're using custom EMMC just rename the custom emmc to RX-51_2009SE_10.2010.13-2.VANILLA_PR_EMMC_MR0_ARM.bin

hope this help
Hi Silo,

Thanks for the efforts. Unfortunately, the procedure failed. The first command ran well to success. The second command, flasher-3.5.exe -F RX-51_2009SE_10.2010.13-2.VANILLA_PR_EMMC_MR0_ARM.bin -f –R, failed. After this, the “ Suitable USB device not found,waiting” message appeared in the command prompt and the N900 appeared to be rebooting phase, where the 5 dots stuck and nothing could be done for a longer time. I ensured that the battery was full too. I had to remove the battery inorder to get the screen back. This has always been the outcome of the flashing.

To make the things worse, when I went to settings > Memory, I saw that the memory was corrupt.


Please find the attached document with the screenshot. By the way i am on Windows XP
Attached Files
File Type: zip flasher.zip (189.3 KB, 66 views)
 
Posts: 470 | Thanked: 413 times | Joined on May 2010 @ nanaurbusiness
#15
From the wiki
Note that flashing eMMC will delete the /opt directory, so you *always* need to reflash your rootfs (the COMBINED image) after - or same time as - flashing eMMC (VANILLA img)
I guess you wasn't quick enough for the vanilla flashing to start properly:

For your information (also from the wiki)

When flashing the eMMC content, the safe way is flash the eMMC/VANILLA image first, then remove battery for a moment, and then flash the FIASCO/Rootfs image. Do not boot up the device between the two i.e do NOT use the -R parameter at the end!

Also see troubleshooting section, bullet 6:"If you cannot establish..."

Rationale: on accidental booting in between the 2 flash processes, the sequence formerly suggested (rootfs first) will result in a broken system. The sequence "eMMC first, then rootfs" is checked back with Nokia affiliates and is proven to work as long as your rootfs still is somewhat functional. Note however that eMMC flashing will fail when your rootfs is completely messed up, the recommended flash sequence then is rootfs, eMMC, rootfs *again*.
For users familiar with flashing and interested in a smooth fast process: you can flash combined first, and then *immediately* after that - without one 10th of a second of booting - directly continue with flashing the vanilla. The other way round doesn't work due to a bug in NOLO - so after flashing vanilla you need to remove battery to recover
And additionally you should definitely read the wiki about "Troubleshooting"

This for example could be useful for you:

What to do if you cannot establish a connecion:

1. (try to) Turn off the device - if nothing else helps, holding power key for >8s is the ultimate means (except next point 2.) to do this.

2. Remove the battery - even if you were not able to shut device down in 1.

3. Start flasher with above mentioned command to flash (without -R, it's a useless convenience thing). It says "Suitable device not found... waiting"

4. Plug the device to computer with a good USB cable.

5. Insert battery while holding "u" key. You can release the key as soon as screen turns on and shows the USB logo. Flashing shall start automatically. (If flasher answers "unable to enumerate USB buses!" as soon as N900 gets battery, just re-issue same flasher cmd immediately - cursor-up helps ;-D). If flasher doesn't detect the device, a Ctrl+C abort and re-issuing of the flasher command may help
Cheers,

Drunken Monkey err J4ZZ
 

The Following User Says Thank You to J4ZZ For This Useful Post:
Posts: 13 | Thanked: 0 times | Joined on Apr 2012 @ Navi Mumabi
#16
Hi,

I tried the troubleshooting above. Well I am able to run the combined one successfully, but when i am trying the EMMC, it is still showing "suitable device. I tried the following.
1. Remove the battery, as the Device got hanged
2. Issued the command, connected the device to my laptop
3. held the "U" key and inserted the battery.
 
Posts: 13 | Thanked: 0 times | Joined on Apr 2012 @ Navi Mumabi
#17
Anyone with other thoughts !!
 
Posts: 58 | Thanked: 12 times | Joined on Apr 2012 @ philippines
#18
same problm b4r but i only flash my phone emmc and arm.bin and it wrks,my advice is try to download again emmc file the latest software,i am confusing that ur emmc file is not fully completly downloaded.thats why thre is an error... jzt follw my advice gud day
 
Posts: 13 | Thanked: 0 times | Joined on Apr 2012 @ Navi Mumabi
#19
Originally Posted by bugoy View Post
same problm b4r but i only flash my phone emmc and arm.bin and it wrks,my advice is try to download again emmc file the latest software,i am confusing that ur emmc file is not fully completly downloaded.thats why thre is an error... jzt follw my advice gud day
Could you please explain me in detail... I can say that I have a complete and correct download of the bin files..
 
Posts: 13 | Thanked: 0 times | Joined on Apr 2012 @ Navi Mumabi
#20
Guys...thanks everyone...i got my wonderful piece of technology back in my hands !!!!!
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 08:18.