Reply
Thread Tools
Posts: 19 | Thanked: 11 times | Joined on Oct 2011
#1
I've been trying to connect to the wireless at my university and keep running into "Can't authenticate" errors with my N9.

Can't say I know too much about wireless networks, but from what I understand, we're using a WPA (TKIP) with EAP (PEAP/EAP MSCHAPv2) which I have set on phone. It's also set to not "require client authentication" in the advanced settings tab. What I'm thinking is, even though I have the cert from the university registered and set to Wifi on my phone under Security>Certifications, I can't pull that cert up on the wifi setting's "select certificate" and that's currently set to "none". Is there any way to fix this or does anyone know of another method to connect?

Thanks.
 
Posts: 19 | Thanked: 11 times | Joined on Oct 2011
#2
Originally Posted by teddy View Post
I've been trying to connect to the wireless at my university and keep running into "Can't authenticate" errors with my N9.

Can't say I know too much about wireless networks, but from what I understand, we're using a WPA (TKIP) with EAP (PEAP/EAP MSCHAPv2) which I have set on phone. It's also set to not "require client authentication" in the advanced settings tab. What I'm thinking is, even though I have the cert from the university registered and set to Wifi on my phone under Security>Certifications, I can't pull that cert up on the wifi setting's "select certificate" and that's currently set to "none". Is there any way to fix this or does anyone know of another method to connect?

Thanks.
EDIT: Woot! 3 hrs of procrastinating work later and it now says it's connected with no actual connection.
 
Posts: 86 | Thanked: 42 times | Joined on Oct 2011
#3
I'm disappointed this is still not fixed with Nokia. It's been a problem since the N97 (Symbian) days.

Sigh.

A lot of corporations rely on this too. I'm amazed that the first gen iPhone was able to this but Nokia devices, regardless of OS, still can't.
 
Posts: 120 | Thanked: 37 times | Joined on Jun 2010 @ Portugal
#4
I have this problem too but with my n900
 
Posts: 19 | Thanked: 11 times | Joined on Oct 2011
#5
Got it to work randomly today, no different settings from what I've tried (just can trying to set up a new connection). Unfortunately, I have no clue why.
 
Posts: 157 | Thanked: 185 times | Joined on Sep 2010 @ USA around Chicago
#6
I had similar issues with the wireless at my office.

I was able to successfully connect with the following manual settings:
Security method: WPA EAP
WPA EAP type: PEAP
Select certificate: None
EAP method: EAP MSCHAPv2
Username: <myusername>
Password: <mypassword>
Advanced Settings:
Proxy configuration: No proxy
Auto-retrieve IP address: on
Auto-retrieve DNS address: on
Manuall username: off
Require client authentication: off
WPA2 only mode: off

So create a manual connection and play with the settings. I tried 2 corporate networks and the above settings works with both.

Good luck.
 
Posts: 13 | Thanked: 0 times | Joined on Oct 2011
#7
Originally Posted by abyzthomas View Post
I had similar issues with the wireless at my office.

I was able to successfully connect with the following manual settings:
Security method: WPA EAP
WPA EAP type: PEAP
Select certificate: None
EAP method: EAP MSCHAPv2
Username: <myusername>
Password: <mypassword>
Advanced Settings:
Proxy configuration: No proxy
Auto-retrieve IP address: on
Auto-retrieve DNS address: on
Manuall username: off
Require client authentication: off
WPA2 only mode: off

So create a manual connection and play with the settings. I tried 2 corporate networks and the above settings works with both.

Good luck.
hi..i have updated to Pr 1.1 and i have used the following configurations but i still get the same message over and over again when i try to connect to my college's network using my N9, which is "Something's wrong with the network connection".

Typed in connection and network name(SSID)
Use automatically: yes/no (no difference)
Network mode: Infrastructure
Security method: WPA EAP
WPA EAP type: PEAP
Select certificate: None
EAP method: EAP MSCHAPv2
Username: typed in correctly
Password: typed in correctly

Advanced Settings:
Proxy configuration: No proxy
Auto-retrieve IP address: on
Auto-retrieve DNS address: on
Manuall username: on/off (no difference)
Username: same as the username above
Require client authentication: off
WPA2 only mode: on/off (no difference)

please help me..
 
Posts: 11 | Thanked: 1 time | Joined on Jul 2010
#8
any solution so far?
 
Posts: 1 | Thanked: 1 time | Joined on Nov 2013
#9
I don't know if people are still having this issue since this is an old post. I started getting this "Can't Authenticate" error about 2 weeks ago at my university. I came across this thread while trying to seek answers to my problem, I didn't find any that helped. I then started playing around with my settings. However, the thing that solved my problem was changing the connection to a WPA2 only setting.

Security method: WPA EAP
WPA EAP type: PEAP
Select certificate: None
EAP method: EAP MSCHAPv2
Username: <username>// without the domain
Password: <password>
Advanced Settings:
Proxy configuration: No proxy
Auto-retrieve IP address: on
Auto-retrieve DNS address: on
Manuall username: off
Require client authentication: off
WPA2 only mode: on <<-- This was what fixed it for me.

Seems like the router settings changed at my university without our knowledge. Only found the issue when checking for ways to connect to other OS, as every other OS were using WPA2-enterprise.

I hope this helps resolves the problems you may have as well.
 

The Following User Says Thank You to makkaCha For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 07:40.