Active Topics

 

Posts: 21 | Thanked: 0 times | Joined on Oct 2010
#1
Hello,

I want to install pyqt to n900. firstly, i open app manager, then i choose the apps. Pyqt4-full-install and other doesnt work, i cant install couse where are some problems like conflicts with other packs. only pyqt4-experimental-demo installed, anyways when i open it from desktop its not lounching.

any sugestions, what im doing wrong..?
sorry for spelling..
 
Venemo's Avatar
Posts: 1,192 | Thanked: 1,225 times | Joined on Aug 2009 @ Budapest, Hungary
#2
Please elaborate on what were the problems.
 
fpp's Avatar
Posts: 2,853 | Thanked: 954 times | Joined on Nov 2005
#3
If you have upgraded to Maemo5 PR 1.3 already, it is best to wait a bit more for updated PyQt packages, to match the new version of Qt.
__________________
maemo blog
 
Posts: 21 | Thanked: 0 times | Joined on Oct 2010
#4
Venemo I attached the screenshot of problems.

fpp how to check what version i got?
Attached Images
 
 
Posts: 7 | Thanked: 1 time | Joined on May 2012 @ Iran
#5
Im having problems too

plz take a look at this

Code:
--- 2012-05-01 19:13:02 ---
Start reading package lists
--- 2012-05-01 19:13:14 ---
Finished reading package lists
--- 2012-05-01 19:13:14 ---
Start fetching package dates
--- 2012-05-01 19:13:15 ---
need to fetch date for 0 packages
--- 2012-05-01 19:13:15 ---
sent 0 requests, received 0 replies with 0 errors
--- 2012-05-01 19:13:15 ---
Finished fetching package dates
--- 2012-05-01 19:13:43 ---
/usr/bin/apt-get -qsy --allow-unauthenticated -o Dir::Etc::sourcelist=/opt/fapman-cache/sources.list -o Dir::State::lists=/opt/fapman-cache/lists -o Dir::Etc::sourceparts="" --auto-remove install python2.5-qt4
--- 2012-05-01 19:13:52 ---
Output from last process:
---
Reading package lists...
Building dependency tree...
Reading state information...
python2.5-qt4 is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
python2.5-qt4: Depends: python2.5-qt4-core (= 4.7.5-maemo2)
Depends: python2.5-qt4-gui (= 4.7.5-maemo2)
Depends: python2.5-qt4-network (= 4.7.5-maemo2)
Depends: python2.5-qt4-phonon (= 4.7.5-maemo2)
Depends: python2.5-qt4-sql (= 4.7.5-maemo2)
Depends: python2.5-qt4-svg (= 4.7.5-maemo2)
Depends: python2.5-qt4-script (= 4.7.5-maemo2) but it is not going to be installed
Depends: python2.5-qt4-test (= 4.7.5-maemo2)
Depends: python2.5-qt4-webkit (= 4.7.5-maemo2)
Depends: python2.5-qt4-gl (= 4.7.5-maemo2)
Depends: python2.5-qt4-xml (= 4.7.5-maemo2)
Depends: python2.5-qt4-xmlpatterns (= 4.7.5-maemo2)
Depends: python2.5-qt4-multimedia (= 4.7.5-maemo2) but it is not going to be installed
python2.5-qt4-dbus: Depends: python-dbus (>= 0.80.0) but it is not going to be installed or
libqtcore4 but it is not installable
python2.5-qt4-maemo5: Depends: python2.5-qt4-gui (= 4.7.5-maemo2)
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

--- 2012-05-01 19:17:38 ---
/usr/bin/apt-get -qsy --allow-unauthenticated -o Dir::Etc::sourcelist=/opt/fapman-cache/sources.list -o Dir::State::lists=/opt/fapman-cache/lists -o Dir::Etc::sourceparts="" --auto-remove install python2.5-qt4
--- 2012-05-01 19:18:12 ---
Output from last process:
---
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
python2.5-qt4: Depends: python2.5-qt4-test (= 4.7.5-maemo2)
E: Broken packages






--- 2012-05-01 19:13:02 ---
Start reading package lists
--- 2012-05-01 19:13:14 ---
Finished reading package lists
--- 2012-05-01 19:13:14 ---
Start fetching package dates
--- 2012-05-01 19:13:15 ---
need to fetch date for 0 packages
--- 2012-05-01 19:13:15 ---
sent 0 requests, received 0 replies with 0 errors
--- 2012-05-01 19:13:15 ---
Finished fetching package dates
--- 2012-05-01 19:13:43 ---
/usr/bin/apt-get -qsy --allow-unauthenticated -o Dir::Etc::sourcelist=/opt/fapman-cache/sources.list -o Dir::State::lists=/opt/fapman-cache/lists -o Dir::Etc::sourceparts="" --auto-remove install python2.5-qt4
--- 2012-05-01 19:13:52 ---
Output from last process:
---
Reading package lists...
Building dependency tree...
Reading state information...
python2.5-qt4 is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
python2.5-qt4: Depends: python2.5-qt4-core (= 4.7.5-maemo2)
Depends: python2.5-qt4-gui (= 4.7.5-maemo2)
Depends: python2.5-qt4-network (= 4.7.5-maemo2)
Depends: python2.5-qt4-phonon (= 4.7.5-maemo2)
Depends: python2.5-qt4-sql (= 4.7.5-maemo2)
Depends: python2.5-qt4-svg (= 4.7.5-maemo2)
Depends: python2.5-qt4-script (= 4.7.5-maemo2) but it is not going to be installed
Depends: python2.5-qt4-test (= 4.7.5-maemo2)
Depends: python2.5-qt4-webkit (= 4.7.5-maemo2)
Depends: python2.5-qt4-gl (= 4.7.5-maemo2)
Depends: python2.5-qt4-xml (= 4.7.5-maemo2)
Depends: python2.5-qt4-xmlpatterns (= 4.7.5-maemo2)
Depends: python2.5-qt4-multimedia (= 4.7.5-maemo2) but it is not going to be installed
python2.5-qt4-dbus: Depends: python-dbus (>= 0.80.0) but it is not going to be installed or
libqtcore4 but it is not installable
python2.5-qt4-maemo5: Depends: python2.5-qt4-gui (= 4.7.5-maemo2)
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

--- 2012-05-01 19:17:38 ---
/usr/bin/apt-get -qsy --allow-unauthenticated -o Dir::Etc::sourcelist=/opt/fapman-cache/sources.list -o Dir::State::lists=/opt/fapman-cache/lists -o Dir::Etc::sourceparts="" --auto-remove install python2.5-qt4
--- 2012-05-01 19:18:12 ---
Output from last process:
---
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
python2.5-qt4: Depends: python2.5-qt4-test (= 4.7.5-maemo2)
E: Broken packages
i tried apt-get -f install
but no luck.
Attached Images
 
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 18:58.