Notices


Reply
Thread Tools
Posts: 329 | Thanked: 504 times | Joined on Jul 2008 @ Israel
#191
Originally Posted by Schturman View Post
Hi
Today I got 3 time the same error on the black screen "WAZE is not responding" - close "YES" and "NO"..
I always pressed "NO" and it has continued to work..
i wonder why it happend... Anyway, you dont have to click No, as it recovers after 3 seconds.it also happend here so I will try to find the cause.

@anonymous the ssl network encryption change is commited and will be released with the missing list items next week. Regarding the password encryption in the config files, it is acomplex matter: since this application is opensourced, the encryption key is exposed in the source repository so even if i encrypt it, it can easily be decrypted.
 

The Following 2 Users Say Thank You to damagedspline For This Useful Post:
Posts: 329 | Thanked: 504 times | Joined on Jul 2008 @ Israel
#192
Starting to roll out v0.0.8, starting with N900.
Unless you will specifically request URLs, the new version is only going to be available in the repositories as follows:
N900: Extras-devel repository (already available)
N9/N950: Apps4Meego testing repository (UPDATE: already available)
Ubuntu Oneiric and above: My personal PPA reposiory (to use: sudo add-apt-repository ppa:damagedspline/waze-qt) which will hopefully be integrated to the next Ubuntu releases. (work in progress)

I am doing this for 2 reasons:
1) push more people to use apps4meego - which contains several more free applications
2) you will have an "package update" notification whenever a new release is out and you will not have to keep refreshing the forum - even though I like the company.

@gianko - I am not sure that this new release will fix your crash, I made 2 fixes suggested by the ubuntu autobuilder compiler that might also be relevant to N900. anyway, after I am done with fixing the autobuilds for ubuntu and N9 - I will dedicate myself to the issue you're experiencing.

Next release (0.1.0) will be codenamed "Chico" and will be ~1 months from now and will have new map engine for better performance.
Then the next next release (0.2.0) will be codenamed "Djako" and will have an entire new UI - targeted ~4 months from now.

Last edited by damagedspline; 2012-05-03 at 11:44. Reason: Now available in Apps4Meego as well
 

The Following 7 Users Say Thank You to damagedspline For This Useful Post:
Schturman's Avatar
Posts: 4,765 | Thanked: 3,231 times | Joined on Jan 2010 @ Israel
#193
Hi
Today I noticed about update to 0.0.8 and installed this. Thank you !
I saw that now we can change profile and the car, but I don't see the button for downloading map, only for refresh ? :/
 
Posts: 329 | Thanked: 504 times | Joined on Jul 2008 @ Israel
#194
Originally Posted by Schturman View Post
Hi
Today I noticed about update to 0.0.8 and installed this. Thank you !
I saw that now we can change profile and the car, but I don't see the button for downloading map, only for refresh ? :/
If you have downloaded the map in v0.0.7 you still have it in v0.0.8 so no need to redownload everything
 

The Following User Says Thank You to damagedspline For This Useful Post:
coredumb's Avatar
Posts: 92 | Thanked: 74 times | Joined on Nov 2008 @ Indonesia
#195
damagedspline,
seems "data compression" doesn't work properly. it won't let waze do the transfer data, and keep show "searching network..." message.
 

The Following User Says Thank You to coredumb For This Useful Post:
Schturman's Avatar
Posts: 4,765 | Thanked: 3,231 times | Joined on Jan 2010 @ Israel
#196
Originally Posted by damagedspline View Post
If you have downloaded the map in v0.0.7 you still have it in v0.0.8 so no need to redownload everything
Ok, and if i don't have downloaded map from previous version? It will work only online..
 
Posts: 329 | Thanked: 504 times | Joined on Jul 2008 @ Israel
#197
Originally Posted by coredumb View Post
damagedspline,
seems "data compression" doesn't work properly. it won't let waze do the transfer data, and keep show "searching network..." message.
10x for reporting, i will fix it and release an update in the next week or 2 (for such scenarios i've reserved v0.0.9)

mmmm... So now the release codenames will be:
1) Chico - fix for compression, and other stuff if such found
2) Djako - new map engine
3) Erlich - new ui
 

The Following 3 Users Say Thank You to damagedspline For This Useful Post:
Posts: 397 | Thanked: 273 times | Joined on Nov 2010 @ Italy
#198
Originally Posted by damagedspline View Post

@gianko - I am not sure that this new release will fix your crash, I made 2 fixes suggested by the ubuntu autobuilder compiler that might also be relevant to N900. anyway, after I am done with fixing the autobuilds for ubuntu and N9 - I will dedicate myself to the issue you're experiencing.
latest version installed but same segfault / illegal instruction errors.
i trust in a fix.
ps: do we still have to remove home/user/MyDocs/.waze folder everytime we update?
 
Posts: 329 | Thanked: 504 times | Joined on Jul 2008 @ Israel
#199
Originally Posted by gianko View Post
latest version installed but same segfault / illegal instruction errors.
i trust in a fix.
ps: do we still have to remove home/user/MyDocs/.waze folder everytime we update?
You don't have to delete. In any event it is very not recommended to manualy copy the data directory (in v0.0.8 and v0.0.7). If you did copy this directory in after installing v0.0.8 or v0.0.7, please remove ~/MyDocs/.waze/ . It will be recreated automatically on the first run.

I hope to finish the Ubuntu release by Monday and then I will add a lot of debugging messages and send you a new binary.
 
Posts: 329 | Thanked: 504 times | Joined on Jul 2008 @ Israel
#200
People that installed the v0.0.8 for N9 from apps4meego: can you please verify if there is a bug in the battery status detection (always think less than 30%) + screen not stay lit (Not stays lit even when enabled in the configuration)?

Last edited by damagedspline; 2012-05-04 at 23:44.
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 15:35.