Reply
Thread Tools
Posts: 170 | Thanked: 85 times | Joined on Dec 2011
#1
Hi All,

I am using my N9 with PR 1.2 . Previously, when I enabled developer mode, I could SSH in to my phone from my laptop (i.e phone as SSH Server) .

But now, when I enable developer mode, I am not able to SSH in. Also , I tried to start "sshd" manually by issuing command "/usr/sbin/sshd -p 22 -D" , it turns out there is no such executable. Instead there is a file called "sshd.disabled" in the /usr/sbin directory !!

I am baffled at this point! I want to be able to SSH in to my phone as I want to start working on developing a keyboard layout.
 

The Following 2 Users Say Thank You to nokiac For This Useful Post:
Posts: 86 | Thanked: 21 times | Joined on Jan 2010 @ That beer and prezels country in Europe -_-
#2
I'm having the same issue since PR 1.1, now also on PR 1.2
Deinstalling Developer Mode from list of programs and reinstalling it again helped.

Sometimes furious on/off switching of DevMode and restarting the device either with DevMode enabled or disabled helped.

SSH isn't started and won't start up and the sshd.disabled file is still there (no port assigned, no process running)

Don't know why...looks like enabling the DevMode does not complete to rename / copy files.
 
Posts: 170 | Thanked: 85 times | Joined on Dec 2011
#3
Hi,

I tried uninstalling the developer-* packages from application and then reinstalled, did not help.
Could you please list exactly which packages you removed and re-installed ?
 
Posts: 170 | Thanked: 85 times | Joined on Dec 2011
#4
As I mentioned above, uninstalling and reinstalling the developer-* packages from the settings/applications menu did not help .

So, I went to terminal, deleted the sshd.disabled file and thought that reinstalling just openssh-server should fix it. So I did "apt-get remove openssh-server" . And to my surprise, after it uninstalled that package, the phone also killed the dev-mode automatically, and the terminal/sdk icons were gone.

The I re-installed dev-mode by enabling it form the Settings GUI, and this somehow got back the SSH server .

This is totally unexplained behaviour! I am used to some sort of predictability in linux systems, coming from using Fedora/RHEL a lot.

But all is well that ends well.
 
Reply

Thread Tools

 
Forum Jump


All times are GMT -4. The time now is 08:38 PM.