Reply
Thread Tools
Posts: 26 | Thanked: 3 times | Joined on Oct 2011
#1
My N900's antenna is working very bad, not in every call, but very often.
The signal is full, 3g,2.5g,2g, but this changes nothing.
I've open the device with the level 1-2 guide and i've unmount the antenna two-three times.

My questions are:
is there a method to test my antenna?
is it possibile that is a software-related problem?
did I have broke something by opening my device?
where can I buy a new antenna?

thanks!
 
Posts: 8 | Thanked: 0 times | Joined on May 2012
#2
Originally Posted by Orsobirra View Post
My N900's antenna is working very bad, not in every call, but very often.
The signal is full, 3g,2.5g,2g, but this changes nothing.
I've open the device with the level 1-2 guide and i've unmount the antenna two-three times.

My questions are:
is there a method to test my antenna?
is it possibile that is a software-related problem?
did I have broke something by opening my device?
where can I buy a new antenna?

thanks!
I was having similar issues for the last 5 days, I always had full signal at home. then suddenly something changed and I couldn't get any signal indoors.
took me a few days to realise what I had done, I had swapped batteries with another n900 and this battery was behaving in an odd way (it would go off completely when it actually measured a 50% charge). Today I swapped back to my old battery and guess what ? full network coverage again.
 
Reply

Thread Tools

 
Forum Jump


All times are GMT -4. The time now is 05:40 PM.