Reply
Thread Tools
Posts: 632 | Thanked: 377 times | Joined on May 2010
#2731
i just started to use a fresh image "debian-m5-estel.img" and without installing anything, just wanted to update all packages, so i used the following:

apt-get update
apt-get upgrade -f
apt-get upgrade --fix-missing (was suggested to run this in output of previous command)

now when i run "apt-get update" -> no errors - finishes with no suggested updates
running apt-get upgrade generates the following:
---
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
file : Depends: libmagic1 (= 5.04-5+squeeze2) but 5.04-5 is installed
E: Unmet dependencies. Try using -f.
----

running "apt-get upgrade -f" generates the following:

----
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages have been kept back:
debian-multimedia-keyring libsmbclient pulseaudio samba-common smbclient ttf-opensymbol
The following packages will be upgraded:
libmagic1 libssl0.9.8
2 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.
70 not fully installed or removed.
Need to get 0 B/1,121 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
E: read, still have 12 to read but none left
E: Error reading archive member header
E: Prior errors apply to /var/cache/apt/archives/libmagic1_5.04-5+squeeze2_armel.deb
debconf: apt-extracttemplates failed: Bad file descriptor
Preconfiguring packages ...
(Reading database ... 65036 files and directories currently installed.)
Preparing to replace libssl0.9.8 0.9.8o-4squeeze7 (using .../libssl0.9.8_0.9.8o-4squeeze12_armel.deb) ...
Unpacking replacement libssl0.9.8 ...
dpkg: error processing /var/cache/apt/archives/libssl0.9.8_0.9.8o-4squeeze12_armel.deb (--unpack):
corrupted filesystem tarfile - corrupted package archive
configured to not write apport reports
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace libtiff4 3.9.4-5+squeeze4 (using .../libmagic1_5.04-5+squeeze2_armel.deb) ...
Unpacking replacement libtiff4 ...
Errors were encountered while processing:
/var/cache/apt/archives/libssl0.9.8_0.9.8o-4squeeze12_armel.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
----

Am i doing something wrong?
 
Posts: 523 | Thanked: 1,233 times | Joined on Jan 2011 @ Germany
#2732
Originally Posted by impeham View Post
Need to get 0 B/1,121 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
E: read, still have 12 to read but none left
E: Error reading archive member header
E: Prior errors apply to /var/cache/apt/archives/libmagic1_5.04-5+squeeze2_armel.deb
debconf: apt-extracttemplates failed: Bad file descriptor
It seems like apt thinks that you've already downloaded libmagic1 but it can't find the package.
Please run
Code:
apt-get clean
and try to upgrade again!
 

The Following User Says Thank You to sulu For This Useful Post:
Estel's Avatar
Posts: 4,900 | Thanked: 8,143 times | Joined on Mar 2011
#2733
I got little different question. One of Easy Debian dependencies is Murina Orange theme (for Maemo). It's great for many purposes - i.e. running Debian programs from within Maemo, via debbie - but it got big drawback. Somehow, it replaces "default" theme in situations, where Hildon GTK2 theme is unset - so, murina orange is seen in Truecrypt, or any other application with hildon theme unset before execution.

As Murina actually makes interface elements bigger, the result is, that many times important elements are "hidden", overlapped etc.

Any idea how to disable it for such situations, or at least, easily disable/enable it when needed?

/Estel
__________________
N900's aluminum backcover / body replacement
-
N900's HDMI-Out
-
Camera cover MOD
-
Measure battery's real capacity on-device
-
TrueCrypt 7.1 | ereswap | bnf
-
Hardware's mods research is costly. To support my work, please consider donating. Thank You!
 

The Following User Says Thank You to Estel For This Useful Post:
Posts: 632 | Thanked: 377 times | Joined on May 2010
#2734
Originally Posted by sulu View Post
It seems like apt thinks that you've already downloaded libmagic1 but it can't find the package.
Please run
Code:
apt-get clean
and try to upgrade again!
Thanks - problem solved.
 
Posts: 632 | Thanked: 377 times | Joined on May 2010
#2735
Originally Posted by Estel View Post
Haven't You though about starting from fresh image again? Lately, You seem to have many problems, that are hard to solve without knowing their source.

/Estel
Started from a fresh image, installed all updates first and then installed my wanted packages.

No problems with the updates anymore.
 

The Following User Says Thank You to impeham For This Useful Post:
ArchiMark's Avatar
Posts: 414 | Thanked: 109 times | Joined on Mar 2007 @ Silicon Valley
#2736
Two more ED questions please....using Estel's image file....

1. Tried watching a youtube video, first by using Epiphany browser....browser crashed, ie, window disappeared as it tried loading webpage with video....then tried Chromium browser, page loads, but don't see video, just black window with the little spinning circle thingie.....left window for long time (about 15-20 minutes...), but it never loads video....

Is this problem a function of limited functionality of ED and N900?

Anyway to get this working?


2. In order to log in to some webpages, I need to be able to type in my email address. However, when I try typing the '@' symbol, nothing happens....

How do I get this fixed?

Thanks!
__________________
Mark
Silicon Valley Digerati

Nokia N900
Previous: Nokia N810 & N800
 
Estel's Avatar
Posts: 4,900 | Thanked: 8,143 times | Joined on Mar 2011
#2737
Originally Posted by ArchiMark View Post
Two more ED questions please....using Estel's image file....

1. Tried watching a youtube video, first by using Epiphany browser....browser crashed, ie, window disappeared as it tried loading webpage with video....then tried Chromium browser, page loads, but don't see video, just black window with the little spinning circle thingie.....left window for long time (about 15-20 minutes...), but it never loads video....

Is this problem a function of limited functionality of ED and N900?

Anyway to get this working?
There are reports of bringing it to working state, but it's still too much memory hog. For watching flash videos, microB is still recommended.

Originally Posted by ArchiMark View Post
2. In order to log in to some webpages, I need to be able to type in my email address. However, when I try typing the '@' symbol, nothing happens....

How do I get this fixed?

Thanks!
copy Your (Maemo's) [b]/usr/share/X11/xkb/symbols/nokia_vndr/rx-51 file into Your *debian's* /usr/share/X11/xkb/symbols/nokia_vndr. From within Maemo, when Debian is mounted and .chrooted, it's /.debian//usr/share/X11/xkb/symbols/nokia_vndr, where You should copy file to. This way, you'll have exactly same hardware keyboard mapping, as in Maemo - of course, if You setxkbmap <your language> inside ED, or via Ed autostart script.

In layout that is found default in ED (before You copy rx-51), @ is just blue arrow + shift + space. Blue arrow + space is TAB. Default config is actually very useful, and contain many symbols assigned to blue arrow + shift + key, but I think that everyone will like own mapping's most.

/Estel
__________________
N900's aluminum backcover / body replacement
-
N900's HDMI-Out
-
Camera cover MOD
-
Measure battery's real capacity on-device
-
TrueCrypt 7.1 | ereswap | bnf
-
Hardware's mods research is costly. To support my work, please consider donating. Thank You!
 

The Following User Says Thank You to Estel For This Useful Post:
ArchiMark's Avatar
Posts: 414 | Thanked: 109 times | Joined on Mar 2007 @ Silicon Valley
#2738
Originally Posted by Estel View Post
There are reports of bringing it to working state, but it's still too much memory hog. For watching flash videos, microB is still recommended.
OK, thanks for explaining....



copy Your (Maemo's) [b]/usr/share/X11/xkb/symbols/nokia_vndr/rx-51 file into Your *debian's* /usr/share/X11/xkb/symbols/nokia_vndr. From within Maemo, when Debian is mounted and .chrooted, it's /.debian//usr/share/X11/xkb/symbols/nokia_vndr, where You should copy file to.
OK, done....

This way, you'll have exactly same hardware keyboard mapping, as in Maemo - of course, if You setxkbmap <your language> inside ED, or via Ed autostart script.
By 'ED autostart script', do you refer to
'/etc/xdg/lxsession/LXDE/autostart' or ?

If you meant in '/etc/xdg/lxsession/LXDE/autostart', then would I enter a line like this:

Code:
@setxkbmap us
Or ?



In layout that is found default in ED (before You copy rx-51), @ is just blue arrow + shift + space. Blue arrow + space is TAB. Default config is actually very useful, and contain many symbols assigned to blue arrow + shift + key, but I think that everyone will like own mapping's most.

/Estel
Thanks for the info...it worked, but as you say, would prefer US keyboard mapping as I'm used to it now...
__________________
Mark
Silicon Valley Digerati

Nokia N900
Previous: Nokia N810 & N800
 
Estel's Avatar
Posts: 4,900 | Thanked: 8,143 times | Joined on Mar 2011
#2739
Yes, I mean file You've mentioned. It isn't working for You, or You've asked just in case?
__________________
N900's aluminum backcover / body replacement
-
N900's HDMI-Out
-
Camera cover MOD
-
Measure battery's real capacity on-device
-
TrueCrypt 7.1 | ereswap | bnf
-
Hardware's mods research is costly. To support my work, please consider donating. Thank You!
 

The Following User Says Thank You to Estel For This Useful Post:
ArchiMark's Avatar
Posts: 414 | Thanked: 109 times | Joined on Mar 2007 @ Silicon Valley
#2740
Originally Posted by Estel View Post
Yes, I mean file You've mentioned. It isn't working for You, or You've asked just in case?
Thanks for confirming file....

I just wanted to make sure that I am doing the right thing....trying to avoid making more mistakes and screw-ups than I already do.....

So, I edited that file as I noted in my previous post and keyboard mapping is good no, ie, same as in Maemo....

Thanks!
__________________
Mark
Silicon Valley Digerati

Nokia N900
Previous: Nokia N810 & N800
 

The Following User Says Thank You to ArchiMark For This Useful Post:
Reply

Tags
beta, debian, easy debian, extras-devel, fremantle, i <3 qole, squeeze

Thread Tools

 
Forum Jump


All times are GMT. The time now is 23:07.