Reply
Thread Tools
marxian's Avatar
Posts: 2,297 | Thanked: 8,472 times | Joined on Aug 2010 @ Wigan, UK
#51
Originally Posted by sifo View Post
Thank you all for your replies
And here come the story how can i copy stuff from / to scratchbox (MyDocs) ?

./sifo
Code:
cp <files> /scratchbox/users/<username>/home/<username>/MyDocs
You can also mount directories in scratchbox like this:

Code:
sudo mount --bind <directory> /scratchbox/users/<username>/home/<username>/MyDocs/mydir
The above example mounts the chosen directory in scratchbox as a subdirectory of MyDocs called 'mydir'.

I prefer to use the second approach when working with Qt Creator and scratchbox, as there is then no need to copy files. I write code in Qt Creator, then compile in scratchbox.
__________________
Its already dog-eat-dog, friend. Im not sure what worse a bunch of zombies could do.

My website

GitHub

Last edited by marxian; 10-25-2012 at 05:59 PM.
 

The Following 3 Users Say Thank You to marxian For This Useful Post:
sifo's Avatar
Posts: 1,359 | Thanked: 1,288 times | Joined on Oct 2011 @ Tartus.Syria
#52
Thank you marxian that helped a lot ( silly me )
__________________
[ N900-Crack ] [ The Purge ] [ New Smiles ] [ New icons ] [ ? ]
" Hey ! I've just met you and this is crazy, so install cssu maybe ? "
Please help out keeping Maemo.org alive, and consider donating.
https://www.facebook.com/ZoRk7
 
sifo's Avatar
Posts: 1,359 | Thanked: 1,288 times | Joined on Oct 2011 @ Tartus.Syria
#53
the qt-sdk version i have is 1.1.2 i downloaded this old as i expected to have maemo target ( which was not in 1.2.1 ) and i only have now the desktop and qt simulator targets !
so when i go to the SDKMaintenanceTool i get an error as in the screenshot !
please help

( im thinking about moving to learn python or Gtk+, do you recommend that ? )
Thanks
Attached Images
 
__________________
[ N900-Crack ] [ The Purge ] [ New Smiles ] [ New icons ] [ ? ]
" Hey ! I've just met you and this is crazy, so install cssu maybe ? "
Please help out keeping Maemo.org alive, and consider donating.
https://www.facebook.com/ZoRk7
 
marxian's Avatar
Posts: 2,297 | Thanked: 8,472 times | Joined on Aug 2010 @ Wigan, UK
#54
You should be able to add the Maemo5 toolchain to the latest version of the SDK. No need to install an earlier version. However, as a (possible) fix, I have attached the files from my 'Licences' folder. Place these in your ~/QtSDK/Licences folder (create the folder if it does not already exist).
Attached Files
File Type: zip licences.zip (49.4 KB, 25 views)
__________________
Its already dog-eat-dog, friend. Im not sure what worse a bunch of zombies could do.

My website

GitHub
 

The Following 2 Users Say Thank You to marxian For This Useful Post:
sifo's Avatar
Posts: 1,359 | Thanked: 1,288 times | Joined on Oct 2011 @ Tartus.Syria
#55
that directory is already there, but i overwrite with your files and still the same error
but hold on ! im in a blocked country ! is this what causing the whole problem ?
Much appreciated

./sifo
__________________
[ N900-Crack ] [ The Purge ] [ New Smiles ] [ New icons ] [ ? ]
" Hey ! I've just met you and this is crazy, so install cssu maybe ? "
Please help out keeping Maemo.org alive, and consider donating.
https://www.facebook.com/ZoRk7
 
marxian's Avatar
Posts: 2,297 | Thanked: 8,472 times | Joined on Aug 2010 @ Wigan, UK
#56
Originally Posted by sifo View Post
that directory is already there, but i overwrite with your files and still the same error
but hold on ! im in a blocked country ! is this what causing the whole problem ?
Much appreciated

./sifo
I don't think so. It's complaining that the file does not exist. Maybe it is looking in the wrong location. Do you have multiple versions of the SDK installed?
__________________
Its already dog-eat-dog, friend. Im not sure what worse a bunch of zombies could do.

My website

GitHub
 

The Following User Says Thank You to marxian For This Useful Post:
sifo's Avatar
Posts: 1,359 | Thanked: 1,288 times | Joined on Oct 2011 @ Tartus.Syria
#57
No but i have multiple qt-creator versions, one from the SDK and one from ubuntu repos, im going now to remove what i dont need
Thanks
__________________
[ N900-Crack ] [ The Purge ] [ New Smiles ] [ New icons ] [ ? ]
" Hey ! I've just met you and this is crazy, so install cssu maybe ? "
Please help out keeping Maemo.org alive, and consider donating.
https://www.facebook.com/ZoRk7
 

The Following User Says Thank You to sifo For This Useful Post:
sifo's Avatar
Posts: 1,359 | Thanked: 1,288 times | Joined on Oct 2011 @ Tartus.Syria
#58
still the same error
im thinking about reinstalling the sdk, but i cant find it in the "installed apps" in application manager, shuold i use rm -r ?
thanks
__________________
[ N900-Crack ] [ The Purge ] [ New Smiles ] [ New icons ] [ ? ]
" Hey ! I've just met you and this is crazy, so install cssu maybe ? "
Please help out keeping Maemo.org alive, and consider donating.
https://www.facebook.com/ZoRk7
 

The Following User Says Thank You to sifo For This Useful Post:
marxian's Avatar
Posts: 2,297 | Thanked: 8,472 times | Joined on Aug 2010 @ Wigan, UK
#59
Originally Posted by sifo View Post
still the same error
im thinking about reinstalling the sdk, but i cant find it in the "installed apps" in application manager, shuold i use rm -r ?
thanks
QtSDK is (by default) installed in ~/QtSDK. So you can remove it simply by deleting that folder.
__________________
Its already dog-eat-dog, friend. Im not sure what worse a bunch of zombies could do.

My website

GitHub
 

The Following 2 Users Say Thank You to marxian For This Useful Post:
sifo's Avatar
Posts: 1,359 | Thanked: 1,288 times | Joined on Oct 2011 @ Tartus.Syria
#60
So i gave up making Tor working on my ubuntu ( i need it to access the sdk repo ),
Finally i got ride of it on my Windows 7 by using hot spot shield, Downloading now Maemo tool-chain, i hope it will work fine
thank you all

./sifo

Edit : i failed downloading it i got "data corrupted error" will try reinstalling the whole sdk as i played too much with it.
__________________
[ N900-Crack ] [ The Purge ] [ New Smiles ] [ New icons ] [ ? ]
" Hey ! I've just met you and this is crazy, so install cssu maybe ? "
Please help out keeping Maemo.org alive, and consider donating.
https://www.facebook.com/ZoRk7

Last edited by sifo; 12-20-2012 at 06:38 AM. Reason: Failed
 

The Following User Says Thank You to sifo For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT -4. The time now is 04:40 PM.