Notices


Reply
Thread Tools
Posts: 38 | Thanked: 25 times | Joined on Mar 2011
#1
HOWTO


install anki2 on your n900
http://talk.maemo.org/showpost.php?p=1326179

install anki2 on easy-debian on your n900
http://talk.maemo.org/showpost.php?p=1326077


------------------------------------------

Hi guys,

Since 7th of February, anki 1 does not allow to sync its state with multiple devices. Users are encouraged to upgrade to anki 2 or use the new web interface.

I don't have a data plan and cannot use the web version. It would cost too much.

How are you using anki right now?

Thanks in advance for your answers.

Last edited by darodi; 2013-09-13 at 22:57. Reason: added links
 

The Following 2 Users Say Thank You to darodi For This Useful Post:
Posts: 399 | Thanked: 598 times | Joined on Dec 2012
#2
You can always try ankiqml with MeeCoLay libraries
 

The Following 2 Users Say Thank You to elros34 For This Useful Post:
Posts: 38 | Thanked: 25 times | Joined on Mar 2011
#3
here is what i get, even if the file is there:

Code:
$ meecolay /opt/ankiqml/usr/bin/ankiqml
/usr/bin/meecolay: exec: line 11: /opt/ankiqml/usr/bin/ankiqml: not found
First time i try meecolay, I've no clue how to solve this.
And i read here that ankiqml doesn't support sound
http://talk.maemo.org/showpost.php?p...8&postcount=79

guess i'll have to try easy-debian now....

If it doesn't work, I'll stick with nitdroid but it's not convenient to reboot the phone every time i want to use anki2

Last edited by darodi; 2013-02-19 at 00:12.
 

The Following User Says Thank You to darodi For This Useful Post:
Posts: 38 | Thanked: 25 times | Joined on Mar 2011
#4
too many dependencies problems with easy-debian.
I used image debian-m5-v3e.img.ext2.lzma

with the .deb file:

Code:
The following packages have unmet dependencies:
  anki: Depends: libqtgui4 (>= 4.7) but it is not going to be installed
  lame: Depends: libncurses5 (>= 5.7+20100313) but 5.7+20090803-2 is to be installed
  mplayer: Depends: liba52-0.7.4 but it is not going to be installed
           Depends: libartsc0 (>= 1.5.9) but it is not going to be installed
           Depends: libaudio2 but it is not going to be installed
           Depends: libbs2b0 but it is not going to be installed
           Depends: libcaca0 (>= 0.99.beta17-1) but it is not going to be installed
           Depends: libcdparanoia0 (>= 3.10.2+debian) but it is not going to be installed
           Depends: libdirectfb-1.2-9 but it is not installable
           Depends: libdv4 but it is not going to be installed
           Depends: libenca0 (>= 1.9) but it is not going to be installed
           Depends: libfribidi0 (>= 0.19.2) but it is not going to be installed
           Depends: libggi2 (>= 1:2.2.2) but it is not going to be installed
           Depends: libggiwmh0 (>= 0.3.2) but it is not going to be installed
           Depends: libjack-jackd2-0 (>= 1.9.5~dfsg-14) but it is not installable or
                    libjack-0.116 but it is not installable
           Depends: liblircclient0 but it is not going to be installed
           Depends: liblzo2-2 but it is not going to be installed
           Depends: libncurses5 (>= 5.7+20100313) but 5.7+20090803-2 is to be installed
           Depends: liborc-0.4-0 (>= 1:0.4.6) but it is not installable
           Depends: librtmp0 (>= 2.3) but it is not installable
           Depends: libsdl1.2debian (>= 1.2.10-1) but it is not going to be installed
           Depends: libvpx0 (>= 0.9.0) but it is not going to be installed
           Depends: libx264-112 (>= 1:0.svn20110115) but it is not going to be installed
           Depends: libxss1 but it is not going to be installed
           Depends: libxvmc1 but it is not going to be installed
           Depends: mplayer-skin
  python-qt4: Depends: libqt4-assistant (>= 4.4.0) but it is not going to be installed
              Depends: libqt4-designer (>= 4.4.0) but it is not going to be installed
              Depends: libqt4-help (>= 4.4.0) but it is not going to be installed
              Depends: libqt4-network (>= 4.4.0) but it is not going to be installed
              Depends: libqt4-script (>= 4.4.0) but it is not going to be installed
              Depends: libqt4-svg (>= 4.4.0) but it is not going to be installed
              Depends: libqt4-test (>= 4.4.0) but it is not going to be installed
              Depends: libqt4-webkit (>= 4.4.0) but it is not going to be installed
              Depends: libqt4-xml (>= 4.4.0) but it is not going to be installed
              Depends: libqt4-xmlpatterns (>= 4.4.0) but it is not going to be installed
              Depends: libqtcore4 (>= 4.4.0) but it is not going to be installed
              Depends: libqtgui4 (>= 4.4.0) but it is not going to be installed
              Depends: python (< 2.6) but 2.6.6-3+squeeze1 is to be installed
              Depends: python-central (>= 0.6.7) but it is not going to be installed
              Depends: python-sip4 (>= 4.7.6) but it is not going to be installed
              Depends: python-sip4 (< 4.8) but it is not going to be installed
              Depends: python-elementtree but it is not going to be installed
              Depends: python-qt4-common but it is not going to be installed
  python-sqlalchemy: Depends: python (>= 2.6.6-3+squeeze3~) but 2.6.6-3+squeeze1 is to be installed
                     Recommends: python-sqlalchemy-ext but it is not going to be installed

with the source file, you need those prerequisites:

apt-get install python-qt4 mplayer lame libportaudio2 python-sqlalchemy

Code:
The following packages have unmet dependencies:
  lame: Depends: libncurses5 (>= 5.7+20100313) but 5.7+20090803-2 is to be installed
  mplayer: Depends: libcaca0 (>= 0.99.beta17-1) but it is not going to be installed
           Depends: libdirectfb-1.2-9 but it is not installable
           Depends: libfribidi0 (>= 0.19.2) but it is not going to be installed
           Depends: libjack-jackd2-0 (>= 1.9.5~dfsg-14) but it is not installable or
                    libjack-0.116 but it is not installable
           Depends: libncurses5 (>= 5.7+20100313) but 5.7+20090803-2 is to be installed
           Depends: liborc-0.4-0 (>= 1:0.4.6) but it is not installable
           Depends: librtmp0 (>= 2.3) but it is not installable
  python-qt4: Depends: python (< 2.6) but 2.6.6-3+squeeze1 is to be installed
              Depends: python-central (>= 0.6.7) but it is not going to be installed
              Depends: python-sip4 (>= 4.7.6) but it is not going to be installed
              Depends: python-sip4 (< 4.8) but it is not going to be installed
              Depends: python-qt4-common but it is not going to be installed
  python-sqlalchemy: Depends: python (>= 2.6.6-3+squeeze3~) but 2.6.6-3+squeeze1 is to be installed
 

The Following User Says Thank You to darodi For This Useful Post:
Posts: 38 | Thanked: 25 times | Joined on Mar 2011
#5
Anki2 for easy-debian on n900
  • install easy-debian http://wiki.maemo.org/Easy_Debian#Install_instructions
  • sudo debian
    Only if needed:
    vi /etc/apt/sources.list
    and rename repo "debian-multimedia.org" to "deb-multimedia.org"
    :%s/debian-mult/deb-mult/g
  • nice -n 19 apt-get update
  • nice -n 19 apt-get install --no-install-recommends python-qt4 mplayer lame libportaudio2 python-sqlalchemy pulseaudio
  • cd /home/user
  • create a link to MyDocs (the database can be huge)
    mkdir /home/user/MyDocs/.anki
    mkdir /home/user/MyDocs/Anki
    ln -s /home/user/MyDocs/.anki .anki
    ln -s /home/user/MyDocs/Anki Anki
  • wget http://ankisrs.net/download/mirror/anki-2.0.12.tgz
  • tar xvzf anki-2.0.12.tgz
  • exit your debian-root terminal
  • you can run anki by launching:
    debbie /home/user/anki-2.0.12/runanki

Last edited by darodi; 2013-09-16 at 22:09. Reason: updated for version 2.0.12
 

The Following User Says Thank You to darodi For This Useful Post:
Posts: 38 | Thanked: 25 times | Joined on Mar 2011
#6
Almost there....

Then I tried to run the source package directly in maemo natively.
  • sudo apt-get install python2.5-qt4 mplayer lame libportaudio2 python-sqlalchemy
  • cd /home/user
  • ln -s /home/user/MyDocs/.anki/ .anki
  • wget http://ankisrs.net/download/mirror/anki-2.0.8.tgz
  • tar xvzf anki-2.0.8.tgz
  • use the attached patch (code source change to make it compatible with python 2.5)

It works too except I get one error when trying to synchronize:
Code:
Syncing failed
SSL certificate validation is not supported without the ssl module installed. To avoid this error, install the ssl module, or explicitly disable validation
python-openssl is installed.
Anyone has an idea?


My temporary solution is to run debian version to synchronize and maemo version to use and study.
Attached Files
File Type: txt anki.patch.txt (1.6 KB, 148 views)
 

The Following User Says Thank You to darodi For This Useful Post:
Posts: 38 | Thanked: 25 times | Joined on Mar 2011
#7
How to install on n900
(not using easy debian)

  • sudo gainroot
  • apt-get install python2.5-qt4 mplayer lame libportaudio2 python-sqlalchemy busybox-power
  • cd /home/user
  • create a link to MyDocs (the database can be huge)
    mkdir /home/user/MyDocs/.anki
    mkdir /home/user/MyDocs/Anki
    ln -s /home/user/MyDocs/.anki .anki
    ln -s /home/user/MyDocs/Anki Anki
  • wget http://ankisrs.net/download/mirror/anki-2.0.8.tgz
  • tar xvzf anki-2.0.8.tgz
  • place the attached patch (source code change to make it compatible with python 2.5) in /home/user/
  • cd /home/user/anki-2.0.8
  • run
    patch -p1 < ../anki.patch.txt
  • apt-get install libssl-dev python-dev libbluetooth3-dev gcc libc6-dev python-setuptools
  • easy_install pip
  • pip install ssl
  • apt-get autoremove --purge libssl-dev python-dev libbluetooth3-dev libc6-dev
  • run it with
    /home/user/anki-2.0.8/runanki


there are still a few small minor display problems.
But the application works.
Attached Files
File Type: txt anki.patch.txt (1.6 KB, 270 views)

Last edited by darodi; 2013-09-14 at 00:25. Reason: added how to apply patch
 
Posts: 2 | Thanked: 0 times | Joined on Jan 2013
#8
Hi!
I dare not start installing things before I know how to. In this regard, I am not sure how to use the attached patch. Can anyone help me?
Also, thank you for your efforts to bring this very useful learning tool to the newest version. Among other things that failed to deliver due to lack of mainstream interest in this platform, Anki was the last straw, I'm seriosly considering Android if this doesn't work. I know, it's horrible, what can one do...
 
Posts: 38 | Thanked: 25 times | Joined on Mar 2011
#9
Originally Posted by svg View Post
Hi!
I dare not start installing things before I know how to. In this regard, I am not sure how to use the attached patch. Can anyone help me?
Also, thank you for your efforts to bring this very useful learning tool to the newest version. Among other things that failed to deliver due to lack of mainstream interest in this platform, Anki was the last straw, I'm seriosly considering Android if this doesn't work. I know, it's horrible, what can one do...
to use the patch:
  • apt-get install busybox-power
  • place the patch in /home/user/
  • cd /home/user/anki-2.0.8
  • run
    patch -p1 < ../anki.patch.txt

I added this in the previous "how to"

Last edited by darodi; 2013-09-14 at 00:24.
 
Posts: 2 | Thanked: 0 times | Joined on Nov 2011
#10
I tried to download and install the newest version 2.0.22, I edit the batch for this version, but "easy_install pip" shows error (syntax error). is there anyone to help me?

Last edited by alibaba2; 2014-03-15 at 09:35.
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 01:04.