Notices


Reply
Thread Tools
Posts: 631 | Thanked: 412 times | Joined on Dec 2009 @ Kaliningrad, Russia
#1
Hey y'all.
Two days ago I was using my Nokia N9 and suddenly it started to fail in different ways:
camera failed to start, keyboard failed to show up, 2G/3G inernet connection disappeared from "Connect to the Internet" menu.

So I decided to reboot N9. Then I found that Advanced Power Menu fail to start too.
So I pressed and held power button until device turns off, and turned on it again. N9 didn't turn on completely, it rebooted a few times and after that it had boot up, but with all settings, contacts etc were gone, all buttons and images looked like red squares.
I tried to restore backup, but after reboot it looked like it did nothing.
I tried to "restore settings" without clearing data, it rebooted and icons and buttons looked fine, but all my data, including photos, backups and notes was gone. Applications didn't disappear though.

But things got worse.
Now, after every reboot, device clears all data: contacts, photos, etc disappear.

One interesting thing more:
In settings - Data storage it shows available memory for apps and apps data, but it says "not available in mass storage mode" in user data memory.
It also says "Can't access user data" when I connect phone to PC.
But I still can surf to /user/home in File case.


Any advice?
 
peterleinchen's Avatar
Posts: 3,321 | Thanked: 6,208 times | Joined on Aug 2010 @ Ruhrgebiet, Germany
#2
Hmm?
Sounds like failure of mmc chip (especially /dev/mmcblk0p3)?

But tbh I have no idea.
Can you access (write) on MyDocs?
__________________
SIM-Switcher, automated SIM switching with a Double (Dual) SIM adapter
--
Thank you all for voting me into the Community Council 2014-2016!

Please consider your membership / supporting Maemo e.V. and help to spread this by following/copying this link to your TMO signature:
[MC eV] Maemo Community eV membership application, http://talk.maemo.org/showthread.php?t=94257

editsignature, http://talk.maemo.org/profile.php?do=editsignature
 

The Following 3 Users Say Thank You to peterleinchen For This Useful Post:
Posts: 631 | Thanked: 412 times | Joined on Dec 2009 @ Kaliningrad, Russia
#3
BusyBox v1.20.0.git (MeeGo 3:1.20-0.2+0m8) built-in shell (ash)
Enter 'help' for a list of built-in commands.

~ $ cd /home/user/MyDocs/
-/bin/sh: cd: can't cd to /home/user/MyDocs/
~ $ cd /home/user/
~ $ ls
private test
~ $

O_o
Looks like I don't have MyDocs anymore.
I can create this dirrectory, but I am pretty sure it will gone after reboot...

will reflash help?
I think I also can make a simlink in /home to other places to prevent loosing my data like some kind of workaround. Gotta give a try.
 
Posts: 631 | Thanked: 412 times | Joined on Dec 2009 @ Kaliningrad, Russia
#4
The phone also doesn't start in flasher mode:
I start flasher on my PC, it says "Suitable USB interface (bootloader/phonet) not found, waiting..."
Then I connect the phone and... it just turns on like it does not connected to PC or it keeps rebooting or it shows "charging" icon.
Finally it shows "Device not working properly" because of "too many reboots" message and advice me to update software or contact Nokia Care...
Flasher still on "Suitable USB interface (bootloader/phonet) not found, waiting..." stage.
 
coderus's Avatar
Posts: 6,129 | Thanked: 11,556 times | Joined on Nov 2011 @ Open Mobile Platform, Innopolis, Russia
#5
start flasher with -c parameter and hold power key until flasher detects phone
__________________
Twitter | Openrepos | GitHub | PayPal.Me
 

The Following User Says Thank You to coderus For This Useful Post:
Posts: 631 | Thanked: 412 times | Joined on Dec 2009 @ Kaliningrad, Russia
#6
Code:
C:\Program Files\Nokia\Flasher>flasher -c
flasher 3.12.1 (Oct  6 2011) Harmattan
WARNING: This tool is intended for professional use only. Using it may result
in permanently damaging your device or losing the warranty.

ERROR: You have to supply the 2nd image
ERROR: Cold flashing failed.

C:\Program Files\Nokia\Flasher>
I don't understand what is it want.

upd.
I saw your answer here, tried to do this, but I stack with
Code:
C:\Program Files\Nokia\Flasher>flasher -c -F DFL61_HARMATTAN_40.2012.21-3_PR_LEGACY_001-OEM1-958_ARM.bin
flasher 3.12.1 (Oct  6 2011) Harmattan
WARNING: This tool is intended for professional use only. Using it may result
in permanently damaging your device or losing the warranty.

Using 1st image to detect HW
Suitable USB interface (bootrom) not found, waiting...
N9 doesn't boot up anymore (with or without usb connection), it keeps rebooting until "Device not working properly" message.

Last edited by Kroll; 2015-09-20 at 19:39.
 
peterleinchen's Avatar
Posts: 3,321 | Thanked: 6,208 times | Joined on Aug 2010 @ Ruhrgebiet, Germany
#7
Oops.
I would not have risked to flash (, maybe).

Now, what was the output of flasing procedure?
__________________
SIM-Switcher, automated SIM switching with a Double (Dual) SIM adapter
--
Thank you all for voting me into the Community Council 2014-2016!

Please consider your membership / supporting Maemo e.V. and help to spread this by following/copying this link to your TMO signature:
[MC eV] Maemo Community eV membership application, http://talk.maemo.org/showthread.php?t=94257

editsignature, http://talk.maemo.org/profile.php?do=editsignature
 
Posts: 631 | Thanked: 412 times | Joined on Dec 2009 @ Kaliningrad, Russia
#8
Originally Posted by peterleinchen View Post
Oops.
I would not have risked to flash (, maybe).

Now, what was the output of flasing procedure?
Too late, I gave a try. N9 doesn't boot up anymore (with or without usb connection), it keeps rebooting until "Device not working properly" message and sometimes it comes to "charging" icon when I connect it to USB no matter flasher is running or not.

I can't flash it because it does not boot to "flashing" mode, so flasher doesn't detect it and stays on "Suitable USB interface (bootloader/phonet) not found, waiting..." stage.
I have tried on Ubuntu 14.04 and Windows 10 (also tried different USB ports) with the same result.
 
coderus's Avatar
Posts: 6,129 | Thanked: 11,556 times | Joined on Nov 2011 @ Open Mobile Platform, Innopolis, Russia
#9
you should press and hold power button until flasher find your phone
__________________
Twitter | Openrepos | GitHub | PayPal.Me
 
peterleinchen's Avatar
Posts: 3,321 | Thanked: 6,208 times | Joined on Aug 2010 @ Ruhrgebiet, Germany
#10
Yep.
Decoupling battery (holding power button for 8 seconds).
And I guess you'll need cold flash (-c) also.
How did you flash?
Only firmware image?
Or also eMMC image?
I would go step-by-step and first try only firmware and only then do the full wipe. If that does not help I am afraid you got a brick.

Post all commands and output of flashing here....
__________________
SIM-Switcher, automated SIM switching with a Double (Dual) SIM adapter
--
Thank you all for voting me into the Community Council 2014-2016!

Please consider your membership / supporting Maemo e.V. and help to spread this by following/copying this link to your TMO signature:
[MC eV] Maemo Community eV membership application, http://talk.maemo.org/showthread.php?t=94257

editsignature, http://talk.maemo.org/profile.php?do=editsignature
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 00:16.