Notices


Reply
Thread Tools
Posts: 2,152 | Thanked: 1,490 times | Joined on Jan 2006 @ Czech Republic
#531
Originally Posted by fanoush View Post
Thanks for testing. This means the code really does not work on many (all?) devices. Let's just hope it is my bug and can be fixed. It seems unlikely that someone inside Nokia bothered to write the tearsync code for N770 (which is completely different than code for n800) but the hardware in fact does not support it. Still it never made into official N770 kernel so maybe they found it later, who knows.
Reviving this one year old issue. Got tearsync support working with Nokia 770 :-)


Working source patch http://fanoush.wz.cz/maemo/#tearsync.
Works for me but take is as experimental code. I have tested it with two (=all?) widely available 770 board revisions - 1602 and 1802.

For kernel image get one of SDHC ones http://fanoush.wz.cz/maemo/#sdhc it is now part of them. If you already flashed one of them before, please redownload and reflash, previous versions had the non-working tearsync version included by mistake. It was harmless unless you actually try it with mplayer and use options below.

All source patches and kernel configuration used for compiling the image is now inside .tar.gz file in 'source' directory.

After flashing zImage from the archive, you can test it with mplayer arguments '-vo nokia770:tearsync=1'. If it works, you can also set it as default by adding line to /home/user/.mplayer/config
Code:
# Write your default config options here!
vo=nokia770:tearsync=1
Or to enable yuv420 mode too (gives slight speedup), you can add
Code:
# Write your default config options here!
vo=nokia770:tearsync=1,yuv420=1
So after approx. one year delay we finally have it working. What took so long? Basically it was just lack of information, magic words are "pin muxing, ball G20, register 4, value 6, offset 6". The original code posted year ago was OK, it was just a matter of enabling TE pin input on OMAP side. Sadly pin muxing is done in bootloader and 770 bootloader have this disabled. Also getting this information was a pain since TI pretends there is no such thing as SoSSI in OMAP1 chips, documentation for SoSSI was intentionally removed from current and some past revisions of OMAP5912 datasheets.
__________________
Newbies click here before posting. Thanks.

If you really need to PM me with troubleshooting question please consider posting it to the forum instead. It is OK to PM me a link to such post then. Thank you.

Last edited by fanoush; 04-08-2008 at 03:03 AM. Reason: links changed, now part of SDHC kernels
 

The Following 7 Users Say Thank You to fanoush For This Useful Post:
Posts: 31 | Thanked: 8 times | Joined on Sep 2006
#532
and of course it works. Beautifully. Many many thanks
 
Posts: 7 | Thanked: 1 time | Joined on Aug 2007
#533
thank you! works great!
 
Posts: 503 | Thanked: 267 times | Joined on Jul 2006 @ Helsinki
#534
Originally Posted by fanoush View Post
Reviving this one year old issue. Got tearsync support working with Nokia 770 :-)
Thanks, it works great.

Or to enable yuv420 mode too (gives slight speedup), you can add
Code:
# Write your default config options here!
vo=nokia770:tearsync=1,yuv420=1
A minor typo correction, you need to write 'vo=nokia770:tearsync=1:yuv420=1' in the configuration file to activate the use of both yuv420 mode and tearsync.

Anyway, I'll add automatic detection of kernel support for these features and mplayer will use them by default in the next build. So there would be no need tweaking configuration files (unless you would like to disable tearsync ) and just flashing an upgraded kernel would be enough for getting better video quality and performance.
 

The Following 2 Users Say Thank You to Serge For This Useful Post:
Posts: 28 | Thanked: 1 time | Joined on Jul 2008
#535
Is it normal that mplayer (v. 1.0rc1-maemo.27 and 18) hangs on some divx movies when movie starts?

Last edited by Gomez; 07-15-2008 at 03:44 AM.
 
Posts: 9 | Thanked: 2 times | Joined on Sep 2008
#536
I got a similar question, for some mp4 file, the picture freezes while the sound plays smoothly, anyone got ideas?


BTW: I saw the new mplayer released, when will Maemo version update?


thanks guys,
 
Posts: 503 | Thanked: 267 times | Joined on Jul 2006 @ Helsinki
#537
Originally Posted by aya View Post
I got a similar question, for some mp4 file, the picture freezes while the sound plays smoothly, anyone got ideas?
Yes, it is too slow and has to skip frames. In your case it essentially skips almost all the frames.

BTW: I saw the new mplayer released, when will Maemo version update?
Yes, it was released long ago. Moreover, a lot more features are available in SVN version of upstream mplayer which is unreleased yet. But I'm not working on this stuff at the moment, a new maintainer/packager joining garage mplayer project would help.
 

The Following User Says Thank You to Serge For This Useful Post:
Posts: 503 | Thanked: 267 times | Joined on Jul 2006 @ Helsinki
#538
Originally Posted by Gomez View Post
Is it normal that mplayer (v. 1.0rc1-maemo.27 and 18) hangs on some divx movies when movie starts?
No, it's not normal.
 
Posts: 9 | Thanked: 2 times | Joined on Sep 2008
#539
Originally Posted by Serge View Post
Yes, it is too slow and has to skip frames. In your case it essentially skips almost all the frames..
Thanks, I did try with skipframe option under X-term and eventually I got a message that my n800 is too slow to play this movie. Sigh...


Yes, it was released long ago. Moreover, a lot more features are available in SVN version of upstream mplayer which is unreleased yet. But I'm not working on this stuff at the moment, a new maintainer/packager joining garage mplayer project would help.
Do you mean 1.0rc2? I also saw updates for libdvdnav-4.1.3 and libdvdread-4.1.3.

Thanks anyway!
 
Posts: 10 | Thanked: 3 times | Joined on Mar 2009
#540
Is mplayer for maemo dead?
 
Reply

Thread Tools

 
Forum Jump


All times are GMT -4. The time now is 01:00 AM.