Reply
Thread Tools
Posts: 609 | Thanked: 232 times | Joined on Dec 2007 @ the end of my rope
#21
Originally Posted by grog View Post
Only by shutting all of them down was I able to properly configure them, as well as osso-software-version-rx44. TX
Can you expand on this? How do I know if I have these other problems you experienced? I'm especially concerned about the osso-software-version, since that is what will enable future updates to be pushed through to my NIT, right?
 
grog's Avatar
Posts: 546 | Thanked: 85 times | Joined on Feb 2008 @ Winnipeg, Canada
#22
Originally Posted by lm2 View Post
Can you expand on this? How do I know if I have these other problems you experienced? I'm especially concerned about the osso-software-version, since that is what will enable future updates to be pushed through to my NIT, right?
Fortunately I had saved my log, so I can show you exactly the errors I experienced (by log I mean under Tools, Log in the the Application manager. Take a look after you attempt the update)
Code:
Upgrading osso-software-version-rx44 1:5.2008.43-7 to 1:5.2008.43-7
Setting up mediaplayer-daemon (1.3.23-1) ...
Starting Media Player Daemon: mediaplayer-engineinvoke-rc.d: initscript mediaplayer-daemon, action "start" failed.
dpkg: error processing mediaplayer-daemon (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of libmediaplayer0:
 libmediaplayer0 depends on mediaplayer-daemon; however:
  Package mediaplayer-daemon is not configured yet.
dpkg: error processing libmediaplayer0 (--configure):
 dependency problems - leaving unconfigured
Setting up mce (1.7.23) ...
Starting Mode Controller Entity: mceinvoke-rc.d: initscript mce, action "start" failed.
dpkg: error processing mce (--configure):
 subprocess post-installation script returned error exit status 1
Setting up metalayer-crawler0 (1.3.19-2) ...
Starting Metalayer Crawler: metalayer-crawler0invoke-rc.d: initscript metalayer-crawler0, action "start" failed.
dpkg: error processing metalayer-crawler0 (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of osso-software-version-rx44:
 osso-software-version-rx44 depends on libmediaplayer0 (= 1.3.23-1); however:
  Package libmediaplayer0 is not configured yet.
 osso-software-version-rx44 depends on mce (= 1.7.23); however:
  Package mce is not configured yet.
 osso-software-version-rx44 depends on mediaplayer-daemon (= 1.3.23-1); however:
  Package mediaplayer-daemon is not configured yet.
 osso-software-version-rx44 depends on metalayer-crawler0 (= 1.3.19-2); however:
  Package metalayer-crawler0 is not configured yet.
dpkg: error processing osso-software-version-rx44 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 mediaplayer-daemon
 libmediaplayer0
 mce
 metalayer-crawler0
 osso-software-version-rx44
E: Sub-process /usr/bin/dpkg returned an error code (1)
Each of the packages couldn't update because of the previous one. By shutting off all of them I was able to complete the final update of osso-software-version-rx44.

Code:
$ /etc/init.d/mediaplayer-daemon stop
$ /etc/init.d/libmediaplayer0 stop
$ /etc/init.d/mce stop
$ /etc/init.d/metalayer-crawler0 stop
$ sudo dpkg --configure -a
Afterwards I turned them all back on & rebooted.
Code:
$ /etc/init.d/mediaplayer-daemon start
$ /etc/init.d/libmediaplayer0 start
$ /etc/init.d/mce start
$ /etc/init.d/metalayer-crawler0 start
$ sudo /sbin/reboot
HTH
__________________
GROG!
N900 | ZAGG Body Armour | 16Gb A-DATA micro-sd
N810 | 2 x Patriot 8gb mini-SD | Boxwave Crystal Clear SS | Black Aluminum case | OTG dongle
N800 | 2 x 8gb OCX SD | Boxwave Anti-glare SS | PDAir book-style case
Holux M-1200 bluetooth GPS | iGo 4-row bluetooth keyboard | Linksys USB 10/100 ethernet | Plantronics Voyager 855 BT Headset
 

The Following User Says Thank You to grog For This Useful Post:
Posts: 609 | Thanked: 232 times | Joined on Dec 2007 @ the end of my rope
#23
Thanks for that.

I suppose I'm not helping myself by reinstalling sliderotate kernel after updating OS. This seems to send 43-7 back into "broken" status. Has anyone compiled a 43-7 kernel with rotation yet?

EDIT: Found my answer. Will have to wait until after the holidays.

Last edited by lm2; 12-29-2008 at 08:37 PM.
 
tz1's Avatar
Posts: 716 | Thanked: 236 times | Joined on Dec 2007
#24
If you are using a replacement for "ls", remove it. "ls -Q" from xterm should return a complaint message (needed for invoke-rc.d to run - notice how it is listed as the problem in the log output?). If it returns a list of quoted filenames, it will break the upgrade (and you should remove and reset ls so that it uses the busybox version).
 
Reply

Thread Tools

 
Forum Jump


All times are GMT -4. The time now is 08:16 PM.