Reply
Thread Tools
Posts: 2 | Thanked: 0 times | Joined on Mar 2009
#1
Hi all,

Subject pretty much sums it up. When I attempt to connect to an 802.11 access point, I'm able to see available networks, but attempting to connect results in the oh-so-informative "Network connection error. Try again?" message.

I've tried flashing to various OS revisions, and the problem has manifested on all so far (currently I'm on the Diablo 5.2008.43-7 image). I did notice some threads indicating that some people found success in adjusting the power saving setting to intermediate, but I've tried all three to no avail. Assigning the connection a static IP hasn't made any difference either.

I've tried at least three different models of wireless router, and am currently using a Linksys WRT54G with DD-WRT firmware.

The wireless did actually work for a while after I got the N800, but since it started doing this I've had no luck connecting to any access point whatsoever.

It's (fortunately) not out of warranty yet, but I thought I'd check in here to see if anyone might be able to think of something I'd missed.

Thanks in advance for any suggestions.

Update:
Here's a syslog snippet from an attempted connection -- for this attempt I was using WEP, a statically assigned IP, and intermediate power saving mode.

Code:
Mar  4 00:49:56 Nokia-N800-43-7 wlancond 1.3.10[1110]: AP (12) is derf, rssi:-43 channel:6 cap:00000021
Mar  4 00:49:56 Nokia-N800-43-7 wlancond 1.3.10[1110]: AP (13) is Trident Cafe, rssi:-71 channel:6 cap:70000141
Mar  4 00:49:56 Nokia-N800-43-7 wlancond 1.3.10[1110]: AP (14) is , rssi:-88 channel:4 cap:70000141
Mar  4 00:49:56 Nokia-N800-43-7 wlancond 1.3.10[1110]: Wlancond scan change, old_state: SCANNING, new_state: SCAN_IDLE
Mar  4 00:49:56 Nokia-N800-43-7 icd2 0.67[1114]: WLAN: Results received while not expecting them, ignored.
Mar  4 00:49:56 Nokia-N800-43-7 wlancond 1.3.10[1110]: Delaying interface shutdown
Mar  4 00:49:56 Nokia-N800-43-7 wlancond 1.3.10[1110]: Already delaying...
Mar  4 00:49:56 Nokia-N800-43-7 wlancond 1.3.10[1110]: Wlancond state change, old_state: WLAN_INITIALIZED_FOR_SCAN, new_state: WLAN_NOT_INITIALIZED
Mar  4 00:49:56 Nokia-N800-43-7 wlancond 1.3.10[1110]: Received settings_and_connect
Mar  4 00:49:56 Nokia-N800-43-7 wlancond 1.3.10[1110]: Wlancond state change, old_state: WLAN_NOT_INITIALIZED, new_state: WLAN_INITIALIZED
Mar  4 00:49:56 Nokia-N800-43-7 wlancond 1.3.10[1110]: Powersave minimum
Mar  4 00:49:56 Nokia-N800-43-7 wlancond 1.3.10[1110]: Encryption setting: 00000020
Mar  4 00:49:56 Nokia-N800-43-7 wlancond 1.3.10[1110]: WEP enabled
Mar  4 00:49:56 Nokia-N800-43-7 wlancond 1.3.10[1110]: Default key: 1
Mar  4 00:49:57 Nokia-N800-43-7 kernel: [  773.164062] EAC mode: play disabled, rec disabled
Mar  4 00:50:04 Nokia-N800-43-7 icd2 0.67[1114]: WLAN: WLAN active scan has been running for too long; killing it.
Mar  4 00:50:04 Nokia-N800-43-7 icd2 0.67[1114]: scan results returned from 'libicd_network_wlan.so', but no scan ongoing
Mar  4 00:50:05 Nokia-N800-43-7 icd2 0.67[1114]: module 'libicd_network_wlan.so' has no listeners, scan not restarted
Mar  4 00:50:06 Nokia-N800-43-7 wlancond 1.3.10[1110]: Association timeout
Mar  4 00:50:06 Nokia-N800-43-7 kernel: [  782.000000] cx3110x: shut down softmac.
Mar  4 00:50:06 Nokia-N800-43-7 wlancond 1.3.10[1110]: wlan0 is DOWN
Mar  4 00:50:06 Nokia-N800-43-7 icd2 0.67[1114]: WLAN: [wlan0] Disassociated from network "cb5e84d3-b51f-4964-b1f2-dc672e18f11d"
Mar  4 00:50:06 Nokia-N800-43-7 icd2 0.67[1114]: WLAN: [cb5e84d3-b51f-4964-b1f2-dc672e18f11d] Removing association timer because of disconnect (111)
Mar  4 00:50:06 Nokia-N800-43-7 icd2 0.67[1114]: WLAN: [wlan0] calling link up failure for "cb5e84d3-b51f-4964-b1f2-dc672e18f11d", up=0xe139
Mar  4 00:50:06 Nokia-N800-43-7 icd2 0.67[1114]: iap 0x2ed28 link_up callback did not set interface 'wlan0'
Mar  4 00:50:06 Nokia-N800-43-7 icd2 0.67[1114]: iap 0x2ed28 callback in state ICD_IAP_STATE_LINK_UP with status 3, error '(null)', interface '(null)'
Mar  4 00:50:06 Nokia-N800-43-7 icd2 0.67[1114]: IAP reports error, but error string NULL, set to 'com.nokia.icd.error.network_error'
Mar  4 00:50:06 Nokia-N800-43-7 icd2 0.67[1114]: no more link_down functions to call
Mar  4 00:50:06 Nokia-N800-43-7 icd2 0.67[1114]: no env vars for post-down script
Mar  4 00:50:06 Nokia-N800-43-7 icd2 0.67[1607]: running post-down scripts in /etc/network/if-post-down.d, setting following env:
Mar  4 00:50:06 Nokia-N800-43-7 icd2 0.67[1607]: MODE=stop
Mar  4 00:50:06 Nokia-N800-43-7 icd2 0.67[1607]: PHASE=post-down
Mar  4 00:50:06 Nokia-N800-43-7 icd2 0.67[1114]: script timeout value not set, using default 15s
Mar  4 00:50:06 Nokia-N800-43-7 icd2 0.67[1114]: WLAN: 2021: state CONNECTING (1) -> IDLE (0)
Mar  4 00:50:06 Nokia-N800-43-7 icd2 0.67[1607]: VERBOSITY=0
Mar  4 00:50:06 Nokia-N800-43-7 icd2 0.67[1607]: PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
Mar  4 00:50:06 Nokia-N800-43-7 icd2 0.67[1607]: ICD_CONNECTION_ID=cb5e84d3-b51f-4964-b1f2-dc672e18f11d
Mar  4 00:50:06 Nokia-N800-43-7 icd2 0.67[1607]: ICD_CONNECTION_TYPE=WLAN_INFRA
Mar  4 00:50:06 Nokia-N800-43-7 wlancond 1.3.10[1110]: Wlancond state change, old_state: WLAN_INITIALIZED, new_state: WLAN_NOT_INITIALIZED
Mar  4 00:50:06 Nokia-N800-43-7 icd2 0.67[1114]: signal received: Child exited
Mar  4 00:50:06 Nokia-N800-43-7 icd2 0.67[1114]: pid 1607 has exited with status 256
Mar  4 00:50:06 Nokia-N800-43-7 icd2 0.67[1114]: script cb 0xd511 with pid 1607, exit value 256, user data 0x2ed28
Mar  4 00:50:06 Nokia-N800-43-7 icd2 0.67[1114]: iap disconnected, error is 'com.nokia.icd.error.network_error'
Mar  4 00:50:06 Nokia-N800-43-7 icd2 0.67[1114]: IAP status is ICD_IAP_FAILED
In particular, this bit looks to be where it gives up and dies:

Mar 4 00:50:04 Nokia-N800-43-7 icd2 0.67[1114]: WLAN: WLAN active scan has been running for too long; killing it.
Mar 4 00:50:04 Nokia-N800-43-7 icd2 0.67[1114]: scan results returned from 'libicd_network_wlan.so', but no scan ongoing
Mar 4 00:50:05 Nokia-N800-43-7 icd2 0.67[1114]: module 'libicd_network_wlan.so' has no listeners, scan not restarted
Mar 4 00:50:06 Nokia-N800-43-7 wlancond 1.3.10[1110]: Association timeout
Mar 4 00:50:06 Nokia-N800-43-7 kernel: [ 782.000000] cx3110x: shut down softmac.
Mar 4 00:50:06 Nokia-N800-43-7 wlancond 1.3.10[1110]: wlan0 is DOWN
Mar 4 00:50:06 Nokia-N800-43-7 icd2 0.67[1114]: WLAN: [wlan0] Disassociated from network "cb5e84d3-b51f-4964-b1f2-dc672e18f11d"
Mar 4 00:50:06 Nokia-N800-43-7 icd2 0.67[1114]: WLAN: [cb5e84d3-b51f-4964-b1f2-dc672e18f11d] Removing association timer because of disconnect (111)
Mar 4 00:50:06 Nokia-N800-43-7 icd2 0.67[1114]: WLAN: [wlan0] calling link up failure for "cb5e84d3-b51f-4964-b1f2-dc672e18f11d", up=0xe139
Mar 4 00:50:06 Nokia-N800-43-7 icd2 0.67[1114]: iap 0x2ed28 link_up callback did not set interface 'wlan0'
Mar 4 00:50:06 Nokia-N800-43-7 icd2 0.67[1114]: iap 0x2ed28 callback in state ICD_IAP_STATE_LINK_UP with status 3, error '(null)', interface '(null)'
Mar 4 00:50:06 Nokia-N800-43-7 icd2 0.67[1114]: IAP reports error, but error string NULL, set to 'com.nokia.icd.error.network_error'
Mar 4 00:50:06 Nokia-N800-43-7 icd2 0.67[1114]: no more link_down functions to call


Can anyone offer any advice? It looks like it's just timing out.. is it possible that this is a hardware issue, given that the radio itself obviously does work? (since it can see that there are access points available)

I'm stumped.

Last edited by Derf; 03-05-2009 at 01:16 AM. Reason: Updated information
 
Posts: 1 | Thanked: 0 times | Joined on Mar 2009
#2
I am a newbie with exact the same problem. Have you found a solution?
 
Posts: 251 | Thanked: 22 times | Joined on Dec 2007 @ Houston, Texas
#3
I've been having some problems, too. I have two WAPs with WPA2/PSK so I have full signal availability throughout my house, but every other time it seems like the N800 can't seem to get connected.

Another recent problem is that after charging, some of my tray icons disappear. I'm wondering if there's a flakey application (omweather, advanced backlight, large-status-bar clock, load-applet, maemo-control, maemo-control-services, maemo-control-usb) or something?

** UPDATE ***

Summary: WiFi repeatedly won't connect and times out on N800 with Diablo (latest).

Suspicions: I think that the WiFi connection status is left in an indeterminate state by one or more applications and doesn't get reset properly.

Why do I suspect this? WiFi connection is fast and immediate after fresh reboot. If I set mode to OFFLINE and then change to ONLINE, connection is fast and immediate. Therefore I think that selecting Disconnect at the end of my normal browsing sessions doesn't clear or reset some variables somewhere.

Anyone else with observations on this behavior?

Last edited by rdcinhou; 03-30-2009 at 06:55 AM. Reason: Update on problem
 
Reply

Thread Tools

 
Forum Jump


All times are GMT -4. The time now is 02:39 PM.