Notices


Reply
Thread Tools
Posts: 18 | Thanked: 22 times | Joined on Jan 2010
#1
When I try to update to PR1.3 this message is displayed:
"Für die Installation dieser Maemo-Aktualisierung ist die Nokia PC Suite auf Ihrem PC erforderlich"
= PC-Suite required for update.

But I could not find any PC-Suite for my Gentoo Linux. How can I update my N900?

Last edited by Yminus; 2010-10-25 at 21:22.
 

The Following User Says Thank You to Yminus For This Useful Post:
chemist's Avatar
Administrator | Posts: 1,035 | Thanked: 2,004 times | Joined on Sep 2009 @ Germany
#2
Check if you got libgls1-sgx-img or libqt4-test, those packages brake the upgrade so it is held back.

Games like gltron or tuxracer use them.

Zu deutsch du hast eine oder beide libs installiert und die sind nicht compatibel mit dem upgrade. Also deinstallier sie.
 

The Following 2 Users Say Thank You to chemist For This Useful Post:
kinggo's Avatar
Posts: 606 | Thanked: 1,471 times | Joined on Jun 2010 @ Zagreb
#3
you don't need it. Chek your details within your HAM and you'll see which packages makes conflict with update. Remove them firs and try again.
 
Posts: 163 | Thanked: 175 times | Joined on Dec 2007 @ Alabama
#4
You can either grab the latest image from http://http://tablets-dev.nokia.com/nokia_N900.php and flash it using the flasher (backup first).

You can use the terminal with root and "apt-get dist-upgrade"

Otherwise your gonna have to find a windows machine, install nokia ovi suite(not pc suite, because it won't support phone software upgrades, thanks nokia) and upgrade using that
__________________
Hi! I'm a Maemo Greeter!

Useful links for newcomers: New members say hello , New users start here, Community subforum, Beginners' wiki page, Maemo5 101, Frequently Asked Questions (FAQ)

If I can help with anything else, just ask!
 
maluka's Avatar
Posts: 741 | Thanked: 896 times | Joined on Nov 2007 @ Auckland NZ
#5
This has greatly frustrated me over the last few years. One of the reasons why Nokia's recent Qt announcement was exciting was because they finally said they would be building their own tools using Qt so a Linux OVI suite could be a reality within a year perhaps. It wouldn't make sense for them to sell Linux computers and not have desktop software to support it after all.
 

The Following User Says Thank You to maluka For This Useful Post:
Posts: 18 | Thanked: 22 times | Joined on Jan 2010
#6
Originally Posted by chemist View Post
Check if you got libgls1-sgx-img or libqt4-test, those packages brake the upgrade so it is held back.

Games like gltron or tuxracer use them.
I had gltron installed - after uninstalling it, upgrade works.
Thanks - your reply was faster then the maemo.org webserver
 
mikecomputing's Avatar
Posts: 3,380 | Thanked: 4,647 times | Joined on Feb 2010 @ Gothenburg in Sweden
#7
Originally Posted by bdogg64 View Post
You can either grab the latest image from http://http://tablets-dev.nokia.com/nokia_N900.php and flash it using the flasher (backup first).

You can use the terminal with root and "apt-get dist-upgrade"

Otherwise your gonna have to find a windows machine, install nokia ovi suite(not pc suite, because it won't support phone software upgrades, thanks nokia) and upgrade using that
no no no apt-get dist-upgrade ****s up everything it will start to remove alot libs and breks. Dont ask me why but it.does :S

BUT apt-get upgrade seems to work but not 100 percent it will upgrade everything... just checked and qt and latest kernel is there not know what more got upgraded with that command...
 
Posts: 93 | Thanked: 29 times | Joined on Oct 2007 @ Glendale, CA
#8
frogatto also depends on libgles1. I did an "apt-get remove libgles1-sgx-img" in an xterm and then I was able to do the OTA upgrade to PR 1.3. I then install frogatto and it runs fine as far as I can tell.
 
chemist's Avatar
Administrator | Posts: 1,035 | Thanked: 2,004 times | Joined on Sep 2009 @ Germany
#9
Originally Posted by bdogg64 View Post
You can use the terminal with root and "apt-get dist-upgrade"
that is a realy bad idea with devel, testing or sdk repos active

one of the packages uninstalls alot of the systemUI and if there are packages held back they wont get installed again and you end up in a watchdog cycle, even if you do an apt-get upgrade and proceed with held back packages...
 

The Following User Says Thank You to chemist For This Useful Post:
Posts: 249 | Thanked: 45 times | Joined on Apr 2010
#10
How do we check which app use which package?
thanks
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 07:36.